Jump to content
The simFlight Network Forums

FSUIPC will not start after BIOS update fs9&X

Recommended Posts

Hello Peter, first I want to tell you that I have been using FSUIPC & FSWide since 2002 and have had literally no problems with it until now. I am running both 2004 and FSX on the same computer. Everything was running fine with my simulator communicating with other PC’s running Project Magenta, FSCommander and Elite Throttle Quadrant, EzScenery, Squakbox and Wide Viewit until I attempted to update by BIOS.

I am running a AMD DUAL core processor on a ASUS A8N-32 SLI Deluxe Board with a 939 Socket. I have a Ge force 7950 GX2 PCI Card installed with 1 GB of Memory. I also have 2 GB of Ram installed. I am a licensed user of FSUIPC and WIDEFS.

I updaed the Bios from 1205 – 1405. The update went fine, backed up the old BIOS just in case and all seemed fine until I tried to connect via FSUIPC. Nothing and I mean nothing that needs FSUIPC works because in both FS9 and FSX FSUIPC will not initialize. In FS9 when I attempt to load a flight I get an error from Squakbox saying it can’t find FSUIPC. When I install Elite drivers Elite does not appear on the menu until I update to FSUIPC 3.7.5. And when I click on Elite to setup the Throttle Quadrant Elite says “Waiting for FSUIPC”. FSUIPC is there I can select it and change its setting but it just won’t start. In FSX ELITE and FSUIPC are there but nothing works, that needs FSUIPC. I have installed the latest version FSX reinstalled it several times to no avail.

Next I decided to go back to the old BIOS 1205 and to make a long story short, after reinstalling all the proper drivers and even doing a restore, I still can not get FSUIPC to start. I have checked my CMOS startup setting and nothing in this seems to be related to this problem.

I am going to next try uninstalling or as I read in one of your post, renaming Squakbox3 and other programs that are looking for FSUIPC and then try starting FS9 and then FSX. On a side note, I am also having an issue with FSX in that I can not get the TOOLS option to appear on my menu and I have asked MS support to help solve this problem. There appears that there is something weird going on with the dll.xml file in Documents…..FSX folder. For example when I install Elite FSX drivers/software it wipes out the XML file except for the FSUIPC entries and Elite. I have had to reconstruct the XML file and add Elite parameters to it manually. I will send these files to you if you think the problems are related. I have reached the limit of my ability and desperately need some guidance here. In the mean time I will continue to try to resolve this issue in the manner so stated above. Also FSUIPC does come up as registered.


Link to comment
Share on other sites

Update on the problem:

1. I have FSUIPC running in FSX the problem is now narrowed to ELite Throttle Quad, I need to select a different USB port and I think it will work. Elite is found in FSX and I can Calibrate select the setting but Throttles do not work with Aircraft in simulation.

ProjectMagenta is working and WideFS connects of course.

2. The problem with FS9 remains. I removed Squakebox and Elite. WideFS connects to two different computers But project magenta does not connect on either one. Problem is with FSUIPC it is not Initializing for some reason. Below is the log file from the last run of FS9

********* FSUIPC, Version 3.75 by Pete Dowson *********

Running on Windows Version 5.1 Build 2600 Service Pack 2

Verifying Certificate for "C:\Program Files\Microsoft Games\Flight Simulator 9\MODULES\FSUIPC.dll" now ...

SUCCESS! Signature verifies okay!

Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)

User Name="John Abent"

User Addr="J.Abent@mchsi.com"

FSUIPC Key is provided

WideFS Key is provided

Module base=61000000



InitDelay: 0 seconds




7640 System time = 03:48:25

7640 \\FLIFGT-SIM-1\Flight Simulator 9\

7656 System time = 03:48:25, FS2004 time = 12:00:00 (00:00Z)

53484 C:\Documents and Settings\Windows XP\My Documents\Flight Simulator Files\Reading Takeoff with BT-25.flt

53515 AIRCRAFT\B-25J Briefing Time\B-25_BT.air

53656 Aircraft="B-25J Briefing Time"

59547 C:\Documents and Settings\Windows XP\My Documents\Flight Simulator Files\UI generated flight.flt

59984 Clear All Weather requested: external weather discarded

83390 Advanced Weather Interface Enabled

92593 WeatherOptions set, now 40003605 (timer=0)

138093 System time = 03:50:35, FS2004 time = 14:15:00 (18:15Z)

138093 *** FSUIPC log file being closed

Memory managed: 0 Allocs, 222 Freed

********* FSUIPC Log file closed *** *******

3. I have no idea why this is happening. I have again reinstalled FSUIPC and WIDEFS for 2004.


1. Why won't FSUIPC start in 2004?

2. Why won't Elite work in FSX? Might be the USB port I am using off the front of the computer. I had this problem once before where one USB port would work while other ports did not. My problem is I have no other USB ports left but the two front ports. Goflight and yokestake up the rest of the main rear ports. I will install another USB card to see if this solves my problem with FSX. Other ideas will be welcomed.Send comments to John at j.abent@mchsi.com

Link to comment
Share on other sites

2. The problem with FS9 remains. I removed Squakebox and Elite. WideFS connects to two different computers But project magenta does not connect on either one. Problem is with FSUIPC it is not Initializing for some reason. Below is the log file from the last run of FS9

One or other of your FSUIPC or WideFS keys for FS9 is invalid. If you want me to check them, Zip up the FSUIPC.KEY file and send it to me at petedowson@btconnect.com.

2. Why won't Elite work in FSX?

Sorry, I've no idea about that one. Do they have an update for FSX? Best check with Elite support.



Link to comment
Share on other sites

:oops: Mystery solved thanks to Peter. It turns out that my problem with both FS9 and FSX was with my system clock. It turns out that when I updated my system BIOS I failed to update my system clock. It was set for the year 2002. It turns out that FSUIPC reads the system clock when validating the registration and since the clock was before the date of registration it came back as invalid and would not initialize. I didn't notice this until I began looking at the dates my system was giving to downloaded files. :lol:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.