Jump to content
The simFlight Network Forums

Saitek throttle axis suddenly gone haywire

Recommended Posts


I suspect this is a hardware issue, but I have to rule everything out:

On my Saitek Pro Flight Throttle I have all axes mapped through FSUIPC and it worked fine up till a few days ago.

Now one of the axes gives the following values : it starts at 16383 and goes down till 0 halfway but then shoots back up to 16383 and ends at 6016. The numbers never turn negative.I can calibrate all I want (b.t.w. the option to calibrate under windows has disappeared from the game controller applet, is this normal ?)

Do I have to buy a new throttle or is there a setting I have overlooked ?

Thanks for your help


Link to comment
Share on other sites

There was a known hardware fault with the early batches of Saitek Yokes and Throttles. I was one of the victims but mine's been perfect since I sent it back for repair (took a couple of weeks, I think they replaced a dodgy chip or something, they were very vague!).

Check to see if it goes crazy when it's plugged directly into FlightSim (in other words forget about FSUIPC for now and map the throttle and joystick using the FSX controls dialog). If you still get the problem I suggest you check out the Saitek forums and phone their tech support line. Between those two you should find everything you need to solve your problem. Good luck!


Link to comment
Share on other sites

  • 2 weeks later...

also happens when your fsuipc.ini goes corrupted / and you cannot see this, its on a bit level somehow (with me at least)

rename you fsuipc.ini to anything

restart FSX, see if still happens

if ok, you have to setup a new FSuipc.ini (you can copy/paste to a new FSuipc.ini, copy/paste will clean out bad bits)

if not, well its something else then :)

Link to comment
Share on other sites

Thank you guys, I already contacted the Saitek distributor and they told me to send my yoke and throttle back to them for replacement.

Pretty decent since I didn't have the receipt anymore nor the box it came in.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.