Jump to content
The simFlight Network Forums

Help needed with connecting FSUIPC and WideFS


Recommended Posts

Hi. I just can't seem to get this working. I've got 2 computers, one runne vista x64, and the other one running xp x32. The vista computer is the server.

No matter what I do, I just can't get the two pc's to connect, even though they are on a good, stable network, they can ping eachother fine, and i've disabled every firewall.

But still no luck. WideClient just says - Waiting for a connection. I've got the newest FSUIPC (4.40) and the newest WideClient (6.75)... What can I do to fix this problem?

WideServer.log:

********* WideServer.DLL Log [version 7.40] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 24/11/08, Time 21:33:42.920: Server name is JOACHIMS-PC

15974 Initialising TCP/IP server

15974 Initialising IPX/SPX server

15974 IPX/SPX socket() failed [Error=10044] Socket type not supported

15974 Failed to start IPX/SPX Server

15974 Initialising UDP/IP server

16130 Broadcasting service every 1000 mSecs

1307210 Closing down now ...

Memory managed: Offset records: 562 alloc, 561 free

Read buffer usage: 0 alloc, 0 free, max in session: 0

Write buffer usage: 0 alloc, 0 free, max in session: 0

Throughput maximum achieved: 0 frames/sec, 0 bytes/sec

Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec

********* Log file closed *********

WideClient.log:

********* WideClient Log [version 6.75] Class=FS98MAIN *********

Date (dmy): 24/11/08, Time 21:48:32.724: Client name is C840

1593 Attempting to connect now

2594 Trying to locate server: Need details from Server Broadcast

2594 Failed to connect: waiting to try again

4597 Attempting to connect now

68699 Trying to locate server: Need details from Server Broadcast

1205043 ****** End of session performance summary ******

1205043 Total time connected = 0 seconds

1205043 Reception maximum: 0 frames/sec, 0 bytes/sec

1205043 Transmission maximum: 0 frames/sec, 0 bytes/sec

1205043 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

1205043 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

Link to comment
Share on other sites

No matter what I do, I just can't get the two pc's to connect, even though they are on a good, stable network, they can ping eachother fine, and i've disabled every firewall.

Every firewall? How many did you have?

But still no luck. WideClient just says - Waiting for a connection. I've got the newest FSUIPC (4.40) and the newest WideClient (6.75)...

Well, almost. The current official release of Wideclient is 6.78, and has been for a couple of weeks or so. There's also a later one in the Announcements above. But no matter, the differences won't affect this.

The logs show that the Broadcasts from the Server are not reaching the Client. This is usually because you have the two computers in different WorkGroups. Make sure you name the workgroup the same in both machines. After all, you want them to work together, no? Working together should mean they are both in the same group. See?

Alternatively, but not the best solution, you can do as the documentation suggests (you didn't think of looking there at all, perhaps?), and that is: add parameters to the WideClient INI to tell it the name of the Server and the Protocol you want to use. This obviates the need for the computers to be on the same workgroup -- but it isn't the best way to do it.

Regards

Pete

Link to comment
Share on other sites

Well, I've read the documentation thoroughly before posting this post, and yes, the computers are in the same workgroup.

But still, no luck.

I've disabled our three firewalls:

-The one on the server

-The one on the client

-The internal firewall on our router

I've also tried to add my ServerIPAddr and protocol type to the WideClient.ini , but it still doesn't work

Link to comment
Share on other sites

Well, I've read the documentation thoroughly before posting this post, and yes, the computers are in the same workgroup. But still, no luck.

Well if the client log hasn't changed since the last one you posted, the broadcasts from the server still aren't reaching the client. For an otherwise working network the only cause of that I'm aware of is that they are in different workgroups.

I've disabled our three firewalls:

-The one on the server

-The one on the client

-The internal firewall on our router

You have an INTERNAL firewall on a router? Phew. Never heard of one of those.

I've also tried to add my ServerIPAddr and protocol type to the WideClient.ini , but it still doesn't work

Why use the Server IP address? Use the ServerName -- it is much easier and more flexible, in case your server IP address changes (or is masked by your very clever sounding router).

If that doesn't work then I'm sorry but you will need some expert help from someone who knows about Networks. There's absolutely nothing special or clever about how WideFS uses the network, it is a direct copy of Microsoft examples. You do actually need to have a working network first. Evidently at present neither port 9002 (for Broadcasts) nor 8002 (for data exchanges) can connect between the two PCs. I assume you have other networking needs sorted?

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.