Jump to content
The simFlight Network Forums

Installer For FSUIPC.DLL Ver 4.20


Recommended Posts

Good morning Mr, Dowson,

I have searched and reviewed prior posts; however I am still lost to the answer and fix to this problem.

Due to some glitchy FSX I recently did a full delete, DEFRAG and re-install of FSX and Acceleration. I attempted to install FSUIPC 4 and received the following:

Your FSX installation is incorrect! The version of SimConnect installed will not load FSUIPC4. You may need to repair the FSX installation to rectify this first.

No changes have been made by this program.

Installer for FSUIPC4.DLL version 4.20

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

SetupPath="C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\"

Checking version of FSX.EXE:

... Version 10.0.61637.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match a valid base SimConnect needed to load FSUIPC4!

Found later build SimConnect 61242 (SP1 May07)

Found later build SimConnect 61259 (Acc/SP2 Oct07)

*** PLEASE SIR AND HELP IS GRATEFULLY APPRECIATED :)

Link to comment
Share on other sites

Due to some glitchy FSX I recently did a full delete, DEFRAG and re-install of FSX and Acceleration.

Ouch! That's one of the main cause of really bad SimConnect problems. It is not actually possible to properly uninstall the shared libraries for SimConnect, so when you reinstall it makes rather a hash of things. I hope Windows 7 sorts this out, but as it doesn't appear to be a problem for programs with proper uninstallers I suppose the Windows guys would blame the FSX uninstaller for being deficient.

Installer for FSUIPC4.DLL version 4.20

Version 4.20 is pretty old now and certainly not supported. Please refer to the Announcements above for details of supported versions and get yourself updated.

You will probably still get the same error with 4.40. Really you will at some time need to repair your SimConnect installation (the FSX Help Announcement gives some guidance there), but it is really messy and you may end up having to re-install Windows too. However, because of some changes I've had to make to FSUIPC4 to make it work on ESP as well, after installing 4.40, the latest Update (4.435) from the Updates Announcement above may just manage to work on your messed-up installation. Other SimConnect clients may not, however.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.