Jump to content
The simFlight Network Forums

some keys not programming

Recommended Posts

i have windows vista & am running fs2004 with the saitek yoke. yesterday as i was attempting to program keys for a caravan using fsuipc. i was trying to designate the #7 button to control left rudder trim & the #8 button to control right rudder trim. this programing was successful for a few minutes. for some unknown reason, the #7 button quit working & began displaying the electronic kneepad each time the #7 button was pushed. the electronic kneepad is normaly activated by the F10 key. at the same time, the #8 button quit functioning, so now i have no rudder trim control. i then went to a different aircraft & tried the #7 button where again there was no rudder movement, only the electronic kneepad displayed. i then went to a pmdg aircraft & the same thing happend again.

today i tried uninstalling & reinstalling fs2004 only to be met with the same result. i have the same programs set up on a laptop where the buttom commands perform their intended function. (the problem is occuring on a desktop). this makes me think that something has been programmed somehow internally onto the computer. has anyone else had this problem? can anything be done to reprogram the settings?

update! i guess this post can be disregarded. it took me a few days but i just learned the hard way that fs2004 WILL revert back to its own control setting, bypassing the fsuipc all together. my controls were run by fs2004 just as the users guide said.

Link to comment
Share on other sites

When you first plug any yoke into FS it will have some controls assigned by default. You need to go into FS settings/assignments and remove them if you want to use FSUIPC to assign controls. You can also get problems if you use the yoke's own software to assign controls. I use CH equipment and find the best result is to NOT instal the CH software at all, and program everything through FSUIPC, including things like hat views. I then use the FS option "disconnect joystick" That way I never get conflicting commands.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.