Jump to content
The simFlight Network Forums

SimConnect


Recommended Posts

Hello,

When trying to install FSUIPC, I get the error in the attatched image. I realise that my simconnect version isn't up to date, however I can see no way of fixing it. I've tried uninstalling/reinstalling FSX several times and nothing works. Please help because I can't even use Active Sky which i suffering from the same problem obviously because SimConnect is out of date.

post-35184-128689689078_thumb.jpg

Link to comment
Share on other sites

When trying to install FSUIPC, I get the error in the attatched image. I realise that my simconnect version isn't up to date, however I can see no way of fixing it. I've tried uninstalling/reinstalling FSX several times and nothing works. Please help because I can't even use Active Sky which i suffering from the same problem obviously because SimConnect is out of date.

It isn't just that your SimConnect is out of date, but you have no working SimConnect installation at all. FSUIPC4.5xx can operate with any of the three versions of SimConnect, but chooses the most recent if it is available as that is the most efficient and error-free.

Uninstalling and re-installing FSX actually makes things worse unless when uninstalling you take great care to remove the SimConnect parts too, separately. It's a problem with the uninstaller which doesn't actually remove the SimConnect libraries, so the installer then doesn't get to repair them when they are broken.

Your FSX.EXE version number (61472) seems like the SP2 version (not Acceleration). Is that correct? If so, then you could probably get FSUIPC4 installed correctly by deleting only one folder then re-installing SP2. However, that would still leave other programs, needing the SP1 or base versions high and dry.

So, I suggest that you start from scratch. Uninstall SP2, SP1 and FSX, in that order. THEN delete the three SimConnect folders from the Windows\WinSxS folder. Information about deleting the folders can be found in the Announcement at the top of this forum entitled "FSX HELP: Logging or Re-installing SimConnect".

Then install FSX, run it to test, then SP1, run it, then SP2. Folks do advise running it once between each update, else the requisite files may not get created/updated.

Regards

Pete

Link to comment
Share on other sites

When trying to install FSUIPC, I get the error in the attatched image. I realise that my simconnect version isn't up to date, however I can see no way of fixing it. I've tried uninstalling/reinstalling FSX several times and nothing works. Please help because I can't even use Active Sky which i suffering from the same problem obviously because SimConnect is out of date.

It isn't just that your SimConnect is out of date, but you have no working SimConnect installation at all. FSUIPC4.5xx can operate with any of the three versions of SimConnect, but chooses the most recent if it is available as that is the most efficient and error-free.

Uninstalling and re-installing FSX actually makes things worse unless when uninstalling you take great care to remove the SimConnect parts too, separately. It's a problem with the uninstaller which doesn't actually remove the SimConnect libraries, so the installer then doesn't get to repair them when they are broken.

Your FSX.EXE version number (61472) seems like the SP2 version (not Acceleration). Is that correct? If so, then you could probably get FSUIPC4 installed correctly by deleting only one folder then re-installing SP2. However, that would still leave other programs, needing the SP1 or base versions high and dry.

So, I suggest that you start from scratch. Uninstall SP2, SP1 and FSX, in that order. THEN delete the three SimConnect folders from the Windows\WinSxS folder. Information about deleting the folders can be found in the Announcement at the top of this forum entitled "FSX HELP: Logging or Re-installing SimConnect".

Then install FSX, run it to test, then SP1, run it, then SP2. Folks do advise running it once between each update, else the requisite files may not get created/updated.

Regards

Pete

Ok thanks for the reply Pete! Much appreciated. The only thing is in the AddRemove programs section, even with Show Updates checked, SP1 nor FSX is there. Only FSX SP2 is there. Obviously I can uninstall SP2 via the control panel and FSX via the discs, but there would be no way to uninstall SP1.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.