Jump to content
The simFlight Network Forums

Wide Client does not communicate to the Wide Server


Recommended Posts

Hi Peter,

Since yesterday, I have a new Internet connection. I have set up my network (with static IPs) and everything works perfect, except Wide FS. Basically, over the network, on any pc, I can read and write on any other pc, each pc connects well to the Internet, however, none of my Wide Clients find the Wide server. I have attached a scheme of my network to this post.

If I disconnect the modem/router however, Wide Client connects immediately. This is very strange, as I have no firewall (not on the pcs, neither on the router). Did you encounter such a case?

Here are my server/client logs. I hope it will help:

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 02/09/09, Time 22:46:26.640: Client name is BOZO6

266 Attempting to connect now

1157 New Client Application: "B737" (Id=1448)

1344 Trying to locate server: Protocol not yet decided

1344 Failed to connect: waiting to try again

3391 Attempting to connect now

67391 Trying to locate server: Protocol not yet decided

442063 ****** End of session performance summary ******

442063 Total time connected = 0 seconds

442063 Reception maximum: 0 frames/sec, 0 bytes/sec

442063 Transmission maximum: 0 frames/sec, 0 bytes/sec

442063 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

442063 **************** Individual client application activity ****************

442063 Client 1448 requests: 775 (Ave 775/sec), Data: 33170 bytes (33170/sec), Average 42 bytes/Process

442063 ********* Log file closed (Buffers: MaxUsed 1, Alloc 775 Freed 775 Refused 0) *********

********* WideServer.DLL Log [version 6.78] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 02/09/09, Time 23:01:47.625: Server name is BOZO1

70344 Initialising TCP/IP server

70344 Initialising IPX/SPX server

70344 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family

70344 Failed to start IPX/SPX Server

70344 Initialising UDP/IP server

72031 Broadcasting service every 1000 mSecs

98453 Restarting service due to total lack of use

98469 Failed to start IPX/SPX Server

121922 Closing down now ...

Memory managed: Offset records: 0 alloc, 0 free

Read buffer usage: 0 alloc, 0 free, max in session: 0

Write buffer usage: 0 alloc, 0 free, max in session: 0

Throughput maximum achieved: 0 frames/sec, 0 bytes/sec

Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec

********* Log file closed *********

I hope you may help me.

I have noticed that one of my drivers, B737, the Cockpitsonic driver (installed also on the FS/server PC), does not indicate the FSUIPC version (it says FSUIPC version unknown), I'm not 100% sure it did before, but I think it did tell the FSUIPC version.

Thank you and best regards,

Thomas.

Configuration:

FS2004

FSUIPC 3.93

WIDE FS 6.78

Project Magenta Softwares

post-35385-128689692973_thumb.jpg

Link to comment
Share on other sites

Since yesterday, I have a new Internet connection. I have set up my network (with static IPs) and everything works perfect, except Wide FS. Basically, over the network, on any pc, I can read and write on any other pc, each pc connects well to the Internet, however, none of my Wide Clients find the Wide server. I have attached a scheme of my network to this post.

If I disconnect the modem/router however, Wide Client connects immediately. This is very strange, as I have no firewall (not on the pcs, neither on the router). Did you encounter such a case?

No, I've never heard of anything like that. It sounds like the router/switch is implementing its own firewall even though you think not. Either that or it is disguising your otherwise "fixed" IP addresses.

The logs show nothing except that neither Server nor Client ever see each other. Have you tried providing explicit parameters in the WideClient.INI to tell it what the Server is? i.e.

ServerName=BOZO1

Protocol=TCP

Regards

Pete

Link to comment
Share on other sites

Hi Pete,

Thanks for your quick reply. Yes, in my configuation, the Wide Clients are even looking for a specific IP (as I am working with static IP's), I also changed this statitc IP to the server name, just in case, no result. In addition, just like it states in your post, I ask them to use the TCP/IP protocol in the INI files.

Rather than a problem in the Router/Switch, I think the problem lies in the router/Modem which might maybe block certain ports against my will even if there is no Firewall enabled. Anyway, for me the problem is more likely in the router/modem than in the router/switch as I tried to replace the router/switch by a conventional switch with no more success. However, if I disconnect the router/modem, so all the pc's communicate directly through the router/switch, then it works fine.

To solve the problem right now, I will use the router/modem just as a modem, connect the internet to the WAN port in the "router/switch" so this device will be a "real router", this should work to my understanding, I will have to connect the home pc to this router aswell to avoid to have two different networks.

However, I will still try to do some tests with my orginal configuartion and try to find the solution to this problem, on your side, if you encounter the same kind of problem with somebody else and you do find a solution, please keep me posted as it would be the easiest and my prefered way of networking all my pc's.

Thank you

Thomas

Luxembourg.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.