Jump to content
The simFlight Network Forums

Tutorial: Connection over a network


Recommended Posts

Just thought I would share these tips for getting WideFS client

to connecto to FSX over a network:

1. Make sure Client and Server are on the same "Network Group".

With Vista, go to "Control Panel/System and Maintenance/System"

and under "Computer Name, Domain and Workgroup Settings/Workgroup"

you will see the name of your workgroup. Again Client and Server

*must* be on the same workgroup else WideFS Client will FAIL to

connect to WideServer, so do check the two workgroups are *exactly*

the same.

2. Use UIPCHello on both Client and Server to make sure WideClient

and WideServer are running properly.

See: viewtopic.php?f=155&t=78663#p478936

Or: download/file.php?id=81503

4. Make sure FSUIPC v. 4.57 is paired with WideClient v. 6.791

(or check p. 1 of the WideFS User Guide if working with different

versions).

5. Both MS-FSX on the Server and WideClient ("FS Eliminator for

FSUIPC client applications") must be listed under Firewall

Exceptions. In Vista, go to "Control Panel/Security" and under

"Windows Firewall" clock on "Allow a program through Windows

Firewall". This will open the window "Windows Firewall Settings"

at the "Exceptions" tab. On the server verify "Microsoft Flight

Simulator" is checked. On the client do the same for "FS Eliminator

for FSUIPC client applications".

6. In FSUIPC.ini must have:

[WideServer]

WideFSenabled=Yes

AdvertiseService=1

Port=8002

Port2=9002

7. FSUIPC4.log must show:

FSUIPC4 Key is provided

WideFS7 Key is provided

8. WideServer.DLL log must show:

Broadcasting service every 1000 mSecs

indicating the server is active.

9. WideClient.log must have:

[Config]

Port=8002

Port2=9002

Window=810,960,470,34

Visible=Yes

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

MailslotTiming=2000,1000

PollInterval=2000

Port2=9002

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

WaitForNewData=500

MaxSendQ=100

OnMaxSendQ=Log

NewSendScanTime=50

Priority=3,1,2

10. WideClient.log must show:

Server =

Trying TCP/IP host "" port 8002 ...

Okay, IP Address =

Connection made okay!

New Client Application: "FSC86" (Id=2076)

11. Once you get your setup working, you can hide the WideFS client

window. In WideClient.ini, change:

[Config]

Visible=Yes

to:

Visible=No

Have fun!

- jahman.

Link to comment
Share on other sites

Just thought I would share these tips for getting WideFS client

to connecto to FSX over a network

Thank you very much.

Some of these aren't necessary. For instance

" FSUIPC4 Key is provided"

isn't needed if you don't want to use FSUIPC's user menus at all. WideFS can be purchased and used without FSUIPC4 being purchased, though I admit it isn't usual.

Whilst it is much easier if Client and Server are in the same workgroup, in some folks' implementations they don't want this for some logistical reason. If they aren't in the same workgroup they can still connect them by supplying ServerName and Protocol in the client INI file. The problem without the same workgroup being used is that the Server's broadcasts, telling client where it is, don't get through as they only broadcast withing the group.

Naturally, with your item 4, any future version of FSUIPC4 would apply too. The current update version is 4.575 already, so it won't be that long till 4.57 is out of date. Maybe an "or later" would be a good idea?

Perhaps, if would like to tidy it up a little, and put your details on it, you wouldn't mind if I turned it into a PDF and put links to it here, or even included it in the WideFS and/or WideClient downloads at some point? If you want to send me anything, use petedowson@btconnect.com.

Thanks again & Best Regards

Pete

Link to comment
Share on other sites

By all means, Pete, consider this tutorial yours to modify and expand as you wish! :-)

In my case, I wasn't able to connect until I got both PCs on the same workgroup, even though I had included the ServerName variable in the client ini file (though I did not include the Protocol=TCP as I don't have IPX so I thought it would default anyway to TCP anyway.)

I do have one of those pesky "3Com Gigabit (LOM)" (3C940) Drivers (v. 1.00.00.0046) LAN drivers that take ages in sharing a resource (like 5 or 1o minutes!) under Win XP (SP3), so I switched to the one called "3Com Gigabit NIC" (same version, not digitally signed, nite the slight difference in the name string).

But what definitely got me going was synchronizing the workgroup names...

Cheers,

- jahman.

Link to comment
Share on other sites

By all means, Pete, consider this tutorial yours to modify and expand as you wish! :-)

Okay. Thanks.

In my case, I wasn't able to connect until I got both PCs on the same workgroup, even though I had included the ServerName variable in the client ini file (though I did not include the Protocol=TCP as I don't have IPX so I thought it would default anyway to TCP anyway.)

No, it needs both parameters if there's no broadcast details. I forget now why I did it like that. I suspect it dates back to the days when IPX was the default.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.