Jump to content
The simFlight Network Forums

Com 3 Not Opening


Recommended Posts

I am using the ERTLOGIC emulator, but suddenly my com port is not opening. I have not added any new hardware, I HAVE added REX and the CS 727: here is my logfile, any ideas

Cathy Howat:

********* FSUIPC4, Version 4.60a by Pete Dowson *********

Reading options from "G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"

Trying to connect to SimConnect Acc/SP2 Oct07 ...

User Name="Catherine Howat"

User Addr="cathyhowat@hotmail.com"

FSUIPC4 Key is provided

WIDEFS7 not user registered, or expired

Running inside FSX on Windows 7 (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=15

46 System time = 05/05/2010 19:43:13

46 FLT UNC path = "C:\Users\User 977\Documents\Flight Simulator X Files\"

46 FS UNC path = "G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"

421 LogOptions=00000000 00000051

421 SimConnect_Open succeeded: waiting to check version okay

7612 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)

7612 Initialising SimConnect data requests now

7612 FSUIPC Menu entry added

7659 Ready Flags: Ready-To-Fly=N, In Menu=Y, In Dlg=Y

7659 G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\FLIGHTS\OTHER\FLTSIM.FLT

7659 G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

72025 Ready Flags: Ready-To-Fly=N, In Menu=N, In Dlg=N

72228 Ready Flags: Ready-To-Fly=Y, In Menu=N, In Dlg=N

72228 VRI port 1 "COM3" failed to open

72587 System time = 05/05/2010 19:44:26, Simulator time = 19:43:20 (02:43Z)

72587 Aircraft="Aircreation582SL red"

73445 Advanced Weather Interface Enabled

76284 Ready Flags: Ready-To-Fly=Y, In Menu=Y, In Dlg=Y

89560 Ready Flags: Ready-To-Fly=Y, In Menu=N, In Dlg=N

91135 Ready Flags: Ready-To-Fly=Y, In Menu=Y, In Dlg=Y

97453 System time = 05/05/2010 19:44:51, Simulator time = 19:43:25 (02:43Z)

97453 *** FSUIPC log file being closed

Average frame rate for running time of 6 secs = 31.5 fps

Memory managed: 6 Allocs, 5 Freed

********* FSUIPC Log file closed ***********

Link to comment
Share on other sites

I am using the ERTLOGIC emulator, but suddenly my com port is not opening. I have not added any new hardware, I HAVE added REX and the CS 727: here is my logfile, any ideas

It will only not open if it doesn't exist, or is already opened by another program.

Are you using a USB-Serial port adapter? If so, have you checked that it is still COM3?

Pete

Link to comment
Share on other sites

Pete, I THINK I've solved the problem. I had speech recognition enabled at startup. I have removed that. I know start up in the following manner. 1) boot, VSPE loads. 2) LOAD REX Textures (but not the Weather Engine) 3) Load FSX default flight. 4) load SP2. 5) Exit default flight, load my flightplan and plane 60 Start REX weather engine. This seems to work, but it is a little cumbersome, any suggestions for streamlining?

Cathy

Link to comment
Share on other sites

Pete, I THINK I've solved the problem. I had speech recognition enabled at startup. I have removed that.

Would that use up a COM port? Don't understand that.

I know start up in the following manner. 1) boot, VSPE loads. 2) LOAD REX Textures (but not the Weather Engine) 3) Load FSX default flight. 4) load SP2. 5) Exit default flight, load my flightplan and plane 60 Start REX weather engine. This seems to work, but it is a little cumbersome, any suggestions for streamlining?

Sorry, I don't understand why you need to do most of that, nor how any of it impinges on COM port availability. And what do you mean by "SP2"? Is that SerialFP2? If so and you were loading that before FSX (or letting FSX load it) then the problem you had might have been merely due to SerialFP2 grabbing the device on COM3 first. You should be starting SerialFP2 using the [Programs] facilities in FSUIPC4.INI, as documented in the VRInsight dox I included. That makes sure FSUIPC4 gets the device first.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.