Jump to content
The simFlight Network Forums

FSUIPC4


Recommended Posts

Hello, I am having problems installing FSUIPC4 for Microsoft Flight Sim X. I have removed and reinstalled FSX and no joy. Here is the message I get

Installer for FSUIPC4.DLL version 4.60a

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

... >>> OK! FOUND FSX! <<< ...

Looking in registry for ESP install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft ESP\1.0

Parameter"SetupPath"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft ESP\1.0

Parameter"AppPath"

... NOT found! ...

===========================================================

INSTALLATION FOR FSX:

AppPath="C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\"

Checking version of FSX.EXE:

... Version 10.0.61637.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match a valid SimConnect needed to use FSUIPC4!

Link to comment
Share on other sites

Hello, I am having problems installing FSUIPC4 for Microsoft Flight Sim X. I have removed and reinstalled FSX and no joy. Here is the message I get

...

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match a valid SimConnect needed to use FSUIPC4!

You have a corrupted SimConnect side-by-side library setup.

Removing and reinstalling FSX often makes that worse, not better, because the uninstall only does a partial job on SimConnect which prevents the installer doing its job correctly.

When you reinstalled, did you install first the base FSX from the CD, then ran it, then SP1, ran it, then SP2 or Acceleration? I think you need to at least run FSX between each stage, unless maybe you are installing the "Gold" version.

You could try running just the SimConnect.msi installers. If you have the DeLuxe or Gold versions of FSX you'll find them in the Toolkit (SDK). Otherwise somewhere on the disk.

Also, you could try the later FSUIPC4 installer, for 4.638, posted in the Download Links subforum. I've changed the way FSUIPC checks for and connects to SimConnect and that may help. It won't solve problems with other Simconnect users though.

Regards

Pete

Link to comment
Share on other sites

  • 2 weeks later...

Hi

I have removed and reinstalled FSX and I can`t connect for example FSA client or offliner to FSX message is FSUIPC Error 12: FSUIPC_ERR_SENDMSG. Error sending message to FSUIPC

I tried deleted entry from dll.xml as you wrote in diferent post. Instaled again, but no results at all. I`m posting logs I believe they`ll tell everything.

WIndows7/x64 FSXdeluxe SP1+SP2

LOG from file FSUIPC.log

********* FSUIPC4, Version 4.60a by Pete Dowson *********

Trying to connect to SimConnect Acc/SP2 Oct07 ...

User Name=""

User Addr=""

FSUIPC4 not user registered

WIDEFS7 not user registered, or expired

Running inside FSX on Windows 7 (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=0

312 System time = 18/02/2011 21:23:07

312 FLT UNC path = "\\NONO-PC\Users\nono\Documents\Flight Simulator X Files\"

312 FS UNC path = "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"

686 LogOptions=00000000 00000001

686 SimConnect_Open succeeded: waiting to check version okay

3400 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

3400 Initialising SimConnect data requests now

3400 FSUIPC Menu entry added

3447 C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\FLIGHTS\OTHER\FLTSIM.FLT

3447 C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

68936 System time = 18/02/2011 21:24:15, Simulator time = 19:11:50 (02:11Z)

69794 Advanced Weather Interface Enabled

121322 Sim stopped: average frame rate for last 53 secs = 26.7 fps

126548 System time = 18/02/2011 21:25:13, Simulator time = 19:12:42 (02:12Z)

126548 *** FSUIPC log file being closed

Average frame rate for running time of 53 secs = 26.7 fps

Memory managed: 26 Allocs, 25 Freed

********* FSUIPC Log file closed ***********

FSUIPCinstall.log

Installer for FSUIPC4.DLL version 4.60a

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

... >>> OK! FOUND FSX! <<< ...

Looking in registry for ESP install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft ESP\1.0

Parameter"SetupPath"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft ESP\1.0

Parameter"AppPath"

... NOT found! ...

===========================================================

INSTALLATION FOR FSX:

AppPath="C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"

Checking version of FSX.EXE:

... Version 10.0.61472.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

Found SimConnect build 60905 (Original)

Found SimConnect build 61242 (SP1 May07)

Found SimConnect build 61259 (Acc/SP2 Oct07)

Checking if there's already a version of FSUIPC4 installed in:

C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.DLL

... Version 4.600 found.

FSX Modules folder already exists.

Okay -- installed FSUIPC4 into "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.DLL"

Looking for the current user's Application Data path:

... found as "C:\Users\nono\AppData\Roaming"

Now finding \Microsoft\FSX\FSX.CFG for all users, including this one

Looking in "C:\Users\nono\AppData\Roaming"

Found FSX.CFG in "C:\Users\nono\AppData\Roaming\Microsoft\FSX\ FSX.CFG"

Now checking DLL.XML ...

... There is a previous DLL.XML, checking for FSUIPC4 section.

... FSUIPC4 section already exists but will be replaced.

... FSUIPC4 section of DLL.XML written okay

Now checking for a SimConnect.XML file ...

... No SimConnect.XML file found. This is okay.

Looking in "C:\Users\nono\Application Data\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Contacts\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Cookies\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Desktop\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Documents\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Downloads\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Favorites\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Jeppesen\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Links\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Local Settings\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Music\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\My Documents\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\NetHood\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Pictures\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\PrintHood\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Recent\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Saved Games\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Searches\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\SendTo\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Start Menu\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Templates\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\Videos\Roaming"

... No FSX.CFG there

Looking in "C:\Users\nono\WapSter\Roaming"

... No FSX.CFG there

"Modules\FSUIPC Documents" folder already exists.

Now installing additional files into the "Modules\FSUIPC Documents" folder:

Installed "FSUIPC4 User Guide.pdf" okay

Installed "FSUIPC4 for Advanced Users.pdf" okay

Installed "FSUIPC4 History.pdf" okay

Installed "List of FSX controls.pdf" okay

Installed "GlobalSign Root.exe" okay

Installed "FSUIPC Lua Library.pdf" okay

Installed "FSUIPC Lua Plug-Ins.pdf" okay

Installed "Lua License.pdf" okay

Installed "Lua Plugins for VRInsight Devices.pdf" okay

Installed "Example LUA plugins.zip" okay

FSUIPC4.DLL installed and signature checked out okay!

Deleted GlobalSign Root fix program ... no longer relevant

===========================================================

All installer tasks completed okay!

*************** End of Install Log ***************

dll.xml

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>SquawkBox Transponder</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>C:\Program Files (x86)\SquawkBox\sbtrans10.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>SquawkBox AI Control</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>C:\Program Files (x86)\SquawkBox\sbaicontrol10.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>SquawkBox Internal Version</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>C:\Program Files (x86)\SquawkBox\sbmod10.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>VistaMare Core</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>VistaMare\ViMaCoreX.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>FSUIPC 4</Name>

<Disabled>False</Disabled>

<Path>Modules\FSUIPC4.dll</Path>

</Launch.Addon>

</SimBase.Document>

exe.dll

<?xml version='1.0' encoding='Windows-1252'?>

<SimBase.Document Type='Launch' version='1,0'>

<Descr>Launch</Descr>

<Filename>exe.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>Real Environment Xtreme - Weather Engine 2</Name>

<Path>C:\Program Files (x86)\Real Environment Xtreme 2.0\rexwxengine2.exe</Path>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

</Launch.Addon>

</SimBase.Document>

Hmm i dont really know how to solved this problem... please help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.