Jump to content
The simFlight Network Forums

joystick axis deactivation


Recommended Posts

Hello,

I am programming a FBW-System for FS2004. To this end I have to deactivate the joystick elevator, elevator trim, aileron and rudder axes, as the FBW-System controls them directly. In order to achieve this

I set offset 0x310A to 2^0|2^1|2^2|2^5. For most aircraft this works well, but there are some addon aircraft, wilco B737 pic for instance, which cause problems. As long as the joystick is completely deactivated via the FS settings,

everything works fine. But when I activate the joystick within FS2004 (the throttle is still controlled via direct joystick input, that's why it has to be activated) the elevator and aileron sometimes (maybe 2-5 times/sec) jump to the input command which comes directly from the joystick and do not keep the value commanded by my FBW-System.

Astonishingly these jumps seem to be more frequent when the joystick is moved, when it's being held still the jumps are scarce.

I've already set up a test environment in which my program is just keeping the elevator at neutral position (commanding elevator position = 0 approximately 18 times per sec). The effect can now be seen very clearly. When I move the joystick forward frequent jumps occur. Holding it pushed forward the frequency of jumps is lower. Moving it back the frequency rises again. In neutral joystick position no jumps occur (logical: joystick input is 0, a jump from 0 to 0 will remain unnoticed).

Maybe you have an idea what exactly may lead to these problems with the addon aicraft and what could be a solution.

Regards,

Julian S.

Link to comment
Share on other sites

I am programming a FBW-System for FS2004. To this end I have to deactivate the joystick elevator, elevator trim, aileron and rudder axes, as the FBW-System controls them directly. In order to achieve this

I set offset 0x310A to 2^0|2^1|2^2|2^5. For most aircraft this works well, but there are some addon aircraft, wilco B737 pic for instance, which cause problems. As long as the joystick is completely deactivated via the FS settings,

everything works fine. But when I activate the joystick within FS2004 (the throttle is still controlled via direct joystick input, that's why it has to be activated) the elevator and aileron sometimes (maybe 2-5 times/sec) jump to the input command which comes directly from the joystick and do not keep the value commanded by my FBW-System.

I think this is because some add-on aircraft do their own thing and don't go by FS controls into which FSUIPC can intervene.

Astonishingly these jumps seem to be more frequent when the joystick is moved, when it's being held still the jumps are scarce.

Since unmoved axes should give no inputs this isn't surprising. The scarce jumps you do get will be jitter, caused usually by dirt or power fluctuations.

Maybe you have an idea what exactly may lead to these problems with the addon aicraft and what could be a solution.

Sorry, by without any specific knowledge about how the add-on programmer has done things I couldn't really say. Maybe they can help?

Wouldn't you be better off sticking to aircraft you know you can work with? The PMDG ones have always seemed very amenable.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.