Jump to content
The simFlight Network Forums

WideFS Registration Problem (FSUIPC works)


Recommended Posts

I registered WideFS6 (I think) this morning through the FSUIPC 3.99 installer, and it appeared to be working this morning, but now it doesn't.

FSUIPC still works.

The WideServer.log file says:

22168 WideFS cannot be used until it is Registered through FSUIPC (version 3.44 or later)

The FSUIPC.log file says:

WIDEFS not user registered, or expired

The FSUIPC.key file contains the data as it was sent in confirmation e-mail.

Upon installation the "FSUIPC Install.log" says:

Registration for FSUIPC and WideFS was successful! (result code 00)

I ran the installer again and "checked" the registration and "FSUIPC Install.log" says:

Registration check for FSUIPC and WideFS was successful! (result code 00)

I'm not sure what is wrong. Our secretary ordered two licences of the software (2x WideFS, 2x FSUIPC), but the e-mail she sent us only has one code (well, one for FSUIPC, one for WideFS). I've e-mailed her to ask her for credentials to the SimConnect account so I could check if there were multiple keys, but probably won't get those until Monday, so I wanted to see if anyone knew if we should get more than 1 key? I figured it was possible it was just based on the user name and e-mail, and so it would be the same key for the every machine. I thought it was possible the failure started after my development partner installed the software on a second machine (or it could have been a coincidence) with the same key.

Any insights?

Link to comment
Share on other sites

I registered WideFS6 (I think) this morning through the FSUIPC 3.99 installer, and it appeared to be working this morning, but now it doesn't.

I don't know of any way that a registration can work then not work, unless the file containing the Regisytration details gets changed or corrupted, or the computer system date is changed to one BEFORE the purchase date.

The FSUIPC.key file contains the data as it was sent in confirmation e-mail.

I didn't think they came by email these days. Most SimMarket purchases merely put the registration keys in your account for you to retrieve.

I ran the installer again and "checked" the registration and "FSUIPC Install.log" says:

Registration check for FSUIPC and WideFS was successful! (result code 00)

It certainly sounds like it might be a date problem then. Check the computer system date. I've had occasional odd things happen when a purchase is made from the USA when it is just after midnight in Germany (where the keys are generated) so the date was one day later. If that were the case the keys should work okay by now.

I'm not sure what is wrong. Our secretary ordered two licences of the software (2x WideFS, 2x FSUIPC), but the e-mail she sent us only has one code (well, one for FSUIPC, one for WideFS).

Check the account in SimMarket where the data is stored for you.

I've e-mailed her to ask her for credentials to the SimConnect account so I could check if there were multiple keys, but probably won't get those until Monday, so I wanted to see if anyone knew if we should get more than 1 key? I figured it was possible it was just based on the user name and e-mail, and so it would be the same key for the every machine.

You can have multiple keys with the same name and email, though it is unusual and I don't know if SimMarket is set up to do it.

If you send me an email (petedowson@btconnect.com) and attach the FSUIPC.KEY and FSUIPC.LOG files, from the FS Modules folder, I'll check for you.

Regards

Pete

Link to comment
Share on other sites

I don't know of any way that a registration can work then not work, unless the file containing the Regisytration details gets changed or corrupted, or the computer system date is changed to one BEFORE the purchase date.

It certainly sounds like it might be a date problem then. Check the computer system date. I've had occasional odd things happen when a purchase is made from the USA when it is just after midnight in Germany (where the keys are generated) so the date was one day later. If that were the case the keys should work okay by now.

The system date appears to be set properly, but we are in America, so it shouldn't get confused by the whole month/day/year representation should it?

I also noticed that in the FSUIPC.log, that the FS2004 time was off (claims it's always midnight on startup). Wasn't sure if this was normal or in error.

Check the account in SimMarket where the data is stored for you.

If this isn't resolved by the time the Secretary is in on Monday, I'll should be able to verify that the keys I'm using and the one it thinks I should be using are the same.

If you send me an email (petedowson@btconnect.com) and attach the FSUIPC.KEY and FSUIPC.LOG files, from the FS Modules folder, I'll check for you.

An e-mail has been sent, thanks for you time.

Link to comment
Share on other sites

The system date appears to be set properly, but we are in America, so it shouldn't get confused by the whole month/day/year representation should it?

No.

I also noticed that in the FSUIPC.log, that the FS2004 time was off (claims it's always midnight on startup). Wasn't sure if this was normal or in error.

The FS time is not the system time unless you load a flight in the mode set for "Use system time", which you did, and that results in this line just below in the Log you showed:

107375 System time = 04/06/2011 08:50:07, FS2004 time = 08:48:29 (15:48Z)

The log shows it took just over 100 seconds to load the flight.6926 mSecs to

107375 mSecs) which seems to account for the difference.

An e-mail has been sent, thanks for you time.

The KEY file is fine and it works ok here with FSUIPC version 3.995 (the latest update). Could you download that (from the Download Links subforum) and see if that helps? I suspect that when you registered WideFS you didn't run the Installer "as administrator", which seems to be necessary after some recent Windows security changes which can prevent Registry changes. I amended FSUIPC to take a more lenient view if the Registry isn't updated correctly.

Regards

Pete

Link to comment
Share on other sites

The 3.995 was just a single .dll, right? When I put that in the modules directory that "WIDEFS not user registered, or expired" in the FSUIPC.log went away. I won't have access to another machine until I am back in the office, but hopefully that's all it needed.

Thanks for your assistance.

Link to comment
Share on other sites

The 3.995 was just a single .dll, right? When I put that in the modules directory that "WIDEFS not user registered, or expired" in the FSUIPC.log went away. I won't have access to another machine until I am back in the office, but hopefully that's all it needed.

Yes, i think so. It seems the WideFS registration wasn't Registered due to Windows security issues.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.