Jump to content
The simFlight Network Forums

Need for WideFS ?


Recommended Posts

Hi Pete,

I have a question about FSUIPC and ASE on a client PC

ASE is on a client PC and connects to FSX via simconnect . I use DWC mode in ASE.

I use RC4 and for fsuipc to read ASE weather (which is the default when in DWC mode i understand) it needs to get it from the client am i correct?

How does FSUIPC do this; Does it get the weather from ASE via simconnect or do i need a widefs client installed on the client.

I ask this because it seems RC4 always uses the weather what is predicted in FSX

If i need widefs for this is there some special configuration i have to do for having it to work with ASE?

Thanks in advance

William Schoenmakers

Link to comment
Share on other sites

ASE is on a client PC and connects to FSX via simconnect . I use DWC mode in ASE.

I use RC4 and for fsuipc to read ASE weather (which is the default when in DWC mode i understand) it needs to get it from the client am i correct?

How does FSUIPC do this; Does it get the weather from ASE via simconnect or do i need a widefs client installed on the client.

You'd need WideFS enabled (i.e. registered) and WideClient running and connected on the PC running ASE. There's no other way FSUIPC can get the weather from ASE. If ASE were running on the same PC as FSX then it could do it directly. On a Network it has to rely on WideFS.

If i need widefs for this is there some special configuration i have to do for having it to work with ASE?

No, it will be automatic.

Pete

Link to comment
Share on other sites

Using rex2 application for Wx & Scenery

Windows 7 64 bit

Client using Windows XP with Virtual Comport on Com1

WideClient connects with Fsx but not with client application

It worked fine before Microsoft security updates

Config file problem??

See Config file & Log:

[Config]

Port=8002

Window=126,88,867,589

Visible=Yes

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

MailslotTiming=2000,1000

PollInterval=2000

Port2=9002

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

WaitForNewData=500

MaxSendQ=100

OnMaxSendQ=Log

NewSendScanTime=50

Priority=3,1,2

ServerName=XTREME-PC

Protocol=TCP

Port3=COM1

Run1=C:\DLFiles\AWPro.exe

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

********* WideClient Log [version 6.86] Class=FS98MAIN *********

Date (dmy): 28/10/11, Time 12:10:49.640: Client name is OWNER-PC

422 LUA: "C:\Documents and Settings\Owner\Desktop\WideFS 7 Client\Initial.LUA": not found

422 Attempting to connect now

828 Trying TCP/IP host "XTREME-PC" port 8002 ...

828 ... Okay, IP Address = 192.168.1.65

828 Connection made okay!

12344 Lost contact with ASE WX requester

595328 ****** End of session performance summary ******

595328 Total time connected = 592 seconds

595328 Reception maximum: 32 frames/sec, 816 bytes/sec

595328 Reception average whilst connected: 23 frames/sec, 576 bytes/sec

595328 Transmission maximum: 0 frames/sec, 39 bytes/sec

595328 Transmission average whilst connected: 0 frames/sec, 19 bytes/sec

595328 Max receive buffer = 450, Max send depth = 2, Send frames lost = 0

595328 ********* Log file closed (Buffers: MaxUsed 2, Alloc 14399 Freed 14399 Refused 0) *********

All I need is position data sent to the Client application for the moving map.

Please advise........ Anybody

Link to comment
Share on other sites

Client using Windows XP with Virtual Comport on Com1

WideClient connects with Fsx but not with client application

Sorry, I don't understand. What is this "virtual comport"? What is it for? how does it relate to WideClient? Are you talking about using the GSPout facility?

[Config]

...

Port3=COM1

Run1=C:\DLFiles\AWPro.exe

What is that "Port3" parameter? Wideclient won't recognise that.

And Run parameters belong in the [user] section -- that won't work there either.

You don't seem to have any [GPSout] section defined, so I've no idea what it is you are attempting.

The WideClient log is fine. Nothing wrong there.

All I need is position data sent to the Client application for the moving map.

Using GPSout on the Server? Have you enabled it there and specified WideFS?

Without correct parameters in the WideClient INI file nothing will happen.

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.