Jump to content
The simFlight Network Forums

fsuipc 4.70


Recommended Posts

******** WideClient Log [version 6.86] Class=FS98MAIN *********

Date (dmy): 09/01/12, Time 14:08:03.838: Client name is CAMTECH1

234 LUA: "C:\Users\Robert C\Desktop\Initial.LUA": not found

280 Attempting to connect now

1294 Trying to locate server: Need details from Server Broadcast

1294 Failed to connect: waiting to try again

3338 Attempting to connect now

Hello folks i hope all is well , i have the latest fsuipc 4.70 , all went well in loading and registering , in fact when first loaded it worked well no propblems at all.

after several flights i find that fsuipc cannot find the server according to the log above. not for where to go from here , i re loaded fsuipc and widefs several times .

Any help thanks.........Robert

Link to comment
Share on other sites

after several flights i find that fsuipc cannot find the server according to the log above.

FSUIPC is running in the Server -- it runs inside FS. You are talking about the Client, and as it says it isn't receiving broadcasts from the server. Please read the section in the WideFS user guide which tells you how to configure things for this.

i re loaded fsuipc and widefs several times .

Why? What's that going to change? Please use the documentation provided. You need to either make sure all your PCs are in the same workgroup, or else use the ServerName and Protocol parameters, as documented.

Regards

Pete

Link to comment
Share on other sites

  • Thanks for the reply,

Sorry but that has been done before and many times , i have read the fact sheet manual , and i have done and re done ,

what area am i missing.

when i first loaded fsuipc/widefs i did not have to do anything , it worked correctly.

all of a sudden when i startup the sim the , and i launch wifefs.exe , its waiting for connection.

i even checked the firewall , also added the server name section , so i have read the manual.

here is a log

****** WideClient Log [version 6.86] Class=FS98MAIN *********

Date (dmy): 09/01/12, Time 21:15:21.558: Client name is CAMTECH1

234 LUA: "C:\Users\Robert C\Desktop\widefs\Initial.LUA": not found

234 Attempting to connect now

249 Trying TCP/IP host "THERMALTAKE" port 8002 ...

249 ... Okay, IP Address = 192.168.1.2

1294 Error on client pre-Connection Select() [Error=10061] Connection refused

1294 Ready to try connection again

2324 Attempting to connect now

62041 Trying TCP/IP host "THERMALTAKE" port 8002 ...

62041 ... Okay, IP Address = 192.168.1.2

123818 Trying TCP/IP host "THERMALTAKE" port 8002 ...

123818 ... Okay, IP Address = 192.168.1.2

185594 Trying TCP/IP host "THERMALTAKE" port 8002 ...

185594 ... Okay, IP Address = 192.168.1.2

247370 Trying TCP/IP host "THERMALTAKE" port 8002 ...

247370 ... Okay, IP Address = 192.168.1.2

309147 Trying TCP/IP host "THERMALTAKE" port 8002 ...

309147 ... Okay, IP Address = 192.168.1.2

370923 Trying TCP/IP host "THERMALTAKE" port 8002 ...

370923 ... Okay, IP Address = 192.168.1.2

432684 Trying TCP/IP host "THERMALTAKE" port 8002 ...

432684 ... Okay, IP Address = 192.168.1.2

494460 Trying TCP/IP host "THERMALTAKE" port 8002 ...

494460 ... Okay, IP Address = 192.168.1.2

568592 Error on client pre-Connection Select() [Error=10060] Connection timed out

568592 Ready to try connection again

569653 Attempting to connect now

572258 Trying TCP/IP host "THERMALTAKE" port 8002 ...

572258 Error on client gethostbyname() [Error=11004] Valid name, no data record of requested type

614550 Error on client pre-Connection Select() [Error=10061] Connection refused

614550 Ready to try connection again

615580 Attempting to connect now

629994 Trying TCP/IP host "THERMALTAKE" port 8002 ...

629994 ... Okay, IP Address = 192.168.1.2

691770 Trying TCP/IP host "THERMALTAKE" port 8002 ...

691770 ... Okay, IP Address = 192.168.1.2

753547 Trying TCP/IP host "THERMALTAKE" port 8002 ...

753547 ... Okay, IP Address = 192.168.1.2

815323 Trying TCP/IP host "THERMALTAKE" port 8002 ...

815323 ... Okay, IP Address = 192.168.1.2

877100 Trying TCP/IP host "THERMALTAKE" port 8002 ...

877100 ... Okay, IP Address = 192.168.1.2

938876 Trying TCP/IP host "THERMALTAKE" port 8002 ...

938876 ... Okay, IP Address = 192.168.1.2

1000652 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1000652 ... Okay, IP Address = 192.168.1.2

1062413 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1062413 ... Okay, IP Address = 192.168.1.2

1124190 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1124190 ... Okay, IP Address = 192.168.1.2

1141350 Error on client pre-Connection Select() [Error=10060] Connection timed out

1141350 Ready to try connection again

1142411 Attempting to connect now

1191239 Error on client pre-Connection Select() [Error=10061] Connection refused

1191239 Ready to try connection again

1192268 Attempting to connect now

1192268 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1192268 ... Okay, IP Address = 192.168.1.2

1254045 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1254045 ... Okay, IP Address = 192.168.1.2

1315790 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1315790 ... Okay, IP Address = 192.168.1.2

1377566 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1377566 ... Okay, IP Address = 192.168.1.2

1439343 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1439343 ... Okay, IP Address = 192.168.1.2

1501119 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1501119 ... Okay, IP Address = 192.168.1.2

1562896 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1562896 ... Okay, IP Address = 192.168.1.2

1624672 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1624672 ... Okay, IP Address = 192.168.1.2

1686448 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1686448 ... Okay, IP Address = 192.168.1.2

1748225 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1748225 ... Okay, IP Address = 192.168.1.2

1810001 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1810001 ... Okay, IP Address = 192.168.1.2

1871778 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1871778 ... Okay, IP Address = 192.168.1.2

1933554 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1933554 ... Okay, IP Address = 192.168.1.2

1995330 Trying TCP/IP host "THERMALTAKE" port 8002 ...

1995330 ... Okay, IP Address = 192.168.1.2

2057107 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2057107 ... Okay, IP Address = 192.168.1.2

2118883 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2118883 ... Okay, IP Address = 192.168.1.2

2180660 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2180660 ... Okay, IP Address = 192.168.1.2

2244495 Error on client pre-Connection Select() [Error=10060] Connection timed out

2244495 Ready to try connection again

2245556 Attempting to connect now

2248161 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2248161 Error on client gethostbyname() [Error=11004] Valid name, no data record of requested type

2282450 Error on client pre-Connection Select() [Error=10061] Connection refused

2282450 Ready to try connection again

2283495 Attempting to connect now

2305710 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2305710 ... Okay, IP Address = 192.168.1.2

2367486 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2367486 ... Okay, IP Address = 192.168.1.2

2429263 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2429263 ... Okay, IP Address = 192.168.1.2

2491039 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2491039 ... Okay, IP Address = 192.168.1.2

2552816 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2552816 ... Okay, IP Address = 192.168.1.2

2614592 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2614592 ... Okay, IP Address = 192.168.1.2

2676368 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2676368 ... Okay, IP Address = 192.168.1.2

2738145 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2738145 ... Okay, IP Address = 192.168.1.2

2799921 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2799921 ... Okay, IP Address = 192.168.1.2

2861698 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2861698 ... Okay, IP Address = 192.168.1.2

2923474 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2923474 ... Okay, IP Address = 192.168.1.2

2985250 Trying TCP/IP host "THERMALTAKE" port 8002 ...

2985250 ... Okay, IP Address = 192.168.1.2

3047027 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3047027 ... Okay, IP Address = 192.168.1.2

3108803 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3108803 ... Okay, IP Address = 192.168.1.2

3170580 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3170580 ... Okay, IP Address = 192.168.1.2

3232356 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3232356 ... Okay, IP Address = 192.168.1.2

3294132 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3294132 ... Okay, IP Address = 192.168.1.2

3355909 Trying TCP/IP host "THERMALTAKE" port 8002 ...

3355909 ... Okay, IP Address = 192.168.1.2

3410805 ****** End of session performance summary ******

3410805 Total time connected = 0 seconds

3410805 Reception maximum: 0 frames/sec, 0 bytes/sec

3410805 Transmission maximum: 0 frames/sec, 0 bytes/sec

3410805 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

3410805 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

also here is a fsx log i think

******** FSUIPC4, Version 4.751a by Pete Dowson *********

User Name="Robert Campbell"

User Addr="rdtcmtt@yahoo.com"

FSUIPC4 Key is provided

WideFS7 Key is provided

Running inside FSX on Windows 7

Module base=61000000

78 System time = 09/01/2012 22:09:49

78 FLT UNC path = "\\THERMALTAKE\Flight Simulator X Files\"

109 Trying to connect to SimConnect Acc/SP2 Oct07 ...

109 FS UNC path = "\\THERMALTAKE\Flightsim Folder\"

530 LogOptions=00000000 00000001

530 Wind smoothing fix is fully installed

530 G3D.DLL fix attempt installed ok

530 SimConnect_Open succeeded: waiting to check version okay

530 Trying to use SimConnect Acc/SP2 Oct07

21185 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)

21185 Initialising SimConnect data requests now

21185 FSUIPC Menu entry added

21247 \\THERMALTAKE\Flight Simulator X Files\camtech.FLT

21247 C:\Users\R6bert C\Documents\Flight Simulator X Files\IFR McCarran Intl to Indianapolis Intl.PLN

21247 \\THERMALTAKE\Flightsim Folder\SimObjects\Airplanes\LVLD_B763_Winglet\B767-300.AIR

21247 C:\Users\R6bert C\Documents\Flight Simulator X Files\IFR McCarran Intl to Indianapolis Intl.PLN

So i have read the manual , and im wondering what other than adding the server name or address what other reading is important .

you keep suggesting in reading the manual , what part are you talking about.

i have done all and its becoming frustrating.

everything was fine and then all of a sudden it cannot find the server , or whatever is happening.

i know i have it set up right as it was running flawlessly,

it could be a host name issue, my server name is THERMALTAKE , on the client i set it up that way also.

your program is easy to install , it does it automatically for you.

but now i have to manually set the client and that still does not work.

both firewalls are shut off on both machines.

dont know where to go.......Thanks...........Robert

Link to comment
Share on other sites

Sorry but that has been done before and many times , i have read the fact sheet manual , and i have done and re done ,

But then, after all that, all you show me is a partial Wideclient log simpy showing that it isn't receiving any broadcasts, which also shows it is not configured to deal with a non-broadcast setup, wrongly calling it a problem with FSUIPC not finding the server it is running in, and even misleadingly entitling the thread "FSUIPC 4.70"?

when i first loaded fsuipc/widefs i did not have to do anything , it worked correctly.

all of a sudden when i startup the sim the , and i launch wifefs.exe , its waiting for connection.

I assume you mean WideClient, again?

The software does not change on its own. Something else has changed on your system.

i even checked the firewall , also added the server name section , so i have read the manual.

Good. But why, then, not say so and instead make me repeat the advice in the manual you say you've read?

249 Trying TCP/IP host "THERMALTAKE" port 8002 ...

249 ... Okay, IP Address = 192.168.1.2

1294 Error on client pre-Connection Select() [Error=10061] Connection refused

"Connection refused" just means that, and unfortunately Windows gives no more information. All it says (if you Google it, for example) is:

WSAECONNREFUSED 10061 Connection refused.

No connection could be made because the target computer actively refused it. This usually results from trying to connect to a service that is inactive on the foreign host—that is, one with no server application running.

So, there are many possibilities:

* The port being used (8002 by default) is already taken by another program

* There is a firewall problem despite you having checked this

* A hardware or wiring problem on your network

* A Windows software problem, in the network driving part

* FS isn't running or WideServer is not enabled.

also here is a fsx log i think

******** FSUIPC4, Version 4.751a by Pete Dowson *********

No, as it says, that is an FSUIPC4 log. I don't think FSX makes a log.

The WideClient log is only half the story. What does WideServer say? Why not paste the WideServer log (instead of the FSUIPC log which isn't at all relevant).

you keep suggesting in reading the manual , what part are you talking about.

The part on Configuring the Network, and which in particular tells you about the ServerName and Prorocol parameters. The part with a bold red banner advising you to at least read that part!

When you say that I "keep suggesting in reading the manual", if you refer back you will see that I did this only ONCE, so hardly "keep suggesting", and the reason I did so isd that you simply gave such little information, describning it incorrectly, that it looked like you'd nerver looked at it at all. 99% of WideFS connection problems come from matching WinVista or Win7 with WinXp which two systems use different Workgroup names. That's what it looked like in your case, with your unfortunately very flimsy report. I can only respond to what you provide with my best guess

i have done all and its becoming frustrating.

everything was fine and then all of a sudden it cannot find the server , or whatever is happening.

i know i have it set up right as it was running flawlessly,

Something has changed, then, and it isn't WideFS. I'm afraid you will have to figure out what. I can't help very much from here. In your situation I'd try to work out what I changed, because certainly something changed to clobber your network. Do other Network functions operate? You'll need to go through some process of elimination.

both firewalls are shut off on both machines.

It doesn't look like it, but the firewall is probably only one of many possibilities. If it isn't the firewall then something else is wrong with your network.

it could be a host name issue, my server name is THERMALTAKE , on the client i set it up that way also.

I can't verify that in any case because you've not shown me the WideServer log file.

Regards

Pete

Link to comment
Share on other sites

Well im back and i still am in the dark , i imagined after all these years someone would have had this problem before , and yes i have read the manual.

W7 on both machines.

64 bit on both machine

******** FSUIPC4, Version 4.751a by Pete Dowson *********

User Name="Robert Campbell"

User Addr="rdtcmtt@yahoo.com"

FSUIPC4 Key is provided

WideFS7 Key is provided

Running inside FSX on Windows 7

Module base=61000000

47 System time = 10/01/2012 11:34:18

47 FLT UNC path = "\\THERMALTAKE\Flight Simulator X Files\"

78 Trying to connect to SimConnect Acc/SP2 Oct07 ...

78 FS UNC path = "\\THERMALTAKE\Flightsim Folder\"

312 LogOptions=00000000 00000001

312 Wind smoothing fix is fully installed

312 G3D.DLL fix attempt installed ok

312 SimConnect_Open succeeded: waiting to check version okay

312 Trying to use SimConnect Acc/SP2 Oct07

17971 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)

17971 Initialising SimConnect data requests now

17971 FSUIPC Menu entry added

18033 \\THERMALTAKE\Flight Simulator X Files\camtech.FLT

18033 C:\Users\R6bert C\Documents\Flight Simulator X Files\IFR McCarran Intl to Indianapolis Intl.PLN

18033 \\THERMALTAKE\Flightsim Folder\SimObjects\Airplanes\LVLD_B763_Winglet\B767-300.AIR

18033 C:\Users\R6bert C\Documents\Flight Simulator X Files\IFR McCarran Intl to Indianapolis Intl.PLN

71136 System time = 10/01/2012 11:35:30, Simulator time = 11:34:38 (11:34Z)

3209798 Sim stopped: average frame rate for last 3139 secs = 8.2 fps

3218129 System time = 10/01/2012 12:27:57, Simulator time = 12:26:55 (12:26Z)

3218129 *** FSUIPC log file being closed

Average frame rate for running time of 3139 secs = 8.2 fps

G3D fix: Passes 22237, Null pointers 0, Bad pointers 0, Separate instances 0

Memory managed: 2 Allocs, 2 Freed

********* FSUIPC Log file closed ***********

here is a fsuipc log

i have done what your manual ask , no change.

my firewalls are both shut off.

as for ports i have no clue if they are on or off.

how do i change or see these ports .

im really tring to fix this , and it keeps bringing me back to fsuipc.

simconnect works fine so comunication is working, that may not have any bearing on fsuipc.

all my mapped drives are up and running.

i have checked everywhere and if this is all it takes to knock out your fsuipc or whatever is happening.

im sure in the years you have been doing this you have come across this problem.

where do i look to see if fsuipc is the problem or where the heck do i look. i have checed everywhere that i can think of.

i went static , auto , im lost people , and if Mr. Dowson cannot help , is there someout there that has experiance the problem.

Thanks...........Robert

Link to comment
Share on other sites

and yes i have read the manual.

I seem to remember you said this before. We went all through that and came to the conclusion that something has got messed up with your network. I can't sort it for you, I'm sorry.

******** FSUIPC4, Version 4.751a by Pete Dowson *********

Why post the FSUIPC log for a Network problem? The only logs relevant to WideFS are the WideClinet and WideServer logs!

i have done what your manual ask , no change.

You said that before. Have you forgotten?

my firewalls are both shut off.

You said that too. Please do look back. You are repeating yourself to no purpose.

as for ports i have no clue if they are on or off.

Ports aren't "on" or "off", just blocked (firewalls) or used. i simply suggested you might have added something using the same port as needed by WideFs. Since you've studied the documentation so many times you will know you can change the ports used by WideFS easily by parameters.

how do i change or see these ports .

I've no idea how you 'see' ports, but perhaps you can cast your mind back and try to remember what you've changed since things worked. It's likely that one of the thngs you did, maybe one of the programs you added, has messed things up or stolen the ports. Otherwise, you need to start thinking about hardware or wiring problems. I note that you've not yet even confirmed that you have a working network in the first place!

im really tring to fix this , and it keeps bringing me back to fsuipc.

What has FSUIPC got to do with it? There's no network stuff in FSUIPC, only WideFS.

simconnect works fine so comunication is working, that may not have any bearing on fsuipc.

FSUIPC uses SimConnect for 90% of its actions. Are you using SimConnect over the network? If so, check that none of the SimConnect applications are using the ports WideFS needs-- 8002 and 9002. SimConnect would get them first.

I have checked everywhere and if this is all it takes to knock out your fsuipc or whatever is happening.

No idea what you mean there, sorry.

where do i look to see if fsuipc is the problem or where the heck do i look. i have checed everywhere that i can think of.

You ignore half of what i tell you. FSUIPC is not relevant. Where is the WideServer log file I asked you for? What's the point of you ranting on like a crazy person if you don't read what is written?

I'm not going to answer many more of your rants. Please calm down and act sensibly, and for Pete's sake, please read what I write. Else i'm wasting my time altogether. I have better things to do, I assure you!

Pete

Link to comment
Share on other sites

no disrespect but im not versed in your software as you are and im not ranting , and i dont write software you do i just want to fly.

im on the same network .

same w7

same 64 bit

same work group

read the part that made since to me

done the part that made since to me

i dont feel like going back and forth with this with you, all i want is a fix which you dont have.

i dont understand ports and the like like you do.

and just to be honest i dont like coming to your site for this very reason.

im not as smart as you are sir.

Thank you for your help..................................Robert the dummy

just because one reads your manual does not mean one gets what you are talking about .

Link to comment
Share on other sites

no disrespect but im not versed in your software as you are and im not ranting , and i dont write software you do i just want to fly.

I call it 'ranting' because you keep saying the same things without adding anything new, and certainly not appearing to take much notice of my replies.

i dont feel like going back and forth with this with you, all i want is a fix which you dont have.

Correct. I cannot fix a problem on your network, at least not without visiting your place and doing the things you will have to do for yourself.

WideFs needs a working network to start with.

i dont understand ports and the like like you do.

I don't understand ports. All I know is that numbers 8002 and 9002 are used by WideFS, and if anything else gets them first WideFS cant use them. That is precisely why they can be changed in the INI files, as you surely must know, having studied the documentation so much.

and just to be honest i dont like coming to your site for this very reason.

Please be welcome to leave. I have tried my best with you, and spent a lot of time on it too, evidently to no avail, because you continue to ignore so much of what i write!

Bye!

P.S. You have still not even bothered to post the WideServer log, after this time and wasted messaging! :-(

I won't bother answering you again, to avoid your eviident irritation with my attempts to help.

Pete

Link to comment
Share on other sites

Mr. Dowson I have wronged you in your attempt to help me , and you are correct , i should have looked more closely to the manual , what i discovered was that the wideserver files were not in the modules folder, i had mistakenly moved the files to the second computer.

in other words pilot error , i apologize to you for my brashness you sir were right all along.

if you see my name in the future , please skip over.....once again my apologizes............Robert

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.