Jump to content
The simFlight Network Forums

1 Issue, can't get rid.


Recommended Posts

Morning,

I have the latest version of FSUIPC installed and have had no issues with it at all. I shut down my FSX after a flight to Italy last week, went to boot it up yesterday and just as in the FAQ of this forum, I got the "FSUIPC DLL: FS new universal IPC interface" error.

Now, I did everything that was suggested and It worked, the FSUIPC_loader seemed to do the trick, or so I thought. I've just come back to boot FSX again, now it's giving me the same error but with the faulting module as the loader.

I've done a repair of Acceleration pack, plus all the usual suggestions on this forum!

Any further help would be appreciated, I'm going slightly crazy.

Thanks.

Link to comment
Share on other sites

I have the latest version of FSUIPC installed and have had no issues with it at all. I shut down my FSX after a flight to Italy last week, went to boot it up yesterday and just as in the FAQ of this forum, I got the "FSUIPC DLL: FS new universal IPC interface" error.

Sorry, what error is that? Can you be more specific please? FSUIPC.DLL doesn't run on FSX only FS9 and before, You seem to refer to this as some well-known error ("the ...error"?), but I don't know what you actually mean. And there is no message "FSUIPC DLL: FS new universal IPC interface" in FSUIPC4 at all! In fact words similar to that do only appear in FSUIPC.DLL for FS9. Are you sure you haven't got the FS9 version placed in the FSX root folder? This is very likely to crash FSX.

Now, I did everything that was suggested and It worked, the FSUIPC_loader seemed to do the trick, or so I thought. I've just come back to boot FSX again, now it's giving me the same error but with the faulting module as the loader.

Perhaps you could say which FAQ you are talking about and exactly which error you are getting, please. The only one I am aware of is the SimConnect "Trust" error, and that isn't a re-occurring one, once it is overcome the once.

I need the FSUIPC4.LOG file (paste it in a message) if one is produced, and the Windows error log details too, please.

BTW something must have changed. Software doesn't change just because you shut it down and start it up again. Possibly you have a corrupted FSX.CFG file or logbook? The latter can also give crash symptoms during loading.

Regards

Pete

Link to comment
Share on other sites

Hi Pete,

Sorry I couldn't be more specific - It was very late/early!

This is the said error (I also get it with the FSUIPC4_Loader.dll too):

jbb7sjPxkscfkf.jpg

Perhaps you could say which FAQ you are talking about and exactly which error you are getting, please. The only one I am aware of is the SimConnect "Trust" error, and that isn't a re-occurring one, once it is overcome the once.

Yeah, It was the Trust error one (this one for clarity)

I need the FSUIPC4.LOG file (paste it in a message) if one is produced, and the Windows error log details too, please.

There is no .LOG file, only an Install log file (in the Modules folder).

BTW something must have changed. Software doesn't change just because you shut it down and start it up again. Possibly you have a corrupted FSX.CFG file or logbook? The latter can also give crash symptoms during loading.

I Installed XPlane 10, that was about it. I have deleted both .cfg to let it rebuild, still no luck.

Cheers.

Edited by Matt Davies
Link to comment
Share on other sites

This is the said error (I also get it with the FSUIPC4_Loader.dll too)

...

There is no .LOG file, only an Install log file (in the Modules folder).

Hmmm. So FSUIPC4 isn't getting loaded even.

Are you using nVidia's "Surround" mode on three screens, by any chance? If so, that's a video driver problem. Maybe others like this are too, for all I know.

There's no code I can change to fix this if none of my code is actually being loaded, and if it is the "trust" bug then this is the first time i've heard of it recurring after working -- at least till the next update is installed. The idea of the Loader was to save updating the part actually being loaded by SimConnect and so avoid the problem after initial success.

My main problem with all this is that it has never occurred on any of my four FSX systems, and evidently doesn't occur on the vast majority of others either. So it is something to do with something else in the system which somehow wrecks what SimConnect is doing.

Maybe other ideas might occur if we had more information, like, for instance, the Windows error log entry for this crash. To get this enter "event log" into the search programs edit space on the Start button, press return. When the Event Viewer appears, select Windows Logs -- Application, and find the error (marked red exclamation) in the list. Double click on it to get a separate details window, then clcik 'Copy'. you can paste the result into a message.

Please also paste in your DLL.XML and EXE.XML files (the latter may not exist). Find those in the same folder as your FSX.CFG (<usr>\AppData\Roaming\Microsoft\FSX).

Regards

Pete

Link to comment
Share on other sites

Hi Pete,

Yes, I use nVidia's "Surround" mode via 3 screens.

Crash Log:


Log Name: Application
Source: Application Hang
Date: 29/08/2012 10:38:35
Event ID: 1002
Task Category: (101)
Level: Error
Keywords: Classic
User: N/A
Computer: Matt-PC
Description:
The program fsx.exe version 10.0.61637.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: e3c
Start Time: 01cd85c9ee389a4e
Termination Time: 5
Application Path: E:\FSX\fsx.exe
Report Id: 4c6f74b2-f1bd-11e1-bb7e-c86000ca489f
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Hang" />
<EventID Qualifiers="0">1002</EventID>
<Level>2</Level>
<Task>101</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-08-29T09:38:35.000000000Z" />
<EventRecordID>2259</EventRecordID>
<Channel>Application</Channel>
<Computer>Matt-PC</Computer>
<Security />
</System>
<EventData>
<Data>fsx.exe</Data>
<Data>10.0.61637.0</Data>
<Data>e3c</Data>
<Data>01cd85c9ee389a4e</Data>
<Data>5</Data>
<Data>E:\FSX\fsx.exe</Data>
<Data>4c6f74b2-f1bd-11e1-bb7e-c86000ca489f</Data>
<Binary>430072006F00730073002D00740068007200650061006400000044006500610064006C006F0063006B0000000000</Binary>
</EventData>
</Event>
[/CODE]

[i][u][b]DLL.XML:[/b][/u][/i]

[CODE]
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>dll.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>Addon Manager</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>bglmanx.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>Object Placement Tool</Name>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>Traffic Toolbox</Name>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK raffictoolbox.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>Visual Effects Tool</Name>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>A2A Feel</Name>
<Disabled>False</Disabled>
<Path>Modules\A2A_Feel.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
<Launch.Addon>
<Name>AccuFeelMenu</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\AccuFeelMenu.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>IvAp</Name>
<Disabled>False</Disabled>
<Path>D:\IvAp v2\ivap_fsx_bootstrap.dll</Path>
<Commandline></Commandline>
</Launch.Addon>
<Launch.Addon>
<Name>PMDG HUD interface</Name>
<Disabled>False</Disabled>
<Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
<Launch.Addon>
<Name>FSUIPC 4</Name>
<Disabled>False</Disabled>
<Path>Modules\FSUIPC4_Loader.dll</Path>
</Launch.Addon>
<Launch.Addon>
<Name>FSCopilot</Name>
<Disabled>False</Disabled>
<Path>Modules\FSCopilot.dll</Path>
</Launch.Addon>
</SimBase.Document>
[/CODE]

[i][u][b]EXE.XML:[/b][/u][/i]

[CODE]
<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>exe.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>Couatl</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>fsdreamteam\couatl\couatl.exe</Path>
</Launch.Addon>
<Launch.Addon>
<Name>Saitek DirectOutput RadioStack</Name>
<Disabled>False</Disabled>
<Path>C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
<CommandLine>-run</CommandLine>
</Launch.Addon>
</SimBase.Document>
[/CODE]

Cheers.

Link to comment
Share on other sites

Yes, I use nVidia's "Surround" mode via 3 screens.

Aha! Then you need to change the video driver. This bug has now been confirmed by three other users of that facility. There's no other work-around found so far. Here's a quote from one who solved it:

Solved it!

Turns out it is directly related to nvidia surround. More importantly to the current beta driver 304.79. Rolling the drivers back to 304.48 (or even the last official 301.42) stops the issue with various .dll files not loading.

Regards

Pete

Link to comment
Share on other sites

Hi Pete,

Rolled back the drivers to the suggested ones and after 1 Simconnect trust message, we're all back to normal. nVidia, how you frustrate me!

Thanks for your help, it's much appreciated. Lets hope when the beta drivers come to release, they'll have fixed the issues!

Once again, thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.