Jump to content
The simFlight Network Forums

Full CH Throttle Quadrant axis travel not showing in FSuipc


 Share

Recommended Posts

I just recently purchased a CH throttle quadrant and have been trying to set it up with fsuipc. It's working OK for the most part, the problem is that each of the 6 axes ignore anything below the "idle detent" on the CH quadrant. In other words, when each level is in the idle detent, fsuipc is showing 16383 at the top of the level's motion and -16384 in the idle detent, and it doesn't go any lower than that (i.e. when I move the throttle past the idle detent to the very bottom of travel, it still shows -16384).

The CH control manager utility is set up in direct mode with no mapping etc, and is calibrated properly. In there, in the test/calibrate page of the CH control manager, each axis shows full range of movement from stop to stop.

Thanks in advance for any help!

Link to comment
Share on other sites

I just recently purchased a CH throttle quadrant and have been trying to set it up with fsuipc. It's working OK for the most part, the problem is that each of the 6 axes ignore anything below the "idle detent" on the CH quadrant. In other words, when each level is in the idle detent, fsuipc is showing 16383 at the top of the level's motion and -16384 in the idle detent, and it doesn't go any lower than that (i.e. when I move the throttle past the idle detent to the very bottom of travel, it still shows -16384).

Those values represent the absolute maximum range which can be accepted by FS. Those are the values you'd expect AFTER calibration. So, where are you actually reading those numbers? And how are you assigning the axes?

The input values shown in the Axis assignments tab in FSUIPC options are those supplied by the joystick drivers, directly, with no manipulation. FSUIPC cannot invent values outside of the range shown there. But the values you mention are so ideal that I find it difficult to believe they are the raw input values.

Please also state the version of FSUIPC (and the version of FS for that matter). You should be using 3.999z for FS9 and before, or 4.86 for fSX and P3D.

I'm afraid it is late here now and I'm off to bed. I'll check your reply in the morning.

Regards

Pete

Link to comment
Share on other sites

Already figured this out, before anyone takes the time to respond!

I didn't know there was a group of setting in the CH control manager that allowed you to specify a specific range in the detent. It defaults to 255 which means the control will ignore anything between the detent and the stop. I set this to 240 and it works great!

Hopefully this will help anyone in the future who runs into the same problem.

edit: woops, too late! Thank you anyways though, Pete :)

Edited by molleh
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.