Jump to content
The simFlight Network Forums

FSUIPC Will Not Register

Recommended Posts


I recently purchased FSUIPC with WideFS. Everything went well and I was emailed my registration info. I am working with a new computer (Win 8 ) and a fresh install of FS 2004 (9.1) update. I run the installer, put in my registration information, and everything shows successful. I run FS2004 and FSUIPC says it is not registered and to use the installer to register. Below is the install log....pls help!

Installer for FSUIPC.DLL version 3.999z

Looking in registry for FS9.1 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

... NOT found! ...

Looking in registry for FS9 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0

Parameter"EXE Path"

... >>> OK! FOUND FS9! <<< ...



EXE Path="C:\Program Files (x86)\Microsoft Games\Flight Simulator 9"

Checking if there's already a version of FSUIPC installed in:

C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\Modules\FSUIPC.DLL

... Version 3.999z found.

Okay -- installed FSUIPC into "C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\Modules\FSUIPC.DLL"

"Modules\FSUIPC Documents" folder already exists.

Now installing additional files into the "Modules\FSUIPC Documents" folder:

Installed "FSUIPC User Guide.pdf" okay

Installed "FSUIPC for Advanced Users.pdf" okay

Installed "FSUIPC History.pdf" okay

Installed "List of FS2004 controls.pdf" okay

Installed "GlobalSign Root.exe" okay

Installed "FSUIPC Lua Library.pdf" okay

Installed "FSUIPC Lua Plug-Ins.pdf" okay

Installed "Lua License.pdf" okay

Installed "Lua Plugins for VRInsight Devices.pdf" okay

Installed "LuaFileSystem.pdf" okay

Installed "Example LUA plugins.zip" okay


Installed "FSUIPC for Programmers.pdf" okay

FSUIPC.DLL installed and signature checked out okay!

Deleted GlobalSign Root fix program ... no longer relevant


All installer tasks completed okay!

Registration check for FSUIPC and WideFS was successful! (result code 00)

*************** End of Install Log ***************

  • Upvote 1
Link to comment
Share on other sites

I run FS2004 and FSUIPC says it is not registered and to use the installer to register. Below is the install log....pls help!

The FSUIPC log, not the installer log, will help me see what is wrong. It is when FSUIPC is running that the problem is detected, not when the installer runs.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.