Jump to content
The simFlight Network Forums

Black Screen question for Peter

Recommended Posts


I apologize in advance because my question does not relate to any of your modules, but I wanted to get your opinion on the black screen issue that seems to have shown up in FS9.

FS9 runs like a dream on my machine with all default aircraft.

The problem is when I'm in the EagleSoft Beechjet 400A aircraft and I try to bring up the GPS, I get the black screen and FS9 quits.

I even tried a different video card and older, newer, and the latest drivers of everything on the machine from motherboard, sound, video, and including the latest DirectX. Rebuilt from scratch many times trying different drivers and approaches.

Tried the Microsoft knowledge base and they suggested changing different DirectX settings and video settings but nothing worked.

But, if I go to a lower resoultion such as 800x600, it works but it is very touchy when I try to open the menus.

Seems like the "black screen" issue is experienced by some and not others. The Microsoft knowledge base even has a long list of games that have the black screen problem.

I'm not asking for a solution, I just wanted to get your opinion on the issue and what you think might be happening.


Jonathan Clay (registered user of FSUIPC and WideFS)

My machine:

ASUS A7V133 motherboard w/ VIA KT133A chipset

AMD 1.33 Ghz Thunderbird processor

Crucial 256 MB RAM x2 for 512 MB total

ASUS GeForce 4 Ti 4200 video w/ 64 MB RAM

Creative Sound Blaster Audigy Gamer

Western Digital 7200 RPM 40 GB HD x2

RAID 0 configuration

Latest VIA Hyperion 4in1 v4.49 drivers

Latest Nvidia 45.23 drivers

Latest Sound Blaster drivers

Win 98 SE

Link to comment
Share on other sites

I'm not asking for a solution, I just wanted to get your opinion on the issue and what you think might be happening.

I really don't know. It's certainly something which is affected by timing. I got no such problems at all until upgrading from a 2.4GHz P4 to a 3.2 GHz P4. Then I found a situation in FS2004 where I could reproduce it at will -- this is the one I describe in one of my Announcements above. After many experiments I managed to "fix" that one, at least on my setup -- several small changes to three of my modules, and my particular "black screen" is fixed, just provided I don't have the Lago DLL ViMaCore2004 installed.

But all these changes meant was that some installed DLLs then contributed less time, some microseconds, maybe as much as milliseconds, to the processing of messages in FS. There is no logical reason why changing that time should really fix anything. It doesn't seem to make any sense. In my example, the problem only happened if FS lost focus to another process first. Why should that make any difference? It's really weird.

As it happens, I can still get them, just not in the same way.

It must be something between FS and DX9, or maybe DX9 and video drivers - but the latter seems less likely as it happens with Matrox, nVidia and ATI. Maybe it is in that area, and there's a common misunderstanding among them all of something in the DX specification? I don't know. It isn't my area of expertise I'm afraid, and really I wouldn't know how to go about finding out. But my suspicions still fall strongly on DX9.

You say there's somewhere where Microsoft list such problems in programs. Could you point me there, please? I'd be interested to read more.

BTW the black screen things I get aren't actually hangs -- pressing ALT brings up the FS menu and if I go to the Options-Settings-Display Harware tab and change something, it all comes back and you can continue. Some folks do, however, get real hangs, or even a complete CTD (crash to desktop -- no messages, no nothing, FS just disappears!).

Sorry, that about sums up all I know and theorise.



Link to comment
Share on other sites

I found these by searching for the exact phrase "black screen" on the MS knowledgebase. I also did another search "flight black screen" where I asked for a match on all words. Some good ones:

Games: The Screen Turns Black


Black Screen When You Run a DirectX-Based Program


Games: How to Troubleshoot Display Issues


Games: Hangs or Slow Performance on AMD System with VIA Chipset


I've tried everything that these asked for but still have the GPS problems. I finally got an error screen at one time where it said ddhelp performed an illegal operation. I assume that is a DirectX program. I'm with you. I think Microsoft has some DX9 issues to contend with.

Thanks for the reply. You are an invaluable asset to the flight sim community. Regards,

Jonathan Clay

Des Moines, Iowa

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.