Jump to content
The simFlight Network Forums

FSUIPC4 4.933 and ThrottleManager (Lua script from pilotjohn)

Recommended Posts

After installing the new version 4.933 FSUIPC4 my throttle reversu function added by ThrottleManager (Lua script from "pilotjohn"

see: http://forum.simflight.com/topic/69388-throttle-manager-to-allow-axis-forwardreverse-toggle/?hl=throttlemanager ) does not work anymore.

Can depend on some change of FSUIPC?

Best regard


There's no change I'm aware of which will affect any previous Lua plug-in. Maybe it's a bug, but i can't help with no information.


What was your previous version of FSUIPC? What exactly doesn't work? Is it loading? How is it loaded/ started? Have you checked the FSUIPC log file for errors?


It may need tracing (using the option in the FSUIPC Logging tab) to see where it goes wrong. 




Well, I've had a look at that plug-in. Actually there are several versions in that thread, one of which even uses Lua sockets. And they are all so complicated I don't understand what they are doing at all, so even with a trace I wouldn't be able to identify the problem.


So, can you contact the author and see if he can find out what the problem is -- if it is something I've messed up, somehow, I would dearly love to know and fix it.


There's one problem -- I'm off on holiday on Saturday for 10 days.  Do you think you can get "pilotjohn"s  involvement very quickly? Maybe a private message?




Link to comment
Share on other sites

Thank you for the very ready answer.
I believe that the latest version with which it worked was the Throttlemanager 4,929. But even with the 4931 no longer worked.
The assignment of key-buttons of my saitek throttle are well recognized by FSUIPC (a throttle lever for two), but when I act on the lever not hear the sound or turn on the reverse. In Annex I send the logs you requested, my FSUIPC4.ini file and the list of the directory "modules".

I do not see any error message or anything, just does not work.

Fear not, the solution of my problem is not so urgent. I will contact pilotjohn with a PM.

Many tanks, Claudio


Link to comment
Share on other sites

I believe that the latest version with which it worked was the Throttlemanager 4,929. But even with the 4931 no longer worked.


Hmm. Strange. No relevant changes in Lua between 4.929 and 4.931.  In fact pretty much the only changes at all were for P3D 2.2, to match the hooks into the P3D code which had changed. none of that would touch Lua actions.


 In Annex I send the logs you requested, myFSUIPC4.ini file and the list of the directory "modules".




For some reason you have ipc Write logging enabled, which is not relevant to any Lua plug-in (at present -- that's something I may change!). The only logging which might have been useful in the Lua debug/trace actions. But don't bother. I've tried it here and I don't know what ThrottleManager is supposed to do so can't really test it. And in any case I do not understand the code, at least not without spending a long long time working through it.


i'm afraid i am completely dependent upon the author telling me what is wrong.


Fear not, the solution of my problem is not so urgent. I will contact pilotjohn with a PM.

Okay. Tell him I'm away till 20th May.
Link to comment
Share on other sites



Can you try FSUIPC 4.934, please? I think your problem might be the same as one reported separately which is now fixed. it applies only to Lua plug-ins loaded by a non-profile specific [Auto] section in the FSUIPC INI file.


I'll check back with you after my holiday.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.