Jump to content
The simFlight Network Forums

FSX error on startup

Recommended Posts

I am getting the error message shown below once or twice a week when I attempt to open FSX.  Since this started showing up, I'm also loosing ALL of the button and switch assignments that I have assigned to my Saitek Pro X52 joystick and throttle whenever I start up FSX.  Saitek even sent my replacing for these controllers, which did not help.  I have stopped redoing these assignments until I can find the solution to this problem.  The assignments are created in FSX or FSUIPC, depending which system will has the functions I need.  I've also been having major worsening problems with my controllers going whacky during takeoff and flying.  I mention this because I don't know if this could be tied into the FSUIPC issue.  I'm on a Windows 7, 64-bit system and have been flying in FSX for over two years.


Any assistance you can provide regarding the error message (which might also be linked to the other issues) would be greatly appreciated.  At this point I am spending all of my normal flying time in worked on these issues instead of being the air. Thanks.



Flight Simulator has detected a problem with a third-party software program (add-on):

Name: FSUIPC4 DLL: FS new universal IPC interface

Version: 4.86

Company: Peter L. Dowson

File: Modules\FSUIPC4.dll

Do you want to run this software (not recommended)?

To avoid seeing this message in the future, uninstall this program or disable its ability to start when running Flight Simulator.  For more information about third-party programs, contact the publisher or see http:\www.fsinsder.com.

Link to comment
Share on other sites

First of all, you are very much out of date with version 4.86. The currently supported version is 4.934. Please update if you want support as I cannot support old versions.


Second, FSUIPC's assignments and facilities obviously won't be available to you if you get such an error and respond "No" to the question "do you want to run this software". If you do run it and it does get loaded, then it NEVER forgets the assignments and settings you made -- they are stored in the FSUIPC4.INI file in your FS Modules folder, and would only ever be lost if you deleted that file.


Third, if FSUIPC is being loaded there will be an FSUIPC4.LOG file generated each load in the FSX Modules folder. Please check. If it is there and you still get nothing, show me that file. If FSUIPC is not being loaded at all then the problem is probably the well-known SimConnect timing bug. Please see the FAQ subforum for several threads about this which give further help.


Fourth, when Windows does show and error such as the one above, it will have an entry in its application logs. Please use the Windows event viewer to find those details and tell me what they say. but ONLY with the latest FSUIPC version, please, not an unsupported old version.


If you have mixed assignments between FSX and FSUIPC this means you have not disabled controllers in FSX, and FSX will therefore often make automatic default re-assignments whenever it thinks that the controllers are reconnected or new. Unfortunately it seems this happens not infrequently with Saitek gear, which seem to give problems for many.


As far as reassignment in FSUIPC is concerned, it is best to use the Joystick Lettering facilities to prevent changes in Windows ID numbers causing incorrect cross-assignments. There's a chapter about this in the User Guide.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.