Jump to content
The simFlight Network Forums

Throttle Control in ERJ145...


Recommended Posts

I'm getting frustrated and I'm hoping someone has a fix for this already but I can't get my engines to obey any control inputs of mine.  I put the joystick (Saitek X52) to full thrust and I get about 80% if I manage to get the erj airborne by the time I get to FL150 the engines are down to 60% n1.  Then when I land they won't reduce throttle even after disconnecting the AP.  I think I'm programming the FMC correctly as I'm doing what I've done before without problems.  However this new install that I have hasn't worked well from the beginning.  I have to shut the engines down as soon as I touchdown so I can stop.  What am I doing wrong?  And sorry if this has been asked before and I just couldn't find the answers.  Thanks



Link to comment
Share on other sites

I think I fixed it.  I checked the configurator and it was saying that it was looking for a GF-FMC which I don't have and that seems to have done it.  My throttles so far have obeyed my input and I'm climbing.  We'll see what happens at the end of the flight but so far so good.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.