Jump to content
The simFlight Network Forums

P3dv3.2 + PMDG777 Auto pilot = CTD g2d.dll 1 min into flight

Recommended Posts

Hi Pete,


I was having PMDG 777 CTD issues soon after upgrading P3D from v3.1 to 3.2 and so decided to rebuild the entire PC.

I followed Nick N's process for reinstalling and setting up W7 x64 for a SSD based system. So no defrag policies or processes are in place.


Antivirus s/w is ESET nod 32 with my P3D install and addons d: drive excluded in Nod 32.

System: W7x64 Os
Asus Maximus Hero viii mother board - latest bios 1601
CPU: i7-6700K 4.0GHz 8MB LGA1151 Skylake HT off in bios
Kingston HyperX FURY HX426C15FBK2/16 16GB Kit (8Gx2) DDR4 2666 Desktop RAM
Samsung SSD 950 PRO 512 GB nvme for W7 OS only
Samsung SSD 850 PRO 1Tb for P3D + all addons including PMDG and orbx etc.

Order of P3D Addons installed :
Orbx - All products (including global, open LC and airports)
pilots - Vector & fs global ultimate series.
Flytampa - OMDB rebooted and YSSY
ImagineSim - WSSS
Thai Creations - VABB, VAJJ
Weather engine - REX ESS PLUS & REX4 TEX + soft clouds - completely updated
PFPX - latest build with NAVDATAPRO AIRAC 1604

Followed your setup recommendations as per PMDG-777-Introduction.pdf
cfg - only added FIBER_FRAME_TIME_FRACTION=0.01 & alwaysfullload=1 under MAIN
Texture settings 1024 - so NO VAS issues whatsover!
Simconnect working fine - Installed all versions including ESP


How do I load P3d:
I run REX ESS PLUS then click Fly now which starts up P3d and opens the scenario page which has the f22 showing up by default. I change the airplane to PMDG 777 then select Airport / parking bay or runway and select ok


How I fly 777LR and 300ER:
PMDG 777 cold and dark panel is my default startup state.
PFPX is used to create the .rte file for my flight and is then closed.
I then go through the configure and startup process and taxi manually till after take off and when I turn on the Autopilot mode when 500ft AGL.


The 777 LR and 300ER CTD occurs after about 1.5 minutes in the air once autopilot is tuned on.
Faulting application name: Prepar3D.exe, version:, time stamp: 0x56df48ce
Faulting module name: g2d.dll, version:, time stamp: 0x56df4993
Exception code: 0xc0000005
Fault offset: 0x000d1ac3
Faulting process id: 0x1828
Faulting application start time: 0x01d1a04d6dd0de90
Faulting application path: D:\Lockheed Martin\Prepar3D v3\Prepar3D.exe
Faulting module path: D:\Lockheed Martin\Prepar3D v3\g2d.dll
Report Id: 3d5cbc80-0c44-11e6-97de-305a3a0172c9


What did I do:
Googled g2d.dll error and based on online possible solutions and tried
1. Deleted .cfg and and let P3d rebuild the file.
Tried to fly again with settings un touched and default P3d.cfg and same CTD g2d.dll issue about 1 to 2 mins after turning on Autopilot .
2.  Used Guru3d Display Driver Uninstaller version to clean out my nvidia drvier and reinstalled the 364.72 version.
Tried to fly again with settings un touched and default P3d.cfg and same CTD g2d.dll issue about 1 to 2 mins after turning on Autopilot.

I then closed P3d, rebooted the computer and followed the same process to start P3d as detailed above. This time I chose to start from the runway of okbk and loaded the 777 default panel state. Set the fuel at 30000 kg and manually decided to fly the 777. No issues at all.. Take off was normal. I reached 35k ft cruise altitude and decided to turn on auto pilot for heading lock and altitude only. There was no CTD and I flew till 100nm away from OMDB at which point I disconnected Autopilot, landed and parked at OMDB complete with secure parking. Not a single CTD irrespective of moving to spot view every now and then and zooming and panning at all the way around the aircraft during takeoff cruise and landing. Even after secure parking I was able to pan around the aircraft with no VAS warning alarms of any sort.

I did the above for both 777LR and 777300ER without issue.

I rebooted the computer, and tried another PFPX based route with 777LR or ER Autopilot and on queue, 1 minute into the flight got a CTD with the gtd.dll error.

I am now out of options and reaching out for your assistance.

I have also flown the P3d default aircraft between NZAA and NZQN without any issue.


I was advised by PMDG that FSUIPC might be able o trap the g2d.dll errors like was done for FSX g3d.dll errors. 

Appreciate any help on this.


I will try uninstalling and reinstalling DirectX and the vc++ runtimes and see if that helps.


Ps. I have 3Dmark installed and all the 3D 4k and normal demos work without a hitch so I can't find any hardware faults of any kind.

Am running memtest86+ to rule out any ram memory issues - 3 passes done so far with no errors. Will update this thread with the fsiupc.log entries later once the memtest is complete.

Link to comment
Share on other sites

I was advised by PMDG that FSUIPC might be able o trap the g2d.dll errors like was done for FSX g3d.dll errors. 


No, sorry. I'm done with hacking into binary code these days. Even with the P3D one in FSX, it was the only one of many G3D crashes I could find a way around, and I only did it because it was the most common one and one I could reproduce. It was fixed in one of the FSX-SE releases and in P3D by version 2.


It is noticeable on the Lockheed-Marting forum that there are more problems with PMDG aircraft on P3D version 3 than with any other add-on. I would assume that L-M are working with PMDG to resolve these, but no one says so either way. Even so, I think you need to report your problem in the Forum just like all the others.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.