Jump to content
The simFlight Network Forums

Encoder commands delayed in FSUIPC

Recommended Posts

Moved to Main Forum!


I am currently building a home cockpit: There is an Arcaze USB board where I attached some witches and encoders. Some days ago I purchased FSUIPC4 (registered version) with WIDEFS7, and I downloaded Linda for free.
Now I tried to control the SPEED of the Aerosoft Airbus autopilot by an encoder. Programming the Arcze board was easy, and it produces 2 different button events, depending on the turn direction. These events are fed to Linda, which in turn has been programmed to count SPEED up or down. Generally, this works: SPEED follows the encoder turns. But: It does that very slow. It seems like the button events would fill a queue, and this would be emptied 1 to 2 steps per second, even I have already stopped turning the encoder. No encoder tick seems to be lost, cause after a full 360 degree turn SPEED changes by 24 (which matches encoder specs).

Now I did the same with the PDMG 777, with the same result. I fed the button events directly to FSUIPC, using the 777 custom controls without LINDA, but didn´t get a different behaviour.

Finally, I programmed the Arcaze to return key codes for the encoder movements, and used the 777´s KeyCommand feature, without FSUIPC. And halleluja: This works fine, with almost no delay between encoder turns and SPEED display update. Unfortunately this is no solution for the Aerosoft Airbus, because the autopilot of this airplane model cannot be controlled by key commands.

Is there a mistake in my ideas? What is the reason for this mysterious delays, and what can I do to avoid them?

Thanks in advance for your answer.

Link to comment
Share on other sites

4 hours ago, Airbuzzer said:

Is there a mistake in my ideas? What is the reason for this mysterious delays, and what can I do to avoid them?

Sorry, there's no way I can tell without more information. I don't know anything about what LINDA does, but in your 777 case, without LINDA, you could enable FSUIPC key and event logging and do the same with your eventual 777 solution and compare the results.

One of the possibilities is that using the keys directly programmed you are getting the acceleration applied when FS detects two keystrokes close together. The other way may have something intervening. If this is the case you may find enabling the FSUIPC options "fix control acceleration" will help.

Quite often with these increment and decrement operations I have found it helps to assing two or three copies of the same keystroke as a sequence to the one button action. This wouldn't apply to something digital like setting a heading, but could well do me the small increments which are usually applied to analogue inputs like throttle levels. Speed settings on an A/P are possibly needed in single digit increments, so that's more difficult. FS tends to apply 10's when accelerated and 1's when not. Without knowing what you're observing I couldn't say if this was the problem.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.