Jump to content
The simFlight Network Forums

using second monitor


Recommended Posts


I'm having the same issue when I tested TIST. I tried to move ADIRS (Log line 485), and it disappeared. The same is true if I run the game as administrator (which I prefer not to do). I am able to get ADIRS back if I click on the A in the menu, then it's "inside" the game window again.


  • OS: Windows 10 Enterprise (Build 14393)
  • Speech: English (United Stats) - Microsoft David Desktop
  • Graphic card: NVIDIA GeForce GTX 970
  • Graphic Driver version: (dated: 12/29/2016)
  • Resolution: 1920 x 1080
  • DX version: 12 (Games seems to be using DX11)
  • Number of monitors: 3
  • No addons installed for the test

Have anyone found a resolution to the issue?



Link to comment
Share on other sites

Greetings and salutations,

Firstly, nice work on Tower 3d Pro. Well worth the investment!

I too am having this problem. I've tried running Tower 3D as admin, as well as the batch files. From the game, the window pops up for about 1 second, then closes. It does not appear to actually load the ADIRS, DBRITE or strips, I am only able to see the title bar, frame, and what I assume to be the background colour.When running the batch files, I only see the dos prompt for a moment.

I am able to consistently crash mmwindow by clicking and dragging the title bar of the strips window in the brief moment that it is active. (Tower 3d continues running happily through the mmwindow crash).

Something I find interesting, I have noticed in the mmwindow directory there are a couple of log files. I have these only for ADIRS and Strip, neither log is time stamped from today. Are these supposed to be generated every time I attempt to launch these windows?

Not sure which file is most pertinent, I'll take a punt and send the output log from one of the crash folders. If the strip and adirs logs are of interest, I can attach them to another comment, but the remaining content of the crash folders are too large to attach. Email?

Thanks for the help,



Link to comment
Share on other sites

Hello flightsimpilot, thanks for the thought, sadly no joy. My monitors are all at the same resolution. I've even tried disabling the "Aero" theme and reverting to the windows' basic colours. Very strange.



Link to comment
Share on other sites

Please go to mmwindows directory and instead of using the button within the game to undock the adirs, use the adirs.bat in this directory to open a second adirs window. It will then generate an adirs.log file. Please post this file and the usual game.log here right after the adirs disappears. 


Thank you


Link to comment
Share on other sites

Hey Vic,

Thanks for your help. Some strange behaviour from my machine here: I launched Tower 3d and set up a scenario at TIST. Without the ADIRS windows open in the game, I ran the ADIRS batch from Windows Explorer (as administrator, just in case). The ADIRS.log file failed to update, it remained time stamped from a week ago. I renamed the log file, executed the batch again, no new log was generated. I launched the dos prompt to see if an error of some sort was being generated in the dos window. When I ran the batch from the dos prompt, it generated a log. I'm confused. I am surprised that the same procedure can generate a different result based on the method in which it was launched.

When running from the dos prompt, there was no change in the duration of the screen remaining active either with or without the ADIRS window being open in game.

I'm not sure which file you mean for the game log. If it is '\game.log', tower 3d does not appear to be generating one. I have attached tower3d_data\output_log.txt, but \speech.log is far too large to attach.

I have taken the liberty of checking (and relaxing) permissions, they look fine, especially given everything is being run as administrator (both the tower3d & mmwindow executables are set as such in the compatibility tab). In case it is relevant, I'm running Trend Micro Internet Security for anti-virus, but it is not giving any suspicious behaviour/blocked file warnings.

Thanks again,




Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.