Jump to content
The simFlight Network Forums

FSUIPC5 with Saitek X52 Pro - CTD while loading


Recommended Posts

Hi Pete

I have an issue that has been reported by others already, but despite following all advises i wasn't able to resolve it :/

When i register FSUIPC5, P3D crashes while loading the module. It looks like my Saitek X52 Pro is the culprit as P3D loads perfectly fine with the joystick disconnected. 

 

Troubleshooting performed so far:

Reinstalled FSUIPC more than once, including most recent version from downloads section

Completely removed X52 drivers, removed any HID entries related to the X52 with 'Device remover', installed most recent drivers

 

When i run FSUIPC unregistered, everything works fine.

 

 

The attached ZIP contains the following files:

  • FSUIPC5 Install.log
  • FSUIPC5.ini
  • FSIUPCJoyScan.csv
  • FSUIPC5.log
  • HidScanner.log
  • FSUIPC_Appcrash_Log

 

Thanks for looking into it

Lars

FSUIPC_logs.zip

Link to comment
Share on other sites

14 minutes ago, woozie said:

Reinstalled FSUIPC more than once, including most recent version from downloads section

Can you please state the actual version number, as everyone says that and it isn't always the latest when i get more information.

15 minutes ago, woozie said:

Completely removed X52 drivers, removed any HID entries related to the X52 with 'Device remover', installed most recent drivers

Why go to that trouble and then go and install Saitek drivers? Unless you need ot use them for other programs, you really don't need them with FSUIPC and are the cause of many problems. To remove them now, including their low level bits, you'd need to not only uninstall them in Programs & Features but also in the Windows device manager. Uninstall the devices their AND elect to remove the drivers when the option presents itself.

18 minutes ago, woozie said:

The attached ZIP contains the following files:

I'm afraid the link doesn't work.

Pete

 

Link to comment
Share on other sites

I'm using 5.112, see my second post for up to date logs (this link works, dont know why the original attachment doesnt)

I thought i need the drivers anyways in order to use all the buttons. So you want me to completely remove drivers (uninstall software and remove devices) and then try to use the joystick without installing anything?

I'll give it a try 

Link to comment
Share on other sites

4 minutes ago, woozie said:

Sorry, just realized that i was back at version 511 when capturing the logs, attached are the logs for most recent version 5.112

That link works okay.

The JoyScan file indicates a device with Vendor ID 06A3 and Product ID 0762.  But it appears not to be a usable HID device. The crash is not actually occurring in FSUIPC at all.

I suspect it is the drivers you have installed. Try what I suggested.

Pete

 

 

Link to comment
Share on other sites

2 minutes ago, woozie said:

I thought i need the drivers anyways in order to use all the buttons.

How many buttons does it have? FSUIPC handles the standard HID 32 buttons. I know some very recent devices have uo to 64, though.  I expect P3D will support the others, but take care to avoid ocnflicts if you assign in both.

3 minutes ago, woozie said:

So you want me to completely remove drivers (uninstall software and remove devices) and then try to use the joystick without installing anything?

Yes, but "uninstall software and remove devices" should be "uninstall software uninstall devices in Device manager, including drivers in device manger, then re-boot so that Windows supports them with the standard USB HID drivers."

Pete

 

 

Link to comment
Share on other sites

HID Device 06A3/0762 is my Saitek X52 Pro

 

Just did as you requested, removed Joystick drivers/software and removed everything X52 related from the device manager. After reboot windows recognized and initialized the joystick. But P3D still crashes during loading

Attached are the logs from my most recent try (including HID scan log after driver uninstall)

 

FSUIPC5._standard_drivers.zip

Link to comment
Share on other sites

Just looked at your HidScanner log. The Satek X-52 shows 39 buttons altogether, so 7 of those won't be directly assignable in FSUIPC. But they won't be in any case, whether the Saitek software was installed correctly or not.

The log file and the JoyScan file both suggest something was wrong. If after doing what i suggest above, things work (i.e. P3D loads) and you find you need to use those extra 7 buttons, then you could try installing the Saitek software. Maybe by removing everything properly the problem will be cleared. I know aa lot of folks do have the Saitek drivers for later models (I assume later? X-55, X-56) installed okay without the crash you are getting, so I still think it's something worng with your installation.

Pete

 

Link to comment
Share on other sites

ok, thats kinda interesting. I added the two lines to the ini file and now it works. The Joyscan CSV file now look completed and i've got lots of extra lines in my ini file. I'm wondering if it was an issue with the ini file, which 'fixed itself' by editing and saving the file. On the other hand, i delete all fsuipc files in modules folder before i reinstalled FSUIPC. 

Btw, i removed the debug lines and it still works, yay!!

Anyways, it seems to work now, thanks for your help Pete, appreciate it. Do you still want to see my logs or are you busy enough? ;)

Thanks

Lars

Link to comment
Share on other sites

12 hours ago, woozie said:

ok, thats kinda interesting. I added the two lines to the ini file and now it works. The Joyscan CSV file now look completed and i've got lots of extra lines in my ini file. I'm wondering if it was an issue with the ini file, which 'fixed itself' by editing and saving the file. On the other hand, i delete all fsuipc files in modules folder before i reinstalled FSUIPC. 

Btw, i removed the debug lines and it still works, yay!!

Anyways, it seems to work now, thanks for your help Pete, appreciate it. Do you still want to see my logs or are you busy enough? ;)

Well, it's really weird, so interesting from that perspective. The extra logging only makes it log exactly what it is doing and what the result is, it certainly doesn't change what it does. Maybe just slowing it down helped, but then why would it work without the logging too?

I think something else changed which fixed it. 

Thanks but, no, I don't need the files now it works. I am short of time this week -- on holiday from Wednesday eve till mid-September. This will be THE main holiday of the year, over 3 weeks! So all sorts of horrible things are bound to happen! 

Pete

 

Link to comment
Share on other sites

Oh dear.....yes your holidays are legendary...it means we can expect P3D v4.1 to be released during this time which will 105% break the current FSUIPC version :D However, i'm glad i reached out to you with my issue before you went on holiday

Nevertheless, enjoy your vacation, you certainly deserve it after a new major FSUIPC release and all the 64bit excitement :)

Lars

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.