Jump to content
The simFlight Network Forums

What makes my WideClient crash?

Recommended Posts

Hi there

I run a full cockpit with two computers in network, P3D on PC1 and Prosim737 stuff on PC2 (in general).

Every time I run my setup, WideClient will crash sooner or later during a flight. I can then restart WC and most times it will then be stable for the rest of the evening, although is may also crash several times more.
When restarting WC I usually get all components except CDUs up and running again.
I have sort of learned to live with it, but it is quite irritating. Is there a way for my to find the cause of this and try to eliminate it? Can I run WideClient in debug mode or anything?

Link to comment
Share on other sites

sry... i just found the manual... Will look at logs and try to sort it out before asking you again, and hopefully report what caused it :)

IF you immediately do have a clue of what causing my crashes, let me know...

Link to comment
Share on other sites

Hi there

Both Sioc nd Prosim MCP connect to the model via fsuipc as i understand, at least these modules freeze when WideClient crash. Also CDUs fall out due to changes in COM or/and USB states.
I thought about it a great deal while searching for a solution yesterday, and I think I could be on to something regarding my two networks on both machines.
I have a LAN for the fs-stuff with static IPs 10.0.0.x, where is the server/P3D PC. I run Wide client on two other comuters, but the problem is only on my client running all the Prosim modules,

Both these computers also have a wlan for connecting to internet and this scope is 192.168.1.x.

The client pc is set up to run all needed modules automatically, and I usually turn on both computers then enter the cockpit. What happens then, is that WiceClient is up and running long before I have started a flight. It will listen for the server response trying to connect many times then connect to the instead. 

WideClient had no serverIP in the config, only trying to connect to the server called P3D1, and nevermind wich IP.

I edited the .ini for WC and entered the Server IP line on the top with, and had a flight afterwards without error.
It became quite late, so I need to do another test today, starting both computers and let them go through a standard automatic startup to see if the problem is surely gone.

So far I suspect the two network instances and a non ip config was to blame. Fingers crossed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.