Jump to content
The simFlight Network Forums
Sign in to follow this  
neo2810

Odd Saitek Rudder issue!

Recommended Posts

I've been using FSUIPC Pro with all my Saitek gear for years without issue. I've suddenly found my rudder is slightly offset to the left on all planes. I've tried resetting the pedals, reloading the Sim, recalibrating the device, reassigning and recalibrating in FSUIPC, all to no avail. The odd thing is, when assigning the device in FSUIPC, the range is completely normal on the Assignment tab, but in Calibration, the in and out are "stuck" on 6063/5731 and even when I move through the pedals range, those inputs change through the range from -16380 > 16380 but with constant interference from the 6063/5731 figures (as if it keeps trying to return to those figures) as if they are overriding the correct inputs. Hope I've explained that clearly. 

I run LINDA (Multipanel) and SpadNext (all other Saitek drivers) but I've tested with both those shutdown and same issue. Anyone experience anything similar or can shed any light?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.