Jump to content
The simFlight Network Forums
steve99

Licence Code invalid for latest version

Recommended Posts

Apologies if already covered, had a look but couldn't locate an answer....

I have licence for FSUIPC I purchased for P3D V3 (FSUIPC V4 I believe). I have all the details and the zip file. I later upgraded P3D to V4 and FSUIPC to V5 to match. I have just reinstalled P3D on a new drive (2T SSD). I am trying to install FSUIPC. If I install the V5, the licence code doesn't work, but if I try V4 instead  (I have the print out receipt so I know I have the correct licence code for that), it won't install as my P3D is now V4 not V3.

Is there a way round this or do I have to buy another FSUIPC? Hope someone can help

Cheers

Steve

Share this post


Link to post
Share on other sites
2 hours ago, steve99 said:

If I install the V5, the licence code doesn't work

Like FSUIPC4 compared to FSUIPC3, FSUIPC5 is a different product from FSUIPC4, with its own registration you need to purchase. Both those changes were massive re-writes costing lots of man-hours, and FSUIPC5 was the first really major revision in 11 years (Sept 2005 - June 2016). I think it justified a new purchase.

2 hours ago, steve99 said:

it won't install as my P3D is now V4 not V3.

Well, it will install, but as Unregistered, so it can be used by FSUIPC applications, and WideFS too. (Incidentally, WideFS is not changed -- the same registration will work for P3D4 as P3D3 and FSX).

Pete

 

Share this post


Link to post
Share on other sites

Ok, thanks, yes I recall it was a big upgrade. I was sure I had the V5 licence detail somewhere as I had the V5 installation file on my PC. Can't find any purchase email though. as I built a fully new PC over Christmas after I switched to P3D V4. I copied most of the files across but not the emails. However as I am using FSUIPC only as an interface link for software that uses it (I do the command mapping to my controllers in P3D), maybe I didn't do the upgrade. 

Is there any way I can check? 

Thanks for the very quick reply though. 

Cheers
Steve

Share this post


Link to post
Share on other sites
1 hour ago, steve99 said:

However as I am using FSUIPC only as an interface link for software that uses it

You don't need to Register FSUIPC for any application using its data interface.

1 hour ago, steve99 said:

Is there any way I can check? 

You can retrieve all your SimMarket purchased registrations via your SimMarket account.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete, I have a new PC and they installed FSUIPC on it, the latest version.  But now I want to buy it and register it.  Yet when I run the program on my PC it doesn't give me any option to buy it, it asks for registration details.  Like the fellow above I too had v4 but now want to buy v5.

How do I do this and get registration information?

Thanks.

Share this post


Link to post
Share on other sites

Go to the SimMarket purchase page for it, of course. See the “How do I pay” section near the beginning of the User Guide, which of course you’ve looked in the FSUIPC Documents folder (in the P3D4 Modules folder)?

Pete

 

Share this post


Link to post
Share on other sites
8 minutes ago, Pete Dowson said:

Go to the SimMarket purchase page for it, of course. See the “How do I pay” section near the beginning of the User Guide, which of course you’ve looked in the FSUIPC Documents folder (in the P3D4 Modules folder)?

Pete

 

Thanks Pete, just bought it.  Never used it for assigning hardware so this is very difficult to figure out.

For example, I'm on the A2A 182 and I figured out (I think) how to get the ailerons and horizontal stab to work and the prop and mixture to work on my Saitek TPM but I can't get the prop to work.  It is either full in or full out, or it'll go full out and when it's full in it goes too far in so the blue handle disappears in the panel.

Is there a YT I can look at on how to set up controls?

 Thanks 

Share this post


Link to post
Share on other sites
2 hours ago, PHII33 said:

For example, I'm on the A2A 182 and I figured out (I think) how to get the ailerons and horizontal stab to work and the prop and mixture to work on my Saitek TPM but I can't get the prop to work.  It is either full in or full out

If you are assigning an axis, you can see the numbers actually arriving from your device. If they don't run smoothly from somethig like -16380 to +16380, or less, but jump from one to the other, then it is a typical Saitek installation bug.

From Windows Control Panel, Device Manager uninstall the device completely including driver. Then re-boot and let Windows sort it out.

Pete

 

Share this post


Link to post
Share on other sites
11 minutes ago, Pete Dowson said:

If you are assigning an axis, you can see the numbers actually arriving from your device. If they don't run smoothly from somethig like -16380 to +16380, or less, but jump from one to the other, then it is a typical Saitek installation bug.

From Windows Control Panel, Device Manager uninstall the device completely including driver. Then re-boot and let Windows sort it out.

Pete

 

It was the DELTA thing.  I have this, a Yoko yoke, VirtualFLy TQ6 dual quad, Ruddo pedals, and the Saitek TPM, the TPM is solid, no spiking like the old Saitek yoke and quads I had.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.