Jump to content
The simFlight Network Forums

P3D v4 Hot Key to set simulation rate

Recommended Posts

P3D V4.3.29.25520    FSUIPC 5.14

I have set the hot key for simulation rate =ctl+Space. In the past with this hotkey the simulation rate was always set to normal.

I don't know when that changed. Now the simulation rate is reduced by only 2 steps, for example from 64 to 16 and from 16 to 4 etc.
The key combination is not assigned to any other function in P3d.
Does anyone have any idea what I can do to set the simulation rate to normal with using the hot key once?
   Thanks a lot Stefan


Link to comment
Share on other sites

1 hour ago, Stefan01 said:

Does anyone have any idea what I can do to set the simulation rate to normal with using the hot key once?

There are 4 controls still defined by P3D4:


Which ones have you tried by assigning, instead of using the Hot Key? Theoretically SIM RATE SET with a parameter of either 256 or 1 (?) should work, but I know it didn't in FSX. I'll check later today, and also look at the Hot Key option.




Link to comment
Share on other sites

It seems to be a P3D4 bug.

SIM RATE and SIM RATE SET controls appear to do nothing, as before.

FSUIPC uses SIM RATE INCR and DECR to change the frame rate to x1 as indicated by 256 in offset 0C1A, set from Simconnect informing FSUIPC of the multiplier (1 is converted to 256 for compatibility with past sims).

I've tested SIM RATE DECR and INCR separately, and they simple don't work properly in P3D4. After using either a couple of times they stop working altogether, and you have to resort to the P3D Options menu.

Worse, setting "slowest" then trying to use SIM RATE INCR causes P3D4 to crash!

I'll try to gether together some more specific information on all this and report it to L-M


Report to L-M done, as follows:



There are 4 "SIM RATE" key events:

KEY SIM RATE and KEY SIM RATE SET appear to do nothing, just as they did in FSX and 32-bit P3D.

But KEY SIM RATE INCR and KEY SIM RATE DECR have worked in past simulators, and these are used to reset to "normal" (x1) rate by an FSUIPC hot key.

These two events now only partially work. How they don't work is difficult to explain, but the easiest thing to try is use the INCR one to try to get to x8 or faster sim rates. Only the first two work -- to x2 and x4. After that the event seems to be simple ignored -- as, then, does the DECR event! It is only safe to go up 2 or down 2. any more and the events stop responding (though, then, oddly, use of SIM RATE SET seems to "re-enable" the DECR after three or more uses of INCR, and vice versa).

It is rather complicated to work out what is really going on, but it certainly needs looking at and fixing. ideally "SIM RATE SET" should also be made to work.





Link to comment
Share on other sites

On 9/2/2018 at 4:52 PM, Stefan01 said:

Thanks for the quick answer. I will wait till P3D has a bugfix.

I have received clarification from L-M who believe it is a misunderstanding, not a bug. To quote them directly:

Sim Rate has always been limited internally to 4X when the aircraft is below about 50 feet AGL. Perhaps this is what you are observing. This is done for usability, as even really small velocities close to the ground would cause immediate crashing at the higher multiples.

I have pointed out that, misleadingly, the on-screen and menu selected rates, as well as the return from SimConnect which FSUIPC uses, do state the rate above 4x, but checking the clock you will see it is still 4x.

The further clarification was:

What you are setting is actually a "requested" rate. You can continue to change the rate, but below the altitude limit the rate is limited to a maximum of 4X. When above that altitude, the request will be honored.

So, I hope that explains what you are seeing.


Link to comment
Share on other sites

Hi, Pete,
Thank you very much for the clarification. I actually used the time acceleration on the ground to shorten the waiting time until the brakes cooled down.
I would never have thought that the function depends on the altitude.
Thanks again for the quick clarification.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.