Jump to content
The simFlight Network Forums

FSUIPC7 Becomes Unresponsive


jaybird1nyc
 Share

Recommended Posts

I'm having an issue that hasn't been previously reported, as far as I can tell.

FSUIPC7 (latest version but previous versions also) starts and runs fine, either when started before MSFS or after MSFS is already running.  I have successfully assigned and calibrated various axes.  The problem is when selecting either "Buttons & Switches' or 'Key Presses'' from the UI the program will hang and become unresponsive. I can never get to those functions because as soon as either is clicked the entire menu bar greys out and then nothing is functional thereafter.  The only way to end the program is through task manager.  Interestingly, task manager does report that 'IPC interface..'  is functional and available however nothing works in the sim any more, ie: none of the assigned axes are functional.

I've attached my last log file but I don't think it shows any problem happening.

Thank you for any insight you may have,

Jay 

FSUIPC7_log.zip

Link to comment
Share on other sites

27 minutes ago, jaybird1nyc said:

I've attached my last log file but I don't think it shows any problem happening.

No, it doesn't show anything. The log is also very small - no need to zip it!

28 minutes ago, jaybird1nyc said:

The problem is when selecting either "Buttons & Switches' or 'Key Presses'' from the UI the program will hang and become unresponsive.

Every time? And you say also on previous versions? Did you try accessing those dialogs from the system tray icon (right click and select appropriate option)?

I'm a bit flummoxed by this. All that selecting an option does is show a dialog box. I'll look to see if there is any logging I can add if this persists. For now, maybe you could try without loading the PFCcom64.dll to see if that makes a difference - just temporarily rename it.

Maybe also show me your FSUIPC7.ini - and try (temporarily) renaming that (a new one will be generated) to see if its caused by some strange content in that file.

 

 

Link to comment
Share on other sites

It may also be due to a bad driver as it could be hanging when scanning your devices (although it also does this on start-up). You could try downloading and running the HidScanner utility (from Download Links -> Useful additional programs) to see if that reports anything. Also check your windows devices to make sure the drivers registered there look ok.

Link to comment
Share on other sites

Hi John,

Yes, it happens every time.  I'm about 5 versions in and it's happened on all.

I've tried accessing those dialogs from the system tray, right-click and double-click, and also via alt-F, no joy.

It also happens even when MSFS isn't running at all. (does PFCcom64.dll load anyway?)

I'll try renaming PFCcom64.dll and give that a shot.  I'll also try running HIDScanner, however nothing is noted in device manager and all hardware works normally.  And yes, renaming FSUIPC.ini as well.  If none of those things have any effect I'll send you the ini.  Oh, I should've mentioned that the ini is from a clean install, no other version's ini was brought over.

Link to comment
Share on other sites

It could be that the windows are being "displayed" but some where outside your screen coordinates. As its modal, it will block the main FSUIPC window until its closed. Not sure what would cause this though. And it should also be the same with the Axes assignments dialog if that was the case. Anyway, I'll take a look. I'll post you a version to try with extra logging.

No need of the ini at the moment.

2 hours ago, jaybird1nyc said:

It also happens even when MSFS isn't running at all. (does PFCcom64.dll load anyway?)

Yes, it loads, but I don't think it does much (if anything) until the sim is connected and the ready-to-fly flag is set.

Link to comment
Share on other sites

@jaybird1nyc Could you try the attached build please. Run it (doesn't matter if FS sim is running or not). and then open and close the axes assignment dialog (from main window, not directly from the tray icon). Then try to open the button & switches assignments dialog, again from the main window. You will then have to forcibly close FSUIPC7, and send me the FSUIPC7.log file. Thanks.

 

FSUIPC7.exe

Link to comment
Share on other sites

You were right about the window positioning.  My version was opening the dialog at the bottom of the screen, and as you correctly surmised, the new dialog was opening off-screen.  It must have been the window positioning values from a much earlier version that were still in my .ini because renaming mine and having a new one generated also fixed the issue.  I also tried the version you just sent and that work fine as well (with a newly generated .ini).  I just copied your new window position values to my .ini and all is well!

Thank you very much for getting me squared away John, great work!

Jay

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.