Jump to content
The simFlight Network Forums

FSUIPC4 macro issue

Recommended Posts

Hi Pete,


thank you first of all for this amazing tool you did!


I'm trying to build my home cockpit and for that I use FSUIPC4(v4.975a) on FSX.

I did my first macro to trigger a LVAR and after tons of trials and a lot of youtube videos I simply can't get it to appear on the FSUIPC "Control sent ..." drop down list, which makes me think that it is not loaded...

I dump the LVARS for my airplane using the FSUIPC method "List local Panel Vars".


macro file(named:HDGKP.MCRO)



The ini file

at the end of the ini the LuaFiles section




- Registered FSUIPC

- Addons: RAAS Professional, ActiveSky2016, TrafficX

- Add-on Airplane: A320 airbus extended


You can find attached the log and ini file.


So, I really don't know what I'm doing wrong. Could you please give me some hint?

Thank you so much in advance.

FSUIPC4.4.log FSUIPC4.ini

Edited by Rodrigo Parra
Link to comment
Share on other sites

14 hours ago, Rodrigo Parra said:

Ok I just realized reading the extension of the macro file was incorrect.... actually mcro.txt as I didn't turn on the file extension viewing on windows explorer. 

After fixing it everything worked just perfect!

I have the same problem. What did you turn on  exactly? 

I have only created the macro file, Do i need to edit ini files aswell?

Link to comment
Share on other sites

1 hour ago, pannam said:

I have the same problem. What did you turn on  exactly? 

This is described in the User Guide, p6:


Finding and Editing files relating to FSUIPC and WideFS
Normally, when asked to check, post, edit or otherwise handle a file in a Windows folder, you will use Windows
Explorer to find it and select it. There are some things you need to know here, because Microsoft, in its wisdom, has
decided that, with effect from Vista, it should hide some important parts of filename from you, by default.

I recommend you change this nasty habit. Open Explorer and find the Tools-Folder Options selection. Then select the
View tab. Some way down the displayed list, find and uncheck "Hide extensions for known file types". After you do
this, INI files will show as ".ini" and not just as "configuration settings", and LOG files will show as .log and not just as
"text file".



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.