Jump to content
The simFlight Network Forums

Help with FSUIPC7 and Running a Lua Script


Recommended Posts

Hey everyone, new to FSUIPC and the forums here. I know there have been a few threads regarding the Honeycomb Bravo Throttle and the switches above 32 (or 0-31). However, nothing I have found in those threads have worked so far. I'm sure it's error on my end as I'm not familiar with using FSUIPC and lua scripts. All I'm trying to do is use the assignment feature to assign the switches outside of MSFS so I can get around the HDG and ALT 10x increment from the "always on" switches. I've tried the HidDemo.lua script and the one that was supposedly edited specifically for the bravo. I haven't had any luck with either of these getting FSUIPC to recognize the switches. I've verified the vendor and product numbers are correct in the script and added it to the fsuipc.ini to automatically run. Any ideas?

For reference I'm using a logitech yoke, bravo throttle, and CH pro pedals

Link to comment
Share on other sites

First, you posted in the FAQ section where it explicitly says NOT for support requests. I have moved your post for you this time, but please take care to post in the correct forum for any future support requests.

There are so many posts on this topic now. There are dedicated lua scripts for the Honeycomb Alpha and Bravo, please see 

If using the Bravo, to control the LEDs you can also use this: 


Link to comment
Share on other sites


'm still having no luck getting FSUIPC to recognize the seven switches on the bravo. I'm using the hidBravoButtons.lua script and not getting anything. In the button/switches assignment window, other buttons on the bravo show as joystick A, while the saitek yoke shows as Joystick B. I noticed the hat switch on the yoke has buttons up to about 38 or so, but nothing over 31 is showing for the bravo. Is there something in the script that I need to edit that's causing the switches to not be recognized?

Have you verified the script is running? Did you add it to the [Auto] section of your FSUIPC ini file?
Please attach your FSUIPC7.ini and FSUIPC7.log files and I'll take a look.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.