Jump to content
The simFlight Network Forums

7.2.3 doesn't load my .lua scripts specified in the [Auto] section


kaha
 Share

Recommended Posts

Are you sure? Lua scripts are now not started until the aircraft is loaded and ready to fly,and if using the WASM module, lua scripts are not started until after the lvars have been received from the WASM module.

Are you using the WASM module (i.e. do you have the WAPI enabled in your FSUIPC7.ini file)?

Load an aircraft and get ready-to-fly. If your luas aren't started, shutdown  MSFS and show me your FSUIPC7.ini and FSUIPC7.log files.

Note I also just release v7.2.4, so you should update.

Link to comment
Share on other sites

Your log shows that you do not have the WASM module installed:

     281 *** FSUIPC WASM module not detected - not adding WASM menu

But you have activated the WAPI in your FSUIPC7.ini@
   [WAPI]
   EnableWAPI=Yes

Either install the WASM module (you can download the latest installer to do this - it has been updated to 7.2.4), or disable the WAPI if not using lvars/hvars/calculator code.

John

Link to comment
Share on other sites

Thank you. It worked before, I didn't change anything in the .ini

 

The logs I sent are from 7.2.3 were with the 7.2.4b exe file. I now updated to 7.2.4, did not change the .ini file (still EnableWAPI=Yes) and did not install the WASM module. But now everything works again. Files attached.

logs_724.zip

Link to comment
Share on other sites

2 minutes ago, kaha said:

The logs I sent are from 7.2.3 were with the 7.2.4b exe file. I now updated to 7.2.4, did not change the .ini file (still EnableWAPI=Yes) and did not install the WASM module. But now everything works again. Files attached.

Well, I don't know what you did, but the WASM is now installed and working:
       126469 Lvars/Hvars received - checking aircraft autos....

If you re-installed, it would install the WASM module by default.

John

Link to comment
Share on other sites

Just now, kaha said:

Anyway, it now works.

Yep, not sure what happened...

One thing you should do though is change the following settings in your FSUIPC7.ini file in the [General] section:
    TrafficStallTime=1
    InitialStallTime=30
    NormalStallTime=1
to

    TrafficStallTime=-2
    InitialStallTime=120
    NormalStallTime=-2
 

This will prevent FSUIPC re-connecting when data stalls, which can cause FSUIPC7 to run out of simconnect connections in some circumstances.
Changing the traffic and normal stall times to a negative number will tell FSUIPC7 to just log a message when data stalls rather than re-connect.

John

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.