Jump to content

turn off RAW mode


Recommended Posts

4 minutes ago, Gleb Danilenko said:

I did mistake and activated raw mode in Axis Assignment.

See the User guide, P36:

Quote

Note that, in the illustration the ‘Raw’ option is disabled (greyed out). This is because I have other axes on the same joystick
already set using the normal calibrated input. This is a restriction on the way the Windows API works when polling joystick
axes. All 6 axes on a specific joystick must be read in the one mode, calibrated or raw. You cannot mix the modes on a single
joystick. If you need to change the Raw/Calibrated option once an axis has been assigned, you will first have to clear all axis
assignments on that joystick.

 

Alternatively, you could try manually editing the ini, removing the raw specifier and changing the delta back to 256 (from1) - see the Advanced User guide for the format of the axis assignment lines in your .ini, P41:

Quote

For the main axis entry (explanation of values below):
    n=ja,(R)delta(/delay)
where the parentheses merely show optional parts, and
    j = joystick # (0 to 18, 16 to 18 being PFC)
    a = axis (XYZRUVSTPQMN)
    R is only present when "Raw" mode is selected
    delta is the delta value (eg 512, or 1 for Raw mode and POVs)
    /delay is an optional delay*, in milliseconds

 

John

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.