Jump to content
The simFlight Network Forums

FSUIPC7: Weird problem with additional Axis settings


Recommended Posts

Seems I have a problem with FSUIPC7.

Every time I change or add AXIS settings in PROFILE SPECIFIC mode, something goes wrong. Either all old or some AXIS settings are erased after adding new axis commands.

Today I added a spoiler axis to my Mooney MR20:

Old settings:

[Axes.Mooney MR20]
0=AR,256,F,65765,0,0,0    -{ TO SIM: AXIS_THROTTLE_SET }-
1=AU,256,F,66292,0,0,0    -{ TO SIM: AXIS_MIXTURE_SET }-
2=AV,256,F,66291,0,0,0    -{ TO SIM: AXIS_PROPELLER_SET }-
3=BX,256,F,65763,0,0,0    -{ TO SIM: AXIS_AILERONS_SET }-
4=BY,256,F,65762,0,0,0    -{ TO SIM: AXIS_ELEVATOR_SET }-
5=CX,256,F,66387,0,0,0    -{ TO SIM: AXIS_LEFT_BRAKE_SET }-
6=CY,256,F,66388,0,0,0    -{ TO SIM: AXIS_RIGHT_BRAKE_SET }-
7=CZ,256,F,65764,0,0,0    -{ TO SIM: AXIS_RUDDER_SET }-

After adding the Spoiler Axis, these were the settings:

[Axes.Mooney MR20]
0=AY,256,F,66382,0,0,0    -{ TO SIM: AXIS_SPOILER_SET }-
1=CX,256,F,66387,0,0,0    -{ TO SIM: AXIS_LEFT_BRAKE_SET }-
2=CY,256,F,66388,0,0,0    -{ TO SIM: AXIS_RIGHT_BRAKE_SET }-
3=CZ,256,F,65764,0,0,0    -{ TO SIM: AXIS_RUDDER_SET }-

All other Axes settings were gone !

Now that I know that this happens, I ALWAYS make a backup of the FSUIPC7.ini when I changed it. So that I can enter settings manually from the backup file if they were erased.

But it's a bit annoying. Any help ?  THANKS in advance!

Link to comment
Share on other sites

This is very strange, and I am not sure how this is possible.... I have just tried with several different profiles and cannot repeat this.

Next time you do this (i.e. add a profile-specific axis control), can you check if your existing axis assignments are visible. I can only assume that the original axis assignments weren't loaded for some reason. but as some of the assignments are preserved, this doesn't seem likely. If you keep your FSUIPC7.ini file open in an editor, it will get updated when you open the axis assignments panel - check the axis assignments are still there when you do this (you will need to reload the file), and then reload and check again once you have added the additional assignment.

Can you also make sure that you are using the latest version, v7.2.10, and check that you have not installed FSUIPC in a windows protected folder, such as Program Files or Documents. If you have, please uninstall and re-install into a different location.

Also, can you attach the full FSUIPC7.ini files next time, both before and after, so I can check the whole file.




Link to comment
Share on other sites


Hi John,

As it is always, I couldn't reproduce the error either...

what I can tell you so far: I use v.7.2.10 installed in D:\FSUIPC7 . And only one [Axes.Mooney MR20] in the ini.

I tested by adding a new livery, and all worked as it should. Think I will do some more testing, I remember that when I first installed FSUIPC I had that error when adding a new plane. Think it had something to do with the "Profile Specific" setting. Perhaps a certain order of the steps.

I will do some more testing and I'll be back when I have this error again.

Thanks for your help!


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.