Jump to content
The simFlight Network Forums

Selecting FSUIPC6 from P3D addon menu crashes P3D

Recommended Posts

Peter:  Please help me with my P3Dv5 CDT.  Thanks in advance.....Gary

Windows 10

Setup: P3D v5.2 is running with registered FSUIPC6.16, Active Sky P3D5 NOT running

  • 1. Selected FSUIPC from P3D’s addon menu
  • 2. FSUIPC opens and I immediately cancelled out of FSUIPC.
  • 3. P3D now stalls and crashed to desktop (CDT) after 20 seconds. Log file follows.

FFSUIPC6 Log 30Nov21.logFSUIPC6 Log 30Nov21.logFSUIPC6 ini 30Nov21.log

I I also ran a second P3D startup and log file with Active Sky P3D5 running, same problem. Problem happens with PMDG and any P3D native aircraft, with or without P3D’s WX file.

Link to comment
Share on other sites

Sorry Paul, I think I posted this problem in the wrong support forum. Am I in the correct Forum?

Thanks Pete, for your reply. I'll check on your questions and get right back you. Thanks for taking time from your busy day.


Link to comment
Share on other sites

Yes John, I verified this happens regardless of aircraft location. Whenever I exit FSUIPC, I get P3D CTD.

Yes, this is a new issue, after I installed and ran P3D v5.1.12.26829 (client only), I would start Active Sky for P3D. Whenever I would start P3D without Active Sky (AS), the problem went away, that is, I could freely enter and exit FSUIPC without CTD issues.

Recently I upgraded to P3D v5.2.22.27615 and current version of AS for P3D v5. Then the problem returned. P3D  CTD  upon exiting FSUIPC6.1.6, regardless if I had AS for P3D running or not. Recently I also installed PMDG with extension 737 NGXu.

I do need FSUIPC soon for many settings for PMDG 737 NGXu.

No idea which program is responsible for the P3D CTD. No idea what “LogonUI.exe” is in the Events Log  that’s causing a million errors in the log.

I checked Windows Event Viewer in test case 2 below, sample error messages are available from my link below.

Test Case 1 –

  • 1.      Started computer with Win 10 from computer off state.

  • 2.      Started P3Dv5.2, with Chase Plane Little NavMap and Spadnext. No Active Sky.

  • 3.      Launched native P3D aircraft from KBFI using a pre-loaded scenario. Default weather settings. FSUIPC.ini with NO WEATHER AT ALL=Yes.

  • 4.     Opened FSUIPC616 and immediately cancelled out of FSUIPC to P3D.

  • 5.      P3D hung for 30 seconds and CTD.

  • 6.    Ran Test case 2.

Test Case 2 –

  • 1.      Repeated test case 1 except with Win 10 already running and NO Active Sky. Started from different airport, 21W, Ranger Creek.

  • 2.      Same result, CTD on leaving FSUIPC.

  • 3.      Saved FSUIPC.log and FSUIPC.ini for this test case. Saved sample of entries from System Tools>Event Viewer>Windows Logs>Application. I save some of the beginning errors and the same errors repeated may times farther into the log. This saved file and the two FSUIPC log and ini files may be viewed at

  • https://drive.google.com/drive/folders/1THdrZXv_gWdAzcEOvPJO-OTv3KTqou31?usp=sharing

  • Simply double-click to open the FSUIPC Test Cases folder and view or download any of the 3 files.

 Test Case 3 --

  • 1.      From Win 10 control panel, I uninstalled Active Sky for P3D.

  • 2.      Shut down computer, not a restart.

  • 3.      Started computer and started P3Dv5 with no addons.

  • 4.      Selected FSUIPC from P3D addons menu and immediately cancelled out of FSUIPC. Same result, P3D CTD.

  • 5.      Re-installed latest ASP3D as administrator.

  • 6.      Restarted P3D with ASP3D and all other addons.

  • 7.      Selected FSUIPC from P3D addons menu and immediately cancelled out of FSUIPC. Same problem, P3D CTD.

Test Case 4 –

  • 1.      Removed P3D v5.2 from computer. Downloaded and installed P3D v5.3, full version, per your suggestion.

  • 2.      Removed FSUIPC 6.1.6 from computer , expanded previously downloaded FSUIPC.zip file and installed again.

  • 3.      Started P3D v5.3

  • 4.      Selected FSUIPC from P3D addons menu and immediately cancelled out of FSUIPC. Same problem, P3D v5.3 CTD.

Now I’m stuck and at a loss with what’s happening. Thanks for your ideas in advance.

Thanks, Gary

Link to comment
Share on other sites

20 hours ago, garyzink said:

I'll hold my report until I install P3Dv5.3. I'll try client only installation first.

You cannot just install the P3Dv5.3 client - you need to uninstall P3D completely and install the full P3Dv5.3, including scenery and content.
From the P3Dv5.3 release notes (https://www.prepar3d.com/news/announcements/2021/12/120925/😞


Please be aware that unlike previous version updates both content and scenery are required to be updated with version 5.3. Completely uninstalling the previous verions and running the full installer is recommended.

Please do that before I look at any of your logs.



Edited by John Dowson
Further info added
Link to comment
Share on other sites

OK John, I removed P3D v5.2 and installed the full version of P3D v5.3 as indicated in my test case 4 above, but failed to run new log files. I'll re-run test case 4 and run P3D v5.3 again, with FSUIPC6.1.6 and post resulting log files, sorry for my forgetfulness.

Gary Zink

Link to comment
Share on other sites

13 minutes ago, garyzink said:

I removed P3D v5.2 and installed the full version of P3D v5.3 as indicated in my test case 4 above

Ok, sorry - missed that. And you are providing too many log files... I am only interested in seeing the latest ones, with P3Dv5.3, and I will take it from there. Your issue is very strange, not heard of anything like this before...Will probably need more logging added to trace this., but I'll wait until I see your initial log files. Also, please attach your FSUIPC6.ini with your FSUIPC6. log file.


Link to comment
Share on other sites

Hi John,

I think I can save you a lot of time. After another CTD, a new message came up: "NVIDIA GeForce RTX 2070 Super stopped working due to DXGL_ERROR_ACCESS_Denied error. Aborting , exit Prepar3D......."

Apparently this has nothing to do with FSUIPC6 at all. Coming out of FSUIPC6 triggered the scenery re-display and my video card failed to handle that due to a access error. Furthermore, after I gave full permissions to my P3D installation directory and its subdirectories, the CTDs disappeared and all is now working fine again. No idea how the permissions got messed up. No wonder you never heard of this problem -- it had nothing to do with FSUIPC. Whenever something wierd and illogical happens now, I'll first check directory permissions. So glad now.

I want to thank you for your time, concern and immediate help on this matter and I'm very sorry to trouble you. You can close this case.

Thanks so much, Gary

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.