Jump to content
The simFlight Network Forums

No toe brakes


Chad P

Recommended Posts

Good morning,

I am using fsuipc7 for all my axis and it works, onyl the toe brakes axis won't be recognize by the sim. The axis is working in the calibration windows in fsuipc 7, but when I am pressing the axis in the sim, there's noting.

I've tried different options like 'send direct to fsuipc calibration' or send 'to fs as normal axis but the problem is always there.

 

Link to comment
Share on other sites

Which aircraft are you using? If its a default one or an add-on that I have then I can check here for you. Otherwise, you can try logging axis controls, operate the toe brakes in the UI and see if anything is logged in the FSUIPC7 console window - if you open the console window you can see what is logged as you activate the toe brakes in real-time.

John

Link to comment
Share on other sites

Hi John,

this is the FBW a320 Mod in the exp. version.

When I am enabling logging, the logging file is flooding with inputs (it's about 85 MB in an hour). This is a little part of the log (without touching anything standing at the gate):

 

  7463172 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463172 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463172 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463172 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463203 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463203 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463203 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463203 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463235 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463235 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463235 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463235 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463266 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463266 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463266 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463266 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463297 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463297 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463297 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463297 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463328 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463328 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463328 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463328 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463360 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463360 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463360 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463375 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463407 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463407 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463407 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463407 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463438 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12840 (0x00003228) AXIS_LEFT_BRAKE_SET
  7463438 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12840 (0x00003228) AXIS_RIGHT_BRAKE_SET
  7463438 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463438 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463469 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12839 (0x00003227) AXIS_LEFT_BRAKE_SET
  7463469 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12839 (0x00003227) AXIS_RIGHT_BRAKE_SET
  7463469 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463469 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463500 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12839 (0x00003227) AXIS_LEFT_BRAKE_SET
  7463500 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12839 (0x00003227) AXIS_RIGHT_BRAKE_SET
  7463500 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463500 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET
  7463532 ***  AXIS: Cntrl= 66387 (0x00010353), Param= 12839 (0x00003227) AXIS_LEFT_BRAKE_SET
  7463532 ***  AXIS: Cntrl= 66388 (0x00010354), Param= 12839 (0x00003227) AXIS_RIGHT_BRAKE_SET
  7463532 ***  AXIS: Cntrl= 66818 (0x00010502), Param= 0 (0x00000000) STEERING_SET
  7463532 *** EVENT: Cntrl= 65700 (0x000100a4), Param= 1 (0x00000001) GEAR_SET

Link to comment
Share on other sites

2 hours ago, Chad P said:

When I am enabling logging, the logging file is flooding with inputs (it's about 85 MB in an hour).

Yes, this is now quite usual with MSFS aircraft, especially airliners and the FBW A320... The logging shows that it is using the standard Axis Left/Right Brake Set control, so that should be working... However, the parameter logged for that control doesn't vary much - just 12840 and 12839, and both always the same, which us unusual - very difficult to apply the same pressure to each, even via the UI...
I'll take a look later (or more probably tomorrow now), but in the stable or dev version of the FBW A320. I am not going to switch to the experimental - and I suggest you always try with the stable or dev if having problems with the experimental.

One thing you could also try is to do the same test, but using your toe brakes. Use each one individually through its full range, and see what parameter is logged as you do this. You can report what you see (no need to attach the log) if it looks strange, and maybe also attach your FSUIPC7.ini so I can see your configuration.

John

Link to comment
Share on other sites

2 hours ago, Chad P said:

Yes I've tried it with the same results, no brake, in other ac the same problem.

Then you have either assigned incorrectly or there is an issue with your hardware (possibly the axus are registered as digital on/off axis). Please attach your FSUIPC7.ini and a full FSUIPC7.log file. for the latter, you need axis logging activated, and with the aircraft loaded activate each toe brake through its full range and then exit - you can zip the log if it is too large to attach as-is.

John

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.