Jump to content
The simFlight Network Forums

FSUIPC doesn't start with MSFS


Aman Lulo
 Share

Recommended Posts

Hi, since the last FSUIPC version, FSUIPC started with MSFS, but after installing the latest one (7.3.3), it doesn't start automatically anymore, I have to click OK on the home page. Of course I checked the "Start with MSFS" option.

   Thanks for any help & regards,

          Fulvio

Link to comment
Share on other sites

20 hours ago, Aman Lulo said:

have to click OK on the home page.

What do you mean by this?

Did you follow the instructions in the README.txt for this issue? If not, please do that. And see this post (and onwards) as this issue has already been reported:

So, check your EXE.xml. If that is correct and FSUIPC7 isn't starting, then you will have to revert to the old way of starting FSUIPC7, which is via the MSFS.bat file. Instructions on how to do this are given in that topic (above).

John

Link to comment
Share on other sites

8 minutes ago, Aman Lulo said:

OK, I used the alt+F key, it's fine!

Ok - so it was auto-starting...when it starts you should see the FSUIPC7 splash screen and then it is iconised to your system tray. Alt+F is the (default) hot-key which opens the FSUIPC7 main window - you can also do this from the system tray icon by double-clicking or using the left-click context menu. Please see the provided documentation (which will be installed under your Windows Documents folder) - as well as the README.txt which is only available in the downloaded zip file.

John

Link to comment
Share on other sites

John,

I have also had a problem with this happening.

It only started happening after I updated to SU9 yesterday afternoon. I had v7.2.10 running quite happily before that. Post upgrade to MSFS 1.25.7.0 the FSUIPC7 splash did not start. Nothing appeared in the system tray.

tried running FSPanelServer but it sat waiting for FSUIPC7.

 

I considered that I might need the latest version so upgraded to 7.3.3 and tried again. Exactly the same. So I startedFSUIPC7 manually and FSPanelServer connected.

So after reading the docs I tried to clear everything out. Uninstalled 7.3.3, renamed the EXE.xml file, ensured that fsuipc-lvar-module was gone from the community folder.

Reinstalled 7.3.3 to autostart. Checked the backed up EXE.xml file with the regenerated one and found that it was the same. Checked the Community folder and fsuipc-lvar-module was there.

Still no splash screen on MSFS start, still nothing in the system tray, also no FSUIPC7.log file generated. Again once I started it manually, FSUIPC7 appeared in system tray. I even tried setting FSUIPC7 to administrator mode.

The only other relevant info that I can think of is that I am running the latest Windows 11 21H2 version 22000.652

 

I think I have exhausted everything I can to be helpful. It seems that the issue is that the fsuipc-lvar-module does not get run under SU9, or at least that and the combination of the latest version of Windows 11.

Install file and exe.xml files attached. Let me know if you need something else.

InstallFSUIPC7.zip EXE.zip

Link to comment
Share on other sites

1 hour ago, Firebird56 said:

The only other relevant info that I can think of is that I am running the latest Windows 11 21H2 version 22000.652

I don't think this can be an issue, but I am still on 21H2 22000.651. I am updating to the latest update (KB5012643) now and will check...

1 hour ago, Firebird56 said:

It seems that the issue is that the fsuipc-lvar-module does not get run under SU9

Why do you think that? The FSUIPC7 and the WASM module are two distinct components. When you start FSUIPC7 manually does it connect to the WASM (e.g. can you list lvars)? If so, the WASM has started with MSFS, it is just that MSFS is no longer starting FSUIPC7 from the EXE.xml.

I have no idea why this is now happening for a few people. All I can suggest is that you go back to the old method of starting FSUIPC7 directly from the MSFS.bat file. See the link I posted above on how to do this.

John

Link to comment
Share on other sites

57 minutes ago, John Dowson said:

I don't think this can be an issue, but I am still on 21H2 22000.651. I am updating to the latest update (KB5012643) now and will check...

I've updated now and still all ok here. I also updated to SU9 (v1.25.7.0) and auto-start is still working.
Another user who experienced this issue has found a solution that works for him - see 

Maybe check that you have not set FSUIPC7 to run with Admin privileges...

John

 

Link to comment
Share on other sites

John, Thanks for responding.

I have read the posts of the other person who had problems but the FSUIPC7 folder had the normal user settings, and I had set the exe to not run in admin mode. I did my individual user settings to the exe but that made no difference either.

I then tried the MSFS.bat file launch and that also fails to work.

I am going to try some other folder settings and any thing else I can think of but I am willing to try anything else you can think of.

 

Something changed in SU9 that has caused this, as two versions failed to be launched automatically after update. I feel confident in ruling out FSUIPC7, with the info I have.

Link to comment
Share on other sites

4 minutes ago, Firebird56 said:

I then tried the MSFS.bat file launch and that also fails to work.

Did you remove the comments so that the bat file starts FSUIPC7? I cannot see how that fails to start FSUIPC7...it is just a standard bat command to start an executable...

6 minutes ago, Firebird56 said:

Something changed in SU9 that has caused this

Are you using an MS Store installed MSFS or a Steam version? I'm on Steam and have no issues here.
If it was an issue with SU9, I would have expected a lot more reports of this issue.

Link to comment
Share on other sites

As John mentioned, It can be made to work using the .bat file. When you install FSUIPC, remove the checkmark to autostart FSUIPC with MSFS. Then, at the end, add the desktop shortcut. Edit MSFS.bat in the FSUIPC7 install folder and remove the "::" in line 34 so it looks like so:

start "" "C:\FSUIPC7\FSUIPC7.exe"

Then FSUIPC will start as before if you launch MSFS using the desktop MSFS shortcut.

Randy

P.S. I'm using the store version and FSUIPC won't start from the exe.xml file (SU9).

Edited by RRVyper
More details.
Link to comment
Share on other sites

15 hours ago, RRVyper said:

Edit MSFS.bat in the FSUIPC7 install folder and remove the "::" in line 34 so it looks like so:

start "" "C:\FSUIPC7\FSUIPC7.exe"

Also a good idea to remove the comments from the delay/timeout line as MSFS takes such a long time to load:

:: wait for MSFS to start (2mins)
timeout /t %delay% /nobreak > NUL
 

John

Link to comment
Share on other sites

OK some update.

Firstly checked the .bat file and you were correct in that the line to start was commented out. It then ran OK, even with the delay line commented out. It started almost straight away but worked with no problem.

i tried uninstalling FSUIPC and moving it to the default location. I tried altering various folder permissions but nothing worked.

What does work is the MSFS.bat although I would prefer not to use that, for personal reasons. Also starting it manually is fine, plus starting as an autorun on system startup works.

I checked MSFS for errors running EXE.xml and there was nothing.

 

So to some up. It runs every way you can think off EXCEPT the autostart. It seems that there is no error in MSFS concerning EXE.xml. Now I would agree that if there was a general error you would have had a lot more people reporting this, or I would like to think so, so it must be a certain set of circumstances that a minority hit that causes it not to work.

The only file that I can think of that might be of some use that you haven't seen is the FSUIPC7.ini file so i have attached it here.

The only other pieces of info that I can think of is that my FSUIPC is not registered, I am not using WideFS7. I am using the -FastLaunch option for MSFS, but I do not think this is a factor as the MSFS.bat starts it that way as well.

So any other ideas or suggestions that you can think of, or debug info that I can provide?

The only other option I can think of is completely uninstalling MSFS and reinstalling but I would rather not go down that route UNLESS the cause for problem is identified.

FSUIPC7.zip

Link to comment
Share on other sites

1 hour ago, Firebird56 said:

The only file that I can think of that might be of some use that you haven't seen is the FSUIPC7.ini file so i have attached it here.

That is because this is not relevant to auto-start.

1 hour ago, Firebird56 said:

So any other ideas or suggestions that you can think of, or debug info that I can provide?

Check that you have not set FSUIPC7 to run as administrator, check your installation location, and check the permissions on the FSUIPC7 installation folder.
Please see 

 

John

Link to comment
Share on other sites

Absolutely no problem.

As I said before I have uninstalled/reinstalled the two versions several times. What I can say is that the folder is D:\FSUIPC7 which is its original location. I have double checked and the FSUIPC7.exe does NOT have admin rights set

The folder security has 4x group/users set. CREATOR OWNER, SYSTEM, Administrators and Users. SYSTEM and Administrators are set to full control. Users is set for Read & Execute, List Folder Contents, Read and Write. Finally CREATOR OWNER is set for Special Permissions only.

Although I did change various things though various tests, the current installation has had nothing altered.

Anything else that you would like?

Link to comment
Share on other sites

12 hours ago, Firebird56 said:

Anything else that you would like?

I have nothing more to say on this matter that hasn't been said already. If auto-start via the EXE.xml isn't working, just use the MSFS.bat method to start FSUIPC7 or start it manually.

 

Link to comment
Share on other sites

Whilst I was waiting for you to respond, I had a thought and carried out some more testing. What I found is that the issue IS either related to the EXE.xml. I am not saying that it is causing it, merely that the cause is related to it.

What I decided to do was carry out a test with a clean Community folder with just the fsuipc-lvar-module in it. Hey presto! FSUIPC started automatically.

Fortunately I use MSFS Addons Linker to manage my addons which makes the admin of the next part a lot easier. So I started to add them one group at a time and re-test. All successful until one section when it failed so I started the load only part of the total process to narrow down the issue to an addon.

What I found was quite strange. It failed at 45 out of the 91 addons, so by a process of elimination I went down to 15 addons and it loaded OK. It failed at 20, 17 and 16. So I expected it to load when i went back to 15. It did not. I tried the first 10 and it failed again. Cleared out everything bar fsuipc-lvar-module again and it was again successful.

So I started again and it failed in an earlier group than the first attempt. The same attempts to clear the problem hit the same issues.

So at the moment my best guess is that it seems that the issue is related to the addons matrix that MSFS builds on startup. It is currently the only thing that makes sense from the tests, i.e the problem does not manifest itself at the same place each time. How exactly this is preventing the EXE.xml loading I don't know. Whether it is related to the number of addons you have or your system memory, again I currently can't tell.

Hopefully this is useful in identifying the root cause.

Link to comment
Share on other sites

20 minutes ago, Firebird56 said:

Hopefully this is useful in identifying the root cause.

Not for me - there is nothing I can do about this - it is (obviously?) an MSFS issue, and nothing to do with FSUIPC. I really don't understand how add-ons in the Community folder can affect the functionality provided by the EXE.xml file.

I suggest you raise a bug with MSFS/Asobo and report your findings there, as it is they who need to look into this.

Cheers,

John

Link to comment
Share on other sites

Today I updated FSUIPC7 on my Windows 11 laptop (21H2 OS build 22000.652). My previous issue was on my desktop PC running Windows 10. Strangely, FSUIPC would not auto-start via the exe.xml, and I checked that FSUIPC7.exe was not set to run as admin. It is the only program set to load via the exe.xml. Also, I have relatively few addons in the Community folder (11) compared to the Win10 PC. I'll try some tests myself to see what I can find.

Randy

Link to comment
Share on other sites

I decided to start MSFS as administrator and this time FSUIPC started automatically. Thinking I had stumbled onto something, I tried MSFS again without running it as admin and FSUIPC started automatically anyway?! I then rebooted, started MSFS normally and FSUIPC did not start (but I noticed a 10-15 sec. freeze in the MSFS loading screen approximately at the point when I would see the FSUIPC logo). I shut down MSFS, started it again as a normal user, and FSUIPC started fine.

I guess the batch file method is the most reliable way to start FSUIPC. At least for me.

Randy

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.