Jump to content
The simFlight Network Forums

MSFS not communicating with PFC's Cirrus II console.

Jeff Enlow

Recommended Posts

I  recently bought a new computer with Windows 11. I installed a serial card DB9 to interface with the console. I also installed FSUIPC7 v7.3.21 for MSFS. When selected it brings up MSFS but the Cirrus II console will not operate with MSFS. The Serial card driver is installed and says it is working per the device manager.


Any help with this would be greatly appreciated!


Thank you in advance.



Edited by Jeff Enlow
Link to comment
Share on other sites

14 hours ago, Jeff Enlow said:

I downloaded and placed in the fsuipc7 folder. Still no change.

You have to do more than that. As i said, please read the provided documentation on how to configure FSUIPC to use the PFC driver - the PFC DLL User Guide.
Once you have read that and configured correctly, if you still have problems then please show me/attach your FSUIPC7.ini file, FSUIPC7.log file and PFCcom64.ini and PFCcom64.log files.

But there is no point in attaching these until you have at least read the documentation and tried to configure this yourself.

Link to comment
Share on other sites

Your log shows:


      109 Loaded PFChid64.dll okay!

Why have you installed the hid/usb driver and not the com/serial driver? Please remove that and install the pfccom64.dll  driver.

I think you also need a registered version of FSUIPC7 - although not sure.... Do you not have a license? If not, try the trial one attached - just save it to your FSUIPC7 installation folder.

Also, please only attach files after you have exited FSUIPC7, not while it is still running.



Edited by John Dowson
key file removed
Link to comment
Share on other sites

8 minutes ago, Jeff Enlow said:

Ok I did both.

No you did not...

The PFCcom64.dll file should be in your FSUIPC7 installation folder, not in a sub-folder. it is not in the correct location....

It also looks like you have saved the FSUIPC7.key file as FSUIPC7.key.txt - please check and correct this, This is probably also related to your windows explorer settings which you should change...

Please also change your windows explorer settings to show the extensions of known file types. This will help you to identify your files when needed. This is explained both in the FSUIPC7 installation and registration manual and in the 'If you cannot see  the DLL...' text document under your PFCDLL folder.

Link to comment
Share on other sites

20 minutes ago, Jeff Enlow said:

Ok it appears to be connecting.


20 minutes ago, Jeff Enlow said:

No ailerons, elevators or throttle.

Any ideas on this issue?

No. Have you enabled and configured/calibrated these? Please read the PFC.dll documentation:


These pages are used to enable and calibrate the main flight controls, trims and steering tiller, if these are available and connected through the PFC system. These controls are not all enabled by default as they can produce unwanted interference with game port or USB connected joysticks and pedals if you are using those for any of the main flight control in Flight Sim. Only you know which devices you have connected where. There is no automatic way the driver can configure this.

Please ALWAYS check the documentation before posting. I do not have any PFC devices - any questions you ask I will just read the provided documentation for an answer. It will save us both time if you read the documentation before posting for support.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.