Jump to content
The simFlight Network Forums

Two Different VA ACARs Programs Not Seeing FSUIPC 6

Recommended Posts


I fly both P3Dv5.4 (whatever the latest iteration is) as well as MSFS 2020.  I fly them both regularly and haven't had any problems until this week.  All of a sudden I have two different VA ACARs programs that are not seeing that FSUIPC 6.20 is installed for P3Dv5.4.  One of them, for British Airways Virtual (their Merlin ACARs) sees the path for P3D but says "FSUIPC is not installed for this simulator".

I happened to have a backup installer from FSUIPC 6.19 so I tried uninstalling 6.20 and installing 6.19 but that hasn't helped.  Curiously, ACARS programs from other VAs don't have this problem and detect when P3Dv5 is running just fine.  I run both P3D and the ACARs programs in question as administrator but have also tried not running them as admin.

I have other things, such as vpilot, which work fine.  I can confirm as I write this that other ACARs programs as well as vpilot work fine.  I'm very confused.  Any help would be appreciated.

Link to comment
Share on other sites

If an FSUIPC client cannot connect, it is usually due to the client being ran at a different privilege level. But if that is not the cause, I cannot really help - you need to contact the support for the ACARS program.

You could try logging IPC Reads and Writes. Don't run any other FSUIPC client apps, and see if any activity is logged from the ACARS program.

Link to comment
Share on other sites

Forgive me for being dense but how do I get to the logging tab?  FSUIPC does not show up in the P3D Add-Ons menu.  There is no APP to run that I can find.  All there is in the FSUIPC6 folder is a .dll.

Also FYI, I just installed yet a 3RD ACARS program from another VA and it has the same problem.  It does not recognize when P3D is running.

Link to comment
Share on other sites

19 minutes ago, gollum65 said:

Also, I'm friends with the CEO of Globe Cargo, who is the person who developed their ACARs programs, and he has advised me that his ACARs program reported that it could not connect to FSUIPC.

Then ask him to look into this - its his program, not mine...

FSUIPC does not distinguish between client apps. If there is an issue with client apps not being able to connect, then I would look into this. But as this issue seems to be with specific ACARS programs only, there is no way I can look into this. You need the ACARS program developers to look into this. You did report that other ACARS programs are working, so this must be a problem with the program, and not FSUIPC.

And, as this was previously working, I suspect the issues lies in a change somewhere in your system, but I have no idea what this could be, if it is not privilege related.

This seems to be a common issue with ACARS programs, reported many times (check the forum), my answer is always the same.
I cannot help with client programs I know nothing about and don't have - you need to contact the developer. 

What ACARS program are you using? Is this free-ware or payware?

Link to comment
Share on other sites

Hi John.  I certainly understand that if some other developer's ACARs program isn't working right that it would be hard for you to even investigate.  If it was only one program, I would agree that it's gotta be the ACARs program.  But in this case I'm up to 3 different ACARs programs and none of them are seeing FSUIPC.  The programs in question are GCP from Globe Cargo, Merlin from British Airways Virtual, and VAS ACARs from the Virtual Airline System (there are 3 alliance VAs that all use this same program).

I did Windows tech support for many years.  I know a lot of "tricks of the trade".  One such trick I just tried.  It's very reliable.  I uninstalled FSUIPC 6, rebooted, deleted any folders left over, then installed FSUIPC 6.20 but changed the default install location to a location of my choosing.  This "trick" almost always works as it forces Windows to treat it as a new installation.  It did not work this time.  

Do you happen to have a version of FSUIPC 6 that is older than 6.19 that I can try?  Maybe that will fix it?

Thanks for your responses and support.

Link to comment
Share on other sites

But you do have an ACARS program that IS connecting. Why that one and not the others?

Have you tried asking the program developers/providers? And if the CEO has told you that his program cannot connect, has he not asked his team/developers to look into this?

I can provide other versions of FSUIPC6 but I do not think this will help, as you have already said that it was working with 6.1.9 but is no longer. And there has been no change to the FSUIPC SDK functionality, which all 3-party clients use, for many years. But if you let me know what version you want to try, I can build that for you.

There is really nothing else I can do about this. If this was a freeware program, I could download and see if it connects, but even then I cannot do much else. Please hassle your CEO friend about this, not me!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.