Emi

Flight Simulator has stopped working

22 posts in this topic

Gentleman,

 

I got a problem with FSUIPC. Since I had installed the Hotfix for Active Sky Next which had required me do download and install the latest FSUIPC Version I am getting random crashes in FSX which are all caused by FSUIPC according to the Windows Event Log.

 

I tried reverting to older FSUIPC versions as well as not flying with ASN, but I keept getting the crashes.

 

Here are two examples of the Event Logs from a random crash over Turkey (the first) and another one from where I am not exactly sure where in the PMDG777:

 

Problemsignatur
Problemereignisame:    APPCRASH
Application Name:    fsx.exe
Application Version:    10.0.61637.0
Application Timestamp:    46fadb14
Fault Module Name:    FSUIPC4.dll
Fault Module Version:    4.9.2.7
Fault Module Timestamp:    52b2cfd8
Exception Code:    c0000005
Exception Offset:    00013691
Betriebsystemversion:    6.1.7601.2.1.0.256.48
Gebietsschema-ID:    1031
 

Problemsignatur
Problemereignisame:    APPCRASH
Application Name:    fsx.exe
Application Version:    10.0.61637.0
Application Timestamp:    46fadb14
Fault Module Name:    FSUIPC4.dll
Fault Module Version:    4.9.2.7
Fault Module Timestamp:    52b2cfd8
Exception Code:    c0000005
Exception Offset:    00013691
Betriebsystemversion:    6.1.7601.2.1.0.256.48
Gebietsschema-ID:    1031

 

I even reverted back to the FSUIPC version which I had used before the trouble with the latest update began, but without luck.

I am out of ideas regarding this one.
Please help me resolving the crashes.

Best regards and a Happy New Year

Emanuel

0

Share this post


Link to post
Share on other sites

I have 4.297b installed, but it also happens with earlier versions of either FSUIPC or without ASN at all. Same problem with AS2012.

 

I have rightnow download the version 4.297e which Pete supplied in the other thread. I will report how it goes.

Edited by Emi
0

Share this post


Link to post
Share on other sites

After I installed the latest version of FSUIPC I am still getting the crashes.

 

I really need help now.

0

Share this post


Link to post
Share on other sites

FWIW, I also have been seeing FSX crashes with the fault module ID'd as FSUIPC.

 

I do not have ASN installed or P3DV2. I first noticed the crashes occuring when I installed 4.927b.

 

I've not been able to reproduce the crashes 'on demand' so haven't been able to devine what may be happening.

The only observation I have been able to make is that these crashes seem to occur when I am using the switches

on my dual Saitek throttle quads which are assigned via FSUIPC and also activate Lua scripts at times.

 

As a result, I have backed out to an earlier version ( 4.924a ) until I can run further test flights. At the moment I

have beta test obligations and online multiplayer mission flight obligations, neither of which can tolerate random crashing of FSX.

 

I've not added any new aircraft/scenery/add-ons since the system was last in a 'stable state' and the onset of the

random crashes.

 

Once I am able to do some further testing with version 4.927b I'll enable the logging and hopefully something will

show up there.

 

My OS is Win7 Pro X64.

 

   Paul

0

Share this post


Link to post
Share on other sites

Peter are you back from your holidays yet?

I need help!

 

Yes. I've answered the same question elsewhere already. I would like to see logs please -- FSUIPC4 log and Install log. Both with 4.927e. Please paste them into a message.

 

Then try setting  "InterceptTextMenu=No" in the [General] section of the INI file and let me know if that helps.

 

I think I also need to know if your FSX installation is the standard International/US version or a specific language version, as I'm a little concerned whether certain modules are different.  Perhaps you could right-click on the module API.DLL in the FSX folder and tell me its full version number?

 

Another contributing factor may be specific SimConnect using add-ons, so also please tell me the aircraft, and list other add-ons you are using.

 

I'm trying to determine why this appears to hit some folks so hard and others not at all. I can't make any such failure here.

 

Pete

0

Share this post


Link to post
Share on other sites

FWIW, I also have been seeing FSX crashes with the fault module ID'd as FSUIPC.

 

Not helpful without the error code and the module offset.

 

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

 

since I tried reinstalling FSUIPC and deleated all the logs I can right now not give you a log of the crash, but I will as soon as the Crash happens again tomorrow (and I am quite sure it will if I try a few flights).

 

Here is the rest of the data you requested:

API dll version: 10.0.61472.0 (fsx-sp2.20071210.2023)

Date of last change of the api.dll: 10.12.2007 21:30

I am using a German version of FSX. The crash happens with both, Acceleration Pack installed or Acceleration Pack not installed.

 

I will try changing that line and let you know tomorrow.

 

Another thing you should know:

Since I had to wait so long until you were back from the Holidays I have meanwhile tried a complete reinstallation of my whole operating system (Windows 7 Professional x64).

After the reinstallation the crashes were gone until I reinstalled the Hotfix for ASN.

Even completly uninstalling and deleating all remains of ASN does not solve the problem though.

Since the problem happens even after the reinstallation of Windows I am sure that it can be bought back to ASN's Hotfix.

 

My other Addons currently installed (I didn't install many of them after I reinstalled Windows) are:

FTX Global, FTX Global Vector, PMDG777, A2A C172, Realair BE60 Duke, FlyTampa Dubai, Mega Airport Düsseldorf, FSUIPC (Payware), ASN (Problems appear since the installation of Hotfix 1, before I isntalled the Hotfix the RTM version worked fine!), REX Texture Direct, FSInn, RealityXP GNS530, GNS430 & GNS WAAS Unlimited Pack.

0

Share this post


Link to post
Share on other sites
since I tried reinstalling FSUIPC and deleated all the logs I can right now not give you a log of the crash, but I will as soon as the Crash happens again tomorrow (and I am quite sure it will if I try a few flights).

 

I might have a test version to try before that which will give me more information.

 

API dll version: 10.0.61472.0 (fsx-sp2.20071210.2023)

Date of last change of the api.dll: 10.12.2007 21:30

 

 

Hmm. That should give no problems.

 

I will try changing that line and let you know tomorrow.

 

 

Thanks.

 

After the reinstallation the crashes were gone until I reinstalled the Hotfix for ASN.

 

Hmm. That's very very strange, as the location of the crash is not rleated to ASN at all, at least if you are using FSUIPC 4.927b which is the one with the full ASN fix.

 

I'm using ASN all the time with the hotfix installed.

 

I'll try to post a test version soon. I need more inforation and it should get it for me, I hope.

 

Pete

0

Share this post


Link to post
Share on other sites

Please download FSUIPC 4.927f and try it for me. I'm anxious to get to the bottom of this because I cannot reproduce it here.

 

Please add these lines to the [General] section of the FSUIPC.INI file:

 

Debug=Please

TestOptions=x8000

 

This version may not actually crash, but it may well get the same error -- I've tried to trap the error before the crash occurs so I can log the details instead. So after using 4.927f whether you get a crash or not, please paste the log here. If no crash, by all means carry on using it but show me the log after each session for a while, please. If the log is too big to paste here, ZIP it an email to petedowson@btconnect.com.

 

Once I know exactly why it is happening I'll fix it properly -- then you'd just need to remove those two added INI lines.

 

Thanks,

Pete

0

Share this post


Link to post
Share on other sites

Hello Pete,

 

the new file is installed now.

 

On the first 2:30 flight no crash happened. Currently I do more testing and I will let you know how this goes.

 

I searched the FSUIPC log of the last flight and couldn't find the line you looked for. I will report how that continues.

0

Share this post


Link to post
Share on other sites
On the first 2:30 flight no crash happened. Currently I do more testing and I will let you know how this goes.

 

I searched the FSUIPC log of the last flight and couldn't find the line you looked for. I will report how that continues.

 

Could you add the INI lines I mentioned above in my revised post above and show me the resulting log.  I think I know what is happening now but I need confirmation before I solidify the code.

 

Thanks!

Pete

0

Share this post


Link to post
Share on other sites

You got a mail ;)

 

Doesn't look like you would have got any crash in the short period you ran FS -- ony 4 minutes? Did you always get the crash in the first 4 minutes?

 

Anyway, with no crash averted there's no logging of the original possibly reason for it, so the log tells me nothing execpt you only flew for 4 minutes.

 

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

 

actually I had made a few restart attempts and didn't know that this would reset the log.

I will be doing a 15 hour flight tomorrow, thereafter you can expect a loooooooooooong log ;)

0

Share this post


Link to post
Share on other sites

Hi Pete,

 

since I have your new FSUIPC version you send me I am now getting hangs of my sim very often.

 

Since I use the PMDG777 in the beginning I thought these would be normal, but actually it should recover after a few minutes if it would be the known 777 bug. Since they do only sometimes recover even after 10 to 15 minutes and sometimes not at all I am almost sure it is related to your new FSUIPC version.

The log is to big to send it via E-Mail so here is the Dropbox link:

https://www.dropbox.com/s/snyhw8hssgl1lmf/FSUIPC4.log

 

More logs to follow later.

0

Share this post


Link to post
Share on other sites
since I have your new FSUIPC version you send me I am now getting hangs of my sim very often

 

Please STOP using the interim test version and remove that extra logging. I posted a fixed full update on Saturday morning -- 4.928 is the supported version now! you are out of date!

 

The log is to big to send it via E-Mail so here is the Dropbox link:

https://www.dropbox.com/s/snyhw8hssgl1lmf/FSUIPC4.log

 

 

I am amazed that so many folks have not heard of ZIP files -- even Windows explorer has the facility to zip files built in now. I did actually ask you to ZIP logs for email -- they are text files and would be quite small if Zipped!

 

Anyway, the log shows nothing wrong with FSUIPC. Your hangs are due to something else. Sorry.

 

More logs to follow later.

 

Please, no. Update your FSUIPC please.

 

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

 

after installing the latest FSUIPC version I just had a crash with FSUIPC4.dll as the reason again.

I have the FSUIPC log file from the crash, shall I send it to you again?

0

Share this post


Link to post
Share on other sites
after installing the latest FSUIPC version I just had a crash with FSUIPC4.dll as the reason again.

I have the FSUIPC log file from the crash, shall I send it to you again?

 

No. It should be short. Paste it here along with the crash details from the Windows event viewer.

 

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

 

apparently it is not really short. I have to admit I forgot to remove the two lines you told me above from my ini file and so it became a long one again. I am so sorry for this.

I have E-Mailed you the long log file.

 

And here is the Log from the Event Viewer:

 

Problemereignisame:    APPCRASH
Application Name:    fsx.exe
Application Version:    10.0.61472.0
Application Timestamp:    475e17d3
Fault Module Name:    FSUIPC4.dll
Fault Module Version:    4.9.2.8
Fault Module Timestamp:    52d1eec2
Exception Code:    c0000005
Exception Offset:    00013978
Betriebsystemversion:    6.1.7601.2.1.0.256.48
Gebietsschema-ID:    1031
 

0

Share this post


Link to post
Share on other sites

I have replied. You seem to have the wrong configuration. The log you sent shows no error whatsoever, the FSUIPC session finishes normally -- take a look!

 

The parameter "NewInterceptTextMenu" defaults to "No" in FSUIPC 4.928.

 

The testing period finished when I released 4.928. The original problem is fixed. The log you provide is not the one relating to whatever crash you had.

 

Pete

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now