Jump to content
The simFlight Network Forums

No Mouse Mixture Control


Recommended Posts

In FS9 with FSUIPC ver 3.50 installed I cannot control fuel mixture using the mouse on some airplanes. Some work ok. Never had this problem before. I can still control mixture using the keyboard but I have always used the mouse. When I remove ver. 3.50 from my system it works ok. I downloaded and installed ver 3.52 but have the same problem. Older versions caused me no problems at all. My Ch Flight Sim yoke does not have a mixture control which is why I have always used the mouse. Even on those planes where the mouse won't move the mixture control it will still move the throttle and prop controls. Any help will be appreciated.

Jim

Link to comment
Share on other sites

In FS9 with FSUIPC ver 3.50 installed I cannot control fuel mixture using the mouse on some airplanes. Some work ok. Never had this problem before. I can still control mixture using the keyboard but I have always used the mouse. When I remove ver. 3.50 from my system it works ok. I downloaded and installed ver 3.52 but have the same problem. Older versions caused me no problems at all.

Though everyone always blames FSUIPC for everything, there is really no way this module can possibly interfere with any mouse control over anything in FS. Even when I have been asked to do something with mouse contorls in FS I have found no way to do it.

You will have to look elsewhere. Sorry to disappoint you.

Regards,

Pete

Link to comment
Share on other sites

All I can say is that when FSUIPC is not on my system, the mouse controls the mixture ok. When it is on my system it works on some planes and not others. Doesn't matter if they are the default or not. I still have FS2002 on my computer and it works fine. There is something about the later versions that make it screw up. I have never had this problem before. Thanks.

Link to comment
Share on other sites

All I can say is that when FSUIPC is not on my system, the mouse controls the mixture ok. When it is on my system it works on some planes and not others. Doesn't matter if they are the default or not. I still have FS2002 on my computer and it works fine. There is something about the later versions that make it screw up. I have never had this problem before. Thanks.

Well, the only thing in FSUIPC which has anything to do with the mixture control is the jet reverser, in the Joysticks page. If you've calibrated that (i.e. pressed its "Set" button so that it now reads "Reset") then the main mixture control will be reset to be the Reverser -- on all aircraft, unless you checked the "jets only" (or whatever) checkbox.

Multi-engined props and turboprops will be using the separate engine mixture controls, so won't be affected. Only the single engined aircraft will.

If you don't know what you've been doing with FSUIPC's options and facilities just delete the FSUIPC.INI file so that everything is defaulted again.

This is not something that has been changed in the many years that the reverser facility has been available. it won't be an "old version" vs. "new versions" phenomenon. And it is exactly the same for FS2002 and FS2004 (and FS2000 for that matter).

Please, just delete the FSUIPC.INI file before loading FS. It sounds like you've done something in the joysticks section you simply don't remember.

Regards,

Pete

Link to comment
Share on other sites

OK Pete. I'll go through everything again to see what happens. What took me by surprise is that for a long time I've been flying planes that are either jet or if prop, the mixture worked ok. Then yesterday I tried to fly one I haven't flown for awhile and the mixture wouldn't adjust. Upon checking other planes with mixture controls some would work ok but others wouldn't. After trying everything I could think of, including changing mouse's (mice) the problem stayed the same. Just as a thought I deleted FSUIPC.dll and all was well. After reinstalling FSUIPC and not accessing it at all, the problem returned. That's why I assumed it was the cause of the problem. I have never blamed FSUIPC on any other problem I have encountered. Have been very satisfied with the program. Any way, I'll try again. Thanks.

Jim

Link to comment
Share on other sites

... I've been flying planes that are either jet or if prop, the mixture worked ok. Then yesterday I tried to fly one I haven't flown for awhile and the mixture wouldn't adjust. Upon checking other planes with mixture controls some would work ok but others wouldn't. ...

Well, there are 5 (five) reversers supported by FSUIPC, the main one which has been around since FS200o days, and four separate ones which were added more recently -- version 3.47 in April.

None of these are active by default. If they are selected (activated by pressing the SET button in their selection of the Joysticks options) then, by default they take over the relevant mixture axes (as documented). This assignment can be changed, in the INI file, of course. There is an option to make them active only if the loaded aircraft is a jet, so then they wouldn't interfere with props and turboprops.

It sounds likely that you have actually set the single reverser, as I mentioned. I suspect the aircraft for which the mouse could adjust the mixtures were multi-engined. If it was the other way around then this would indicate that the single (original) reverser is reset but the separate reversers are not.

This is easy enough to check, just by going to the appropriate Joysticks pages -- the Set button in the top left of each axis section reads "Set" if the axis is NOT being controlled/calibrated, but "Reset" if it is -- just press "Reset" to free them.

The alternative of deleting the FSUIPC.INI file just reverts all your FSUIPC settings to default, and is easier if you don't really understand all this. However, it does mean you'd have to go through each page selecting those options you really still want and, of course, re-calibrating any axes you really wanted FSUIPC to help with.

Regards,

Pete

Link to comment
Share on other sites

Hey Pete,

I went and deleted everything FSUIPC except the .key file and reinstalled.

Everything works ok now. I had already deleted it before checking the reversers so not sure if one was selected or not. I never have tried to do anything with the reversers so I'm not sure if that was the problem or not. I do know that of the planes that the mixture control work vs. the planes that did not-the default C172 worked but the default C182 did not and they are both single engines. Oh well, all is good now. Thanks for your help.

Jim

Link to comment
Share on other sites

Everything works ok now.

Good.

I do know that of the planes that the mixture control work vs. the planes that did not-the default C172 worked but the default C182 did not and they are both single engines.

Well, they most certainly both use the same single mixture control used by FSUIPC's original single reverser. It sounds like as well as setting the reverser you also did some things with the "aircraft specific" facility, which enables you to make completely separate settings for each aircraft. Each such individually-tailored aircraft data would have its own "Joysticks" parameter section in the FSUIPC.INI. It's an easy enough facility to use, just a check box to be clicked.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.