Jump to content
The simFlight Network Forums

FSUIPC not compatible with my FS2004 version?


Recommended Posts

Pete,

I just loaded 'ready for pushback' and now my FS2004 wont even load. I get 2 error windows: FS has potentially detected incompatible aircraft or software, File: FSSound.dll, and 'The version of FS2004 detected is not compatible with this version of FSUIPC. It is build 9.01.40901... the buid should be 9.00.30612.

Can you help? What's going on. Grrrr.

Thanks.

Link to comment
Share on other sites

I just loaded 'ready for pushback' and now my FS2004 wont even load. I get 2 error windows: FS has potentially detected incompatible aircraft or software, File: FSSound.dll

FSSound.dll is nothing to do with me, but I think it was made for FS2002 not FS2004. You may need to add something to the FS9.CFG file to tell FS2004 that it's okay. It sounds like you tried to install an add-on which is VERY old. Either that or it is badly put together. Doesn't it even tell you about this stuff in its documentation?

... and 'The version of FS2004 detected is not compatible with this version of FSUIPC. It is build 9.01.40901... the buid should be 9.00.30612.

The package has also installed a very old version of FSUIPC. The current one is 3.53. Just go to http://www.schiratti.com/dowson and get yourself the current version, which is compatible with the FS9.1 update to FS2004.

All versions of FSUIPC issued since the FS2004 update came out, 16 months ago, have been fine. You will need to take better care to install add-ons which are either up-to-date, or better able to support Microsoft's developments. If you purchased this one recently please write to the publishers/authors and make sure they know of your dissatisfaction.

Regards,

Pete

Link to comment
Share on other sites

Thanks for the help. Removed the FSSound, and installed your latest FSUIPC. Problems melted away.

Good.

Since then I checked a bit further. It appears that you can use FSSound in FS2004 if it is needed (I assume some Gauges use it to play extra sounds). To avoid the FS error report on start-up you have to add the following to the FS9.CFG file:

[OLDMODULES]

FSSOUND.DLL=1

but see if there's an "OLDMODULES" section already there first -- if so just add that second line. You'll find the FS9.CFG file in your Documents & Settings folder, under your user name then Application Data - Microsoft - FS9.

Regards

Pete

Link to comment
Share on other sites

Pete,

Thanks for the help. Removed the FSSound, and installed your latest FSUIPC. Problems melted away.

Thanks! :-)

hi there,

i have just had the same error message re : compatability and .dll. can you explain how you fixed it, am a little unsure how to by your previous explanattion

thanks

Link to comment
Share on other sites

Helo !

Chaps,

I deleted the FSsound altogether,

DAI

No no no !!

Keep FsSound, some panel and gauge need it: you'llnot be able to ear some sound (gauge clic, CPilot anouncement ..etc ..)

So retore back FsSound.dll in your module directory and ADD a

[OLDMODULES] section in your Fs9.cfg: (WITHOUT SPACE !!)

[OLDMODULES]

FSSOUND.DLL=1

Tey are many module like this ex:

SOARRec.dll FLTREC.dll etc ..

If you use them you'll have to add ex:

SOARRec.dll=1

FLTREC.dll=1

in the oldmodules section.

Happy landing !

Link to comment
Share on other sites

Helo !
Chaps,

I deleted the FSsound altogether,

DAI

No no no !!

Keep FsSound, some panel and gauge need it: you'llnot be able to ear some sound (gauge clic, CPilot anouncement ..etc ..)

So retore back FsSound.dll in your module directory and ADD a

[OLDMODULES] section in your Fs9.cfg: (WITHOUT SPACE !!)

[OLDMODULES]

FSSOUND.DLL=1

Tey are many module like this ex:

SOARRec.dll FLTREC.dll etc ..

If you use them you'll have to add ex:

SOARRec.dll=1

FLTREC.dll=1

in the oldmodules section.

Happy landing !

Hi,

thanks for the advice, i was trying to add [OLD MODULES] FSUCIP.dll but had a space. will try without - fingers crossed it works.

Also, should i be downloading FSUCIP 3.35 ?? Am hoping changing my FS9.cfg file will solve the problems

Link to comment
Share on other sites

Hi again

Also, should i be downloading FSUCIP 3.35 ?? Am hoping changing my FS9.cfg file will solve the problems

You're welcome.

Sure you can (have to) download the last FsUipc module. Since it don't seems to make major problems to any one .. when there's a problem Pete allways resolve it, and as far I can say I know him, he wouldn't go for vacation leaving behind him a bad version of his module ...

Also you don't have to add fsuipc.dll in tyour oldmodules section.

Happy landing !

Link to comment
Share on other sites

Hi again

Also, should i be downloading FSUCIP 3.35 ?? Am hoping changing my FS9.cfg file will solve the problems

You're welcome.

Sure you can (have to) download the last FsUipc module. Since it don't seems to make major problems to any one .. when there's a problem Pete allways resolve it, and as far I can say I know him, he wouldn't go for vacation leaving behind him a bad version of his module ...

Also you don't have to add fsuipc.dll in tyour oldmodules section.

Happy landing !

Ok cool, i did save it last night - it was a zipped file. do i need to save it in a particular folder for it to resolve the issue - sorry for what might seem elamentary questions.

mike.

Link to comment
Share on other sites

The MAAM DC3/C47 bundle is giving the same problem. If you do not install FSsound.dll but selected to not install the file as optional asked in the warning message you get when starting FS, you simply will not see all the gauges. It's mentioned in the manual :) .

And indeed it's solved with the additional item in FS9.CFG.

I think this applies to your problem too. So you better reinstall the FSsound.dll file and make the addition in your FS9.CFG file.

However.

There seem to be a new version of the FSSound dll file, v1.6 (beta ). Check at ftp://fssound.hn.org/FSSound/v1.6/FSSound160beta1.zip. This file too will cure the problem of the false warnings (with thanks to the MAAM team for supplying this information).

Grt.

Paul.

Link to comment
Share on other sites

Hi Mike,

Open the zip file and just copy and paste the FSUIPC.dll into your Modules folder. Of course answer Yes to the replace question. Then the whole zip folder can be deleted.

Even downloading and installing the newest version of FSUIPC (3.5.3.0 dated January 1th 2006) wil not cure the problem of getting the message.

The ONLY way is to modify your FS9.CFG file (as decribed above) or to delete the FSSound.dll completely (I know from my own experience!).

Paul.

Link to comment
Share on other sites

Hi again

Also, should i be downloading FSUCIP 3.35 ?? Am hoping changing my FS9.cfg file will solve the problems

You're welcome.

Sure you can (have to) download the last FsUipc module. Since it don't seems to make major problems to any one .. when there's a problem Pete allways resolve it, and as far I can say I know him, he wouldn't go for vacation leaving behind him a bad version of his module ...

Also you don't have to add fsuipc.dll in tyour oldmodules section.

Happy landing !

Hi there,

If i am also getting error messages saying " some aircraft might be missing ..... file CONTROLS.DLL " do i just need to add Controls.dll=1 to my [OLDMODULES] in FS9.cfg?

thanks again.

PS: will get eventually !!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.