Jump to content
The simFlight Network Forums

How to link an application with WideFs ?


Recommended Posts

Hi all,

I try to explain shortly:

I have some personal softwares wich are running very well with FSUIPC and FS9 when they are on the same computer.

If I try to use them on an other computer networked with the main one, they do not connect to FS thru WideFS.

WideFs server and client are connected, as shown by the messages in the caption of their respective windows.

Is there something special to do or to declare in the application software, other than an fsuipc_open, to establish the link ?

Best regards,

Robert

PS : must add that in the wideclient.log, the connection is "OKAY" and that fsuipc_open return a code : FS not running on the server ????

Link to comment
Share on other sites

I have some personal softwares wich are running very well with FSUIPC and FS9 when they are on the same computer.

If I try to use them on an other computer networked with the main one, they do not connect to FS thru WideFS.

WideFs server and client are connected, as shown by the messages in the caption of their respective windows.

Is there something special to do or to declare in the application software, other than an fsuipc_open, to establish the link ?

The FSUIPC interface provided by WideClient is identical to the one provided by FSUIPC directly. That's the whole point. So something else is wrong. Can you try again, then close FS and WideClient down, and show me the FSUIPC and WideServer Log files from the FS Modules folder, and the WideClient LOG file from the Client. If they are large, Zip them up and send them to petedowson@btconnect.com.

Regards,

Pete

Link to comment
Share on other sites

Hi Peter,

thanks for your help! You make me solve the problem...

I'm just beginning with widefs, so I did not had the reflex to look into the wideserver.log...

Of course, as I'm using XP, I have got a:

20093 ServerNode=13330.61389.0.0.512

20093 *** WARNING! *** This ServerNode is probably incorrect! Running IPXROUTE to get list ...

20093 IPXROUTE config >"C:\Program Files\Microsoft Games\Flight Simulator 9\MODULES\WideServer.ipx"

22125The correct value is probably one of these:

22125 ServerNode=2816.39274.5259.0.0 ("Connexion au r‚seau local 00000000")

22125 ServerNode=0.0.40660.21024.21313 ("NDISWANIPX")

I added a "servernode=2816......." in the config of wideclient.ini, and that works. Don't ask me why, but that works...

Thanks,

Robert

Link to comment
Share on other sites

Hi Peter,

thanks for your help! You make me solve the problem...

I added a "servernode=2816......." in the config of wideclient.ini, and that works. Don't ask me why, but that works...

Strange. The ServerNode is only needed with IPX/SPX protocol. By default WideFS would use TCP/IP.

Regards

Pete

Link to comment
Share on other sites

Ah... strange of course...

The only thing that was changed also, but I thought it had no importance, is that, for conveniance, I switched the computers: the server became client and the client became server... Could this have something to do?

The two are running the last versions of FSUIPC and WideFs, and the same version of FS9...

Regards,

Robert

Link to comment
Share on other sites

Ah... strange of course...

The only thing that was changed also, but I thought it had no importance, is that, for conveniance, I switched the computers: the server became client and the client became server... Could this have something to do?

If you were running with IPX/SPX protocol (i.e. had "UseTCPIP=No" in the INI file of the Client), then, yes, the ServerNode is unique to the specific hardware network hardware on the Server.

It would, of course, also matter if you had given the ServerName or ServerIPaddr in the INI, for TCP/IP protocol. This is not needed with WideFS 6.5x provided everything is running WinXP, because it can find out for itself.

WideServer does try to send out the ServerNode data, for IPX/SPX clients, but I have no way at present of determining the correct one on WinXP -- there always seems to be several. That part was actually better on Win98.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.