Jump to content
The simFlight Network Forums

Can't make WideFS work after computer meltdown

Recommended Posts


I had a major meltdown (power outage) which required a complete reinstall of all of Windows XP professional as well as all of my flight programs.

After I reinstalled all of the programs I can’t get WideFS to work. Before the meltdown everything worked great. All machines run Windows XP professional. I used WideFS mostly for Squawkbox

I can see, open and modify all of the computers on my network but no WideFS.

I have the latest release of FSUIPC and WideFS.

WideFS 6.70


Appreciate any help or suggestions you may have.

Link to comment
Share on other sites

Appreciate any help or suggestions you may have.

At first sight it looks like a firewall problem, which would affect WideFs but not Explorer. Try disabling WinXP's firewall (which is enabled by default since SP2), or at least giving permission for WideClient and FS9 to talk.

Otherwise, please show me the WideServer and WideClient LOG and INI files. They will contain the first pointers.


Link to comment
Share on other sites

********* WideClient Log [version 6.70] Class=FS98MAIN *********

Date (dmy): 18/08/06, Time 17:12:59.377: Client name is VAIO

530 Attempting to connect now

1532 Trying to locate server: Need details from Server Broadcast

1532 Failed to connect: waiting to try again

3575 Attempting to connect now

3935 ****** End of session performance summary ******

3935 Total time connected = 0 seconds

3935 Reception maximum: 0 frames/sec, 0 bytes/sec

3935 Transmission maximum: 0 frames/sec, 0 bytes/sec

3935 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

3935 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

Link to comment
Share on other sites

******** WideServer.DLL Log [version 6.70] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 17/08/06, Time 23:41:24.984: Server name is FLIGHT

18797 Initialising TCP/IP server

18797 Initialising IPX/SPX server

18797 ServerNode=0.0.4608.38167.23325

18797 Initialising UDP/IP server

20047 Broadcasting service every 1000 mSecs

26297 Closing down now ...

Memory managed: Offset records: 0 alloc, 0 free

Read buffer usage: 0 alloc, 0 free, max in session: 0

Write buffer usage: 0 alloc, 0 free, max in session: 0

Throughput maximum achieved: 0 frames/sec, 0 bytes/sec

Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec

********* Log file closed *********

PLEASE SEE the documentation for parameter details

; ==================================================












; -----------------------------------------------



; ===============================================

Link to comment
Share on other sites

Okay, the Logs show nothing but that the Client never ever sees a broadcast from the Server. With an all Win2000 or XP setup I think that's only possible if the PCs are on different subgroups (i.e. the subnet mask, often, when applied to the IP addresses of both PCs shows a difference) -- or there's a Firewall in the way.

I do have a dim recollection of someone else who had a problem with broadcasts -- it may be worth a search through this forum to see if you can find something.

Meanwhile, if you are sure your Firewall isn't in the way, you could avoid depending upon a Broadcast from the Server by using the normal Server and Protocol parameters in your Wideclient.INI.



I notice that you also have the IPX/SPX protocol installed on the Server:

18797 Initialising IPX/SPX server

18797 ServerNode=0.0.4608.38167.23325

Maybe you were using that before, thus getting around many of the TCP/IP restrictions? If so, and if you have IPX/SPX installed on the Client, try this in the Wideclient INI instead:






Link to comment
Share on other sites

Thank you so much! I changed the settings as suggested and it worked!!!


Just before you posted this I found the message here that I "dimly remembered", about why Broadcasts may not work. Here's the salient parts:

... the first problem was that the main computer was sitting behind a firewall that has SPI (stateful packet inspection). Unauthorized application socket connections not explicitely defined are dropped.

Secondly, the client and server are on different network subnets joined by a router and as everyone knows routers do not forward broadcast packets which WideFS uses for discovery (Duh!). Defining a static route directly to the server solved to problem. Most won't encounter this problem...but if you do ...

Do you know if any of this applies in your case? Else i'm rather mystified as to why the Broadcasts weren't seen by your Client.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.