Jump to content

Lost Flaps control, all aircraft go to full flaps?


Recommended Posts

Hi Pete,

Not sure what happened but my flap lever has been working great for several flights with my new FS9 sim. Now all planes go to full flaps whenever I move the flap lever? In your cal. tab everything checks out ok? I changed over to the flaps_set axis and still got the same result. According to the fsuipc software, the flaps should be working. I did just install the pmdg 737, any ideas where to look and what for?

Thanks,

Rob

Link to comment
Share on other sites

Not sure what happened but my flap lever has been working great for several flights with my new FS9 sim. Now all planes go to full flaps whenever I move the flap lever? In your cal. tab everything checks out ok? I changed over to the flaps_set axis and still got the same result. According to the fsuipc software, the flaps should be working. I did just install the pmdg 737, any ideas where to look and what for?

Just to be sure it isn't FSUIPC just temporarily reset the Flaps calibration there and operate them purely through the FS assignment. If that works, re-calibrate in FSUIPC.

I assume you are using FSUIPC 3.03? I don't suppose that installing the PMDG737 overwrote your FSUIPC INI file, did it?

You could also try, temporarily, removing PMDGoptions.DLL from the Modules folder, and checking the default aircraft again. Just in case it is somehow interfering.

Otherwise I really have no idea. What else have you changed since it worked okay?

Pete

Link to comment
Share on other sites

Pete,

I have version 3.3, I recalibrated again, removed the pmdg dll but still have the same issue. I did find out one thing though, in the cal. tab in fsuipc, the input shows from -16380 to 16380, ok, in the output window, whenever the number goes below 0, I get full flaps, which in my case is flaps10 setting. Without getting confused, flaps pos. 1,2,5 give full flaps, 10 puts the sim at flaps5 and from there on down it works. Again, only when fsuipc is outputting a positive value? As i said, it worked great for awhile then all of sudden changed?? Very strange, any other pmdg files that could be suspect? I also e-mailed them for ideas. Thanks Pete for your help.

Link to comment
Share on other sites

I have version 3.3, I recalibrated again, removed the pmdg dll but still have the same issue. I did find out one thing though, in the cal. tab in fsuipc, the input shows from -16380 to 16380, ok, in the output window, whenever the number goes below 0, I get full flaps

This is in FS2004 or FS2002?

In FS2004 the flaps control has changed so that -16384 = no flaps. 0 is the half-way point. This is different from FS2002.

As i said, it worked great for awhile then all of sudden changed?? Very strange, any other pmdg files that could be suspect? I also e-mailed them for ideas. Thanks Pete for your help.

It sounds like, somehow, you have the flaps in FS2004 behaving as if they are in FS2002. That's weird. Maybe I'll have to put in an option to allow the range 0-16384 in FS2004 like in FS2002?

Pete

Link to comment
Share on other sites

One more thing. You have tried calibrating it in FS2004 without FSUIPC being involved, haven't you? In other words, reset the FSUIPC setting so that it isn't getting involved at all (even temporarily remove FSUIPC.DLL just to be absolutely sure it isn't doing anything), and just using the FS assignment?

If it has the full range of flap settings, when calibrated there, then there really IS something going very funny in FSUIPC. Otherwise something else has changed it in FS.

Let me know please.

Pete

Link to comment
Share on other sites

Pete,

I disabled the flaps set in fsuipc, I reassigned to the flaps_axis in FS9. Now the flaps work ok except it skips 30. When I had it calibrated thru fsuipc it used to work in all positions. It looks like something has went crazy with-in fsuipc? Let me know if you need anything else. Thanks,

Rob

Link to comment
Share on other sites

It looks like something has went crazy with-in fsuipc? Let me know if you need anything else. Thanks

I don't think it could "go crazy" within FSUIPC without something being changed. Was there a change from, say 3.00 or 3.01 or 3.02 to 3.03?

I'll re-check them again here before I release 3.04, early this week -- look out for the update Monday or Tuesday.

Pete

Link to comment
Share on other sites

No sir, no change, a solid 5-7 hours of flying flawlessly with several takeoff and landings with working flaps. Only thing changed that I know of was the install of the pmdg 737. I really wish there was more I could give you to help out. There may not even be a problem except for some wierd issue with my computer and current set-up. I will triple check everything again.

Thanks,

Rob

Link to comment
Share on other sites

I just verified it is FSUIPC and not pmdg. I set control in the flap_axis and left fsuipc out of the loop and all worked ok except for not being calibrated. That is where I need fsuipc to help compensate for my flap lever. Hopefully that could be addressed in the next update? :)

Thanks,

Rob

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.