Jump to content
The simFlight Network Forums

FS9 WideFS server not communicating


Recommended Posts

Good day Pete and thanks for the great programs. I just registered FSUIPC and WideFS but I've spent several hours unable to get the 2 computers on the network to communicate with FS9. On the desktop with FS9 running it shows wideserver waiting for clients and on the laptop the connection keeps getting dropped. Both are running XP. I installed FSUIPC 3.98a version. Workgroup is the same = MSHOME and I tried to edit servername and protocol but I read another post which I think said this would not help, but I gave it a shot. I also shutdown both McAfee firewalls which didn't help. I think my problem is around the ip address but do not know how to correct it. Here is my log and ini files I hope you can shed some light on this problem. Regards Eric

; PLEASE SEE WideFS documentation for parameter details
; =====================================================

[Config]
Port=8002
Window=312,15,886,94
Visible=Yes
ButtonScanInterval=20
ClassInstance=0
NetworkTiming=5,1
MailslotTiming=2000,1000
PollInterval=2000
Port2=9002
ResponseTime=18
ApplicationDelay=0
TCPcoalesce=No
WaitForNewData=500
MaxSendQ=100
OnMaxSendQ=Log
NewSendScanTime=50
Priority=3,1,2
ServerName=raven1
Protocol=TCP

; -----------------------------------------------
[User]
Log=Errors+

; ===============================================

********* WideClient Log [version 6.78] Class=FS98MAIN *********
Date (dmy): 20/04/10, Time 22:39:41.986: Client name is ACERLAPTOP
     1812 Attempting to connect now
     1922 Trying TCP/IP host "raven1" port 8002 ...
     1922Okay, IP Address = 208.67.216.132
     2344 Connection made okay!
     2625 Connection closed by server!
     2625 Attempting to connect now
     2719 Connection made okay!
     2937 Connection closed by server!
     2937 Attempting to connect now
     3031 Connection made okay!
     3156 Connection closed by server!
     3156 Attempting to connect now
     3265 Connection made okay!
     3562 Connection closed by server!
     3562 Attempting to connect now
     3672 Connection made okay!
     4187 Connection closed by server!
    ......
    44812 Attempting to connect now
    67000 Trying TCP/IP host "raven1" port 8002 ...
    67000Okay, IP Address = 208.67.216.132
    67047 Connection made okay!
    67219 Connection closed by server!
    .....
   223594 ****** End of session performance summary ******
   223594 Total time connected = 68 seconds
   223594 Reception maximum:  0 frames/sec, 0 bytes/sec
   223594 Reception average whilst connected:  0 frames/sec, 0 bytes/sec
   223594 Transmission maximum:  3 frames/sec, 678 bytes/sec
   223594 Transmission average whilst connected:  3 frames/sec, 647 bytes/sec
   223594 Max receive buffer = 187, Max send depth = 1, Send frames lost = 0

   223594 ********* Log file closed (Buffers: MaxUsed 1, Alloc 420 Freed 420 Refused 0) *********

; PLEASE SEE the documentation for parameter details
; ==================================================

[Config]
Port=8002
AdvertiseService=1
AutoRestart=0
AutoUpdateTime=13
MaximumBlock=4096
NoStoppedRestarts=Yes
Port2=9002
RestartTime=10
SendTimeout=15
TCPcoalesce=No

; -----------------------------------------------
[User]
Log=Errors+

; ===============================================

********* WideServer.DLL Log [version 6.78] *********
Blocksize guide = 4096 (double allowed)
Date (dmy): 20/04/10, Time 22:38:48.051: Server name is RAVEN1
    40125 Initialising TCP/IP server
    40125 Initialising IPX/SPX server
    40141 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family
    40141 Failed to start IPX/SPX Server
    40141 Initialising UDP/IP server
    40360 Broadcasting service every 1000 mSecs
    52079 Restarting service due to total lack of use
    52079 Failed to start IPX/SPX Server
   284141 Closing down now ...
Memory managed:  Offset records: 0 alloc, 0 free
Read buffer usage:  0 alloc, 0 free, max in session: 0
Write buffer usage: 0 alloc, 0 free, max in session: 0
Throughput maximum achieved:  0 frames/sec, 0 bytes/sec
Throughput average achieved for complete session:  0 frames/sec, 0 bytes/sec
********* Log file closed *********

Link to comment
Share on other sites

Good day Pete and thanks for the great programs. I just registered FSUIPC and WideFS but I've spent several hours unable to get the 2 computers on the network to communicate with FS9. On the desktop with FS9 running it shows wideserver waiting for clients and on the laptop the connection keeps getting dropped. Both are running XP. I installed FSUIPC 3.98a version. Workgroup is the same = MSHOME and I tried to edit servername and protocol but I read another post which I think said this would not help, but I gave it a shot. I also shutdown both McAfee firewalls which didn't help. I think my problem is around the ip address but do not know how to correct it.

Yes, it looks like Windows is getting your server name "raven1" translated into the IP address " 208.67.216.132". Checking this via the Internet it appears to be an Internet address belonging to "OpenDNS" in California:

Tracing 208.67.216.132. please wait

208.67.216.132 IP address location & more:

IP address [?]: 208.67.216.132 [Whois] [Reverse IP]

IP country code: US

IP address country: ip address flag United States

IP address state: California

IP address city: San Francisco

IP postcode: 94105

IP address latitude: 37.7898

IP address longitude: -122.3942

ISP of this IP [?]: OpenDNS

Organization: OpenDNS

Host of this IP: [?]: hit-nxdomain.opendns.com

I've no idea why or how this happens -- it will be related to settings in your router. But the easiest way around it is to give WideClient the "ServerIPaddr" parameter instead of the Server name. Each of the PC's on your network will have it's own Local IP address, probably starting 192.168 or similar. Use that. If it isn't fixed, fix it to an IP address of your choice first. See this thread from a few days ago:

viewtopic.php?f=54&t=80033

Pete

Link to comment
Share on other sites

Hi Pete, thanks for the quick turnaround. Well I got the 2 computers talking now by specifying ip address 192.168.0.1 on the desktop and 192.168.0.2 on the laptop submask 255.255.255.0 on both and used the same ip address on the Preferred DNS. The client showed "connected" steadily and the Widerserver (top of FS bar recognized client 2). So all looks good in that aspect, but I cannot access the internet on either computers. Which means when I open Plan-G on the laptop it errors out saying internet explorer script error. That program then shuts down. I'm going to take a guess that I now have to do some dancing around with ip address in the router (Gigset SE567) but I have no idea on how to do this.

Do you have any idea (or any router gurus out there, I'd appreciate it) Also would a new log ini file help you at this stage? , Now I have had to reset properties to obtain add automatically in order to access this forum.

Regards

Eric

Link to comment
Share on other sites

Hi Pete, thanks for the quick turnaround. Well I got the 2 computers talking now by specifying ip address 192.168.0.1 on the desktop and 192.168.0.2 on the laptop submask 255.255.255.0 on both and used the same ip address on the Preferred DNS.

No, that's wrong. The Gateway and Preferred DNS fields on all your PCs should contain the IP address of your router -- the same IP address as you have to use to access it to set it up.

Regards

Pete

Link to comment
Share on other sites

Good day Pete. Well I finally got the problem solved. I asked a very computer skilled friend to have a look at my router connection. He was able to sort out the problem quite quickly and I asked him if he wouldn't mind doing a write up so that it may help others. Note that the week before I downloaded Widefs I had upgraded our internet service and a new modem was supplied. Here are his findings.

Quote:

A recent upgrade in speed included a new router and unfortunately our ISP (Telus) uses brain dead (poorly customized) ADSL modems.

I manage Eric's home network and prefer using OpenDNS (because they are faster than our ISPs). The old modem was set to use OpenDNS, and we setup the new one the same.

Unfortunately, the new router when configured to use an alternative DNS server (OpenDNS) , refused to resolve local DNS names (as assigned by DHCP) on the network.

The hard coded physical IP definitions didn’t work because they were done within the old modems address range (192.168.0.x), not the new modem range (192.168.1.x) .

The fix was to configure the Telus Router to ‘not use’ an alternative DNS server.

Hope this help… Unquote.

I've had a blast using your programs. Thank you for your help and for creating these superb applications,

Eric

Link to comment
Share on other sites

He was able to sort out the problem quite quickly and I asked him if he wouldn't mind doing a write up so that it may help others. Note that the week before I downloaded Widefs I had upgraded our internet service and a new modem was supplied. Here are his findings.

Thank you (and he) very much. It is nice to see how folks resolve problems.

I would try to put some sort of explanation into the WideFS documentation. Unfortunately, however, I don't really understand the explanation well enough -- except for the part where you had the fixed IP address range set differently, but wouldn't that have been obvious from the Router's own IP address, the one you need to use to configure it? I always assumed that all devices on the same LAN had to be using the same first three numbers (i.e. 192.168.1 instead of 192.168.0). The network "submask" (255.255.255.0) enforces this.

For now, till I find a way of explaining all thev DNS stuff that I understand, I will refer folks with similar problems to this thread.

Thanks!

Pete

Link to comment
Share on other sites

  • 1 month later...

Thanks for the response Peter. Ufortunately I was not ale to fix the issue. I put the serverIPaddr in the ini file and it still went to the other one for the connection.

I cannot find, in my router's setup area, where to change that DNS thing where it will not use an alt server. I have used the help option and went over all things. Other than dumping the network again and starting over, and probably having the same issue again, I have no idea what to do. Reading this network stuff is like trying to read Japanese for me.

Looks like I will not be using WideFS and ASE on the remote computer.

I really thought the IP command in the ini file would have fixed it.

Link to comment
Share on other sites

Thanks for the response Peter.

You are in a wrong thread here I think?

Ufortunately I was not ale to fix the issue. I put the serverIPaddr in the ini file and it still went to the other one for the connection.

It cannot do that. If you omit the Server name and only give the correct IP address, that's the only one it knows about. It cannot even try the incorrect IP address because it doesn't know it! It certainly does not invent IP addresses. You've made a mistake in the parameters.

Regards

Pete

Link to comment
Share on other sites

  • 1 year later...

Hi all. I too was having the issue where local PCs were having their IPs resolved to non local addresses. This is related to using OpenDNS as your DNS server. The resolution in the FAQ, which states that you shouldn't redirect your DNS servers was not acceptable to me as using OpenDNS is a vital part of my home network security. As it turns out, there's a much easier way to do this and it allows you to keep your router looking at OpenDNS for DNS resolution. Worked perfect for me.

Stacey

http://forums.opendns.com/comments.php?DiscussionID=3670

Here's the relevant post:

Everyone keeps saying to add a VPN typo exception. There is a better and much easier solution. Go into the advanced settings of your network and uncheck the "Enable Typo Correction" option under Domain Typos. Then go to the bottom of the page and hit "Apply". Wait about 30 seconds (possibly up to 3 minutes) and try to ping the same internal computer name as before and you should see the local IP address displayed once again.

Also, when you ping a name that is not resolvable, you will now get a "Ping request could not find..." error instead of it resolving anything and everything you try whether it exists or not.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.