Jump to content
The simFlight Network Forums

INI flie not installing fs9


Recommended Posts

I switched computers & put FS9, PMDG and unzipped FSUIPC onto the new computer with no problem. To begin with, I noticed there was no INI file in the modules folder, so I kept the old INI file & tried placing it in the "new" module's folder. I couldn't get any of my old joystick controls to work. I then deleted this INI file, went back to FS2004 & began reprograming only a few button presses. Everything programed nicely. When I went back to the modules folder, there was still no INI file located there. The only files in the modules folder are either DLL, text or key files.

There's really no problem except for the inconvenience of having to go back & reprogam everything over again, but I have two questions. Why isn't the INI file appearing & how can I get the old INI file to work again?

Thanks in advance for any help, Steve

Link to comment
Share on other sites

I switched computers & put FS9, PMDG and unzipped FSUIPC onto the new computer with no problem.

"Unzipped" FSUIPC? You should (must) run the Installer. FSUIPC isn't supplied on its own, except as an interim update.

To begin with, I noticed there was no INI file in the modules folder

There never is initially -- it generates the default settings.

so I kept the old INI file & tried placing it in the "new" module's folder. I couldn't get any of my old joystick controls to work.

I'm not surprised. I doubt if any of the joystick numbers are the same on a different computer!

I then deleted this INI file, went back to FS2004 & began reprograming only a few button presses. Everything programed nicely. When I went back to the modules folder, there was still no INI file located there. The only files in the modules folder are either DLL, text or key files.

This is because you are looking at an Aliassed folder, not the real one. You need to run the FSUIPC installer.

There's really no problem except for the inconvenience of having to go back & reprogam everything over again, but I have two questions. Why isn't the INI file appearing & how can I get the old INI file to work again?

Install FSUIPC using the supplied installer. You must be using 3.98 or later in any case, or I cannot support you. 3.98 is only supplied in an installer.

Please post to the Support Forum next time, not the FAQ subforum, where I found your post.

Regards

Pete

Link to comment
Share on other sites

I'll be a little more carefull next time about not posting in the FAQ section. Thank you

I've done this several times in the past years & it's always been so easy. This time around I can't figure out what I'm doing wrong on the install. I saved 3.98 to my desktop, clicked on unzipp then I clicked on install, the yellow & gray round globe. I get the text log, then confirmation, then a box prompting me to register. From there I add my information & key then open modules in FS2004 & there's my name & email along with 3.98 & a "thank you!". I thought from this point it was installed.

I'm following the instructions & think I've got everything. But Why am I not getting the INI file? Why would I be getting an alliased folder now? Sorry for the trouble, I know I'm missing something simple, this has worked too well, too easily in the past.

Thank you for your time, Steve

Link to comment
Share on other sites

I'm following the instructions & think I've got everything. But Why am I not getting the INI file?

What Windows version are you using? If it is Vista and you've not set FS9 to run in "XP compatibility mode", then the FSUIPC data files may be going to your Flight Simulator Files folder in your Documents folder, the same place as FS stores its data such as Plans and Flights. This would affect the FSUIPC LOG, INI and KEY files, which is why I'm a bit confused by your statement "The only files in the modules folder are either DLL, text or key files.".

There's really no problem except for the inconvenience of having to go back & reprogam everything over again

You don't have to do this every time you run FS? If you mean after changing PCs, this will be because Windows registers your devices with different numbers. If you unplugged them and plugged them in differently it would happen again. The best way out of this is to allow FSUIPC to keep track of them by using Letters for the devices, not numbers. Look up the Joy Letter facilities in the User Guide, and apply that.

[LATER]

It's occurred to me, perhaps rather late, that by "text" files you may actually be referring to the FSUIPC LOG file, which is a text file. By the same token the INI file is either a text or a configuration settings file -- according to Windows default classification.

If this is how you are seeing things, by Windows types not by the full filenames, it is because you have Explorer set to hide filetypes from you! Just stop it doing that annoying thing -- it's an option someplace in Folder Options.

Regards

Pete

Link to comment
Share on other sites

I'm now using windows 7.

I got out the old computer (XP), where everything is working fine & opened the fs9 modules folder. I sat this same computer down side by side next to the new computer & opened the modules folder there as well and compared which files were missing. The files that're missing from the new computer are:

FSUIPC Configuration setting file

FSUIPC Regestration entry

FSUIPC Text document

FSUIPC1 Text document

Oddly enough, I did a search on "FSUIPC INI" in the start menu & it shows the file sitting where it should be, in the FS9 modules folder. But when I click on it an error message tells me the file has been changed or moved. Also I went looking through all the fs9 folders earlier yesterday per the manual, but wasn't able to find anything there.

Thanks for your efforts, Steve

Link to comment
Share on other sites

The files that're missing from the new computer are:

FSUIPC Configuration setting file

FSUIPC Regestration entry

FSUIPC Text document

FSUIPC1 Text document

Those are FSUIPC.INI, FSUIPC.KEY, FSUIPC.LOG and FSUIPC.1.LOG respectively, as EXplorer would tell you if you changed that stupid option which hides filetypes from you! The FSUIPC.1.LOG file is only produced when you click "New Log" in the Logging tab. The old logs are saved with .n inserted, in order.

FSUIPC always makes those files and cannot run without doing so, so they are certainly on your system, and in the right place too.

If you are not seeing the same on the Windows 7 PC it is because you are looking at the Aliassed folder, not the real one. Windows 7, like Vista, protects all files in "Program Files" from user change -- this is why most folks are advised to install FS elsewhere, not in the default install location. FS9 is not aware of these things and wants to write to its own folders. Windows 7 recognises this and creates special folders which FS9 can see but you cannot, at least without bering an "elevated administrator".

Try running Explorer by right-clicking on the icon or the EXE and selecting "run as administrator". You should be able to see them then. They are there. It is simply the way Windows is protecting its system against you, the "untrustworthy" user. It's a right Royal pain. I always turn all User Account Control (UAC) off and always install FS in its own folders, like C:\FS9 -- or better, on a drive of its own. It performs better that way too.

Regards

Pete

Link to comment
Share on other sites

Try running Explorer by right-clicking on the icon or the EXE and selecting "run as administrator". You should be able to see them then. They are there. It is simply the way Windows is protecting its system against you, the "untrustworthy" user. It's a right Royal pain. I always turn all User Account Control (UAC) off and always install FS in its own folders, like C:\FS9 -- or better, on a drive of its own. It performs better that way too.

Regards

Pete

I tried right-clicking a couple of days ago, per the user manual, to try to run as administrator. It didn't work then and still doesn't. I remember a couple of years ago when installing on the old computer you told me to place fs9 in C:, it worked beautifully. This time around the new computer didn't seem to want to cooperate.

What I'm going to do is uninstall everything, It will take very litle time and effort & this time I'll be a bit more determined in getting fs9 into C:\

No need to respond, just want to say thank you very much for all your time!! Steve

Link to comment
Share on other sites

I tried right-clicking a couple of days ago, per the user manual, to try to run as administrator. It didn't work then and still doesn't.

Sorry, what exactly are you right-clicking, and where in what manual are you reading this?

I am suggesting that in order to view the REAL folders, not the aliassed ones, you need to run Windows Explorer in elevated administrator mode. There's nothing in any manuals I've had anything to do with which gives instructions for Windows Explorer! I think you are not reading what I am telling you. Please read a little more carefully!

I remember a couple of years ago when installing on the old computer you told me to place fs9 in C:, it worked beautifully. This time around the new computer didn't seem to want to cooperate.

You can install FS wherever you like. It's one of the options during installation. It hasn't changed just because you have a new computer.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.