Jump to content
The simFlight Network Forums

FSUIPC unlinked


Recommended Posts

Hello Peter.

My FSX had reverted to Demo mode[still is], and under advise from MS game support, I did a repair to FSX with the origional discs.

My FSX did work fine with many addons[cumulusX/winchX/Aicarriers etc] but just ran for apx 30mins.

That problem is still not solved, However;

In the process of fiddleing with FSX, it now comes up with this little window;

''FSUIPC Not Linked''

What does this mean, and How do I fix it please?

CumulusX still works with manual activation, but theres no indication of FSUIPC on the addon top menu of the game, and AI carriers do not work anymore.

Thanks,

Regards, Ken

Link to comment
Share on other sites

In the process of fiddleing with FSX, it now comes up with this little window;

''FSUIPC Not Linked''

What does this mean, and How do I fix it please?

I don't know what it means because it isn't an FSUIPC message. It sounds like something else needs FSUIPC and it isn't installed.

CumulusX still works with manual activation, but theres no indication of FSUIPC on the addon top menu of the game, and AI carriers do not work anymore.

I don't know CumulusX, nor AI Carriers. I don't think they would be anything to do with FSUIPC in any case.

Have you installed FSUIPC? If so, did it say it installed correctly?

Please check that

1. You are using a supported version of FSUIPC for FSX: version 4.60 or later. (There's a later version, and a later installer in the Download Links subforum).

2. There is a Modules folder in FSX, with an Install log file. Show me that Log file.

3. There is an FSUIPC4.LOG file. If there is not then FSUIPC4 has not run. If there is, show it to me please.

You can paste the text from the Log files into messages here.

Regards

Pete

Link to comment
Share on other sites

AICarriers is an external module that injects aircraft carriers into the sim and controls them, using pop-up dialogue boxes, Pete. It uses FSUIPC as an interface to inject the objects as AI, I believe?

I know that I had a problem with it a while ago that was solved by reinstalling a newer version of FSUIPC after another tool/add-on had installed an older version of the dll. That was a long time ago, though, and I can't remember specifics.

There are internal (dll) and external (exe) versions of it. Whether both use FSUIPC to interface I don't know.

Ian P.

Link to comment
Share on other sites

AICarriers is an external module that injects aircraft carriers into the sim and controls them, using pop-up dialogue boxes, Pete. It uses FSUIPC as an interface to inject the objects as AI, I believe?

No, FSUIPC contains no facilities to inject AI objects. The only facility vaguely sounding like that is the one to place multiplayer objects into the FSUIPC TCAS tables (not into FS) so they show up on TCAS gauges reading from FSUIPC. FSUIPC has never had any facilities for creating AI, or MP.

That program must be using SimConnect to create objects. The fact that FSUIPC apparently doesn't appear in the AddOns menu might indicate a broken SimConnect.

Regards

Pete

Link to comment
Share on other sites

Maybe it uses FSUIPC for something else? Just not to inject AI objects.

Regards

Pete

It apparently doesn't use FSUIPC at all any more, so whether the version I fixed was pre-2r2, or whether it was unrelated and just happened to be part of what I did, I'm not sure.

From the AICarriers2r2 manual:

- Main program :

used to interface with Flight Simulator through simconnect (No separate installation needed as this program does not use the Microsoft implementation of the simconnect library).

Which does make it look like Ken's problem may well be Simconnect related, as you say.

Ian P.

Link to comment
Share on other sites

Hello Peter & Ian.

All interesting reading.

Was not able to log on and reply [would log on and then drop out when returning to this section] when using work computers.

Here is the log file;

********* FSUIPC4, Version 4.60a by Pete Dowson *********

Reading options from "C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"

Trying to connect to SimConnect Acc/SP2 Oct07 ...

User Name=""

User Addr=""

FSUIPC4 not user registered

WIDEFS7 not user registered, or expired

Running inside FSX (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=0

625 System time = 19/01/2011 23:29:52

625 FLT UNC path = "C:\Documents and Settings\Ken\My Documents\Flight Simulator X Files\"

625 FS UNC path = "C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\"

1578 LogOptions=00000000 00000001

1593 SimConnect_Open succeeded: waiting to check version okay

5968 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

5968 Initialising SimConnect data requests now

5968 FSUIPC Menu entry added

6000 C:\Documents and Settings\Ken\My Documents\Flight Simulator X Files\Benson Gyro Mackay.FLT

6000 C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Rotorcraft\Benson\Benson.AIR

77218 Weather Mode now = Theme

118281 System time = 19/01/2011 23:31:50, Simulator time = 10:35:03 (01:35Z)

119296 Advanced Weather Interface Enabled

214796 Sim stopped: average frame rate for last 97 secs = 27.2 fps

240453 System time = 19/01/2011 23:33:52, Simulator time = 10:36:41 (01:36Z)

240453 *** FSUIPC log file being closed

Average frame rate for running time of 112 secs = 26.2 fps

Memory managed: 50 Allocs, 49 Freed

********* FSUIPC Log file closed ***********

I first used FSUIPC for gliding in FSX using Max Roodvelts gauges.

Yes it is a full version of FSX with sp2 added[no acceleration]

All was fine, except sometime it reverted to Demo mode[not sure why-and is still in demo mode]

I do not want to do a FSX reinstall, as it took me 3months partime to get it running well now with all the addons and 3rd praty programs.

Just the FSUIPC does not shiow up on the addon area now.

And as the game starts it comes up with this window--FSUIPC Not Linked. [see attachment]

Thanks Peter.

Regards, Ken

post-19441-0-71119800-1295663908_thumb.j

Edited by simbug
Link to comment
Share on other sites

Here is the log file

Yes, that shows FSUIPC4 is installed and running okay. It even proves that its menu entry is added too.

Yes it is a full version of FSX with sp2 added[no acceleration]

All was fine, except sometime it reverted to Demo mode[not sure why-and is still in demo mode]

FSX in demo mode? What does that look like?

Just the FSUIPC does not shiow up on the addon area now.

Where are you looking? What "addon area"? What's in the AddOns menu then?

SimConnect most certainly confirms it has added the menu entry. Mind you, if FSX is running in "demo mode" maybe it doesn't give you a full menu bar?

And as the game starts it comes up with this window--FSUIPC Not Linked. [see attachment]

That is not a message from FSUIPC. I've never seen it before. Something else you are running is doing that.

Regards

Pete

Link to comment
Share on other sites

Helo Peter.

''FSX in demo mode? What does that look like?''

The sim used to work normal, just stops after apx 1/2hr--says ''thank you for trialing demo''

see attachment

''Where are you looking? What "addon area"? What's in the AddOns menu then?''

On the top/right of the menu bar as the game is runnng.[to the right of HELP]

see attachment

''SimConnect most certainly confirms it has added the menu entry. Mind you, if FSX is running in "demo mode" maybe it doesn't give you a full menu bar?''

Well it all did work perfectly fine[except for thr 1/2hr limit]

But I made the mistake of following the MS support peoples idears of how to poss remove the 1/2hr limit--then it went bad.

They already proved I have a paid and regerested version--but it still has the 1/2hr time limit of a demo version.

Mind you, with all my addons and 3rd party programs, its about 20GB seize game now.

''That is not a message from FSUIPC. I've never seen it before. Something else you are running is doing that.''

Sounds about like my luck.

I always seem to get things happening that nobodys encountered before.

Probably because of my poor computer skills.

Unfortunally this forum only allows Very small attachments, so I can not show you much.''Used 17.73K of your 20K global upload quota (Max. single file size: 2.27K) ''

Can I e-mail you directly please?

Thanks Peter.

Regards, Ken

Link to comment
Share on other sites

Hi Ken,

I don't think that's an AICarriers message - it's certainly not one I've seen before and as I said earlier, I've broken AICarriers fairly regularly!

However it is fairly easy to work out whether any of WinchX, CumulusX or AICarriers are creating that message - all of them place a file in your FSX "modules" directory (the same place you'll find FSUIPC). Can you move CumulusX.dll and WinchX.dll out, temporarily, to another location (such as your desktop?), then run FSX and see if the message goes away?

I've just looked at the user manual for both and it appears that neither require FSUIPC to function directly - it's not listed in the requirements for either, at least. From this, I would presume they both use Simconnect - which would tie in with Pete's suggestion that this is primarily a Simconnect issue, but doesn't explain that error message. I do wish people writing dialogue boxes for Windows would put the name of their product in the title bar and the message in the window, rather than the message in the title bar and just buttons in the window. It really does make fault finding a lot more difficult. :angry:

Ian P.

Link to comment
Share on other sites

The sim used to work normal, just stops after apx 1/2hr--says ''thank you for trialing demo''

Oh, not so much a demo, the unregistered time limit. I see.

see attachment

No need to. Words are fine.

On the top/right of the menu bar as the game is runnng.[to the right of HELP]

And is there NO "AddOn" menu entry, or an empty one, or what?

see attachment

No need to, words are fine.

They already proved I have a paid and regerested version--but it still has the 1/2hr time limit of a demo version.

Mind you, with all my addons and 3rd party programs, its about 20GB seize game now.

Not sure what the size on disk has to do with it?

''That is not a message from FSUIPC. I've never seen it before. Something else you are running is doing that.''

Sounds about like my luck.

You need to employ a process of elimination. To start with, since FSUIPC most certainly is running and has confirmation back from SimConnect that the FSUIPC entry has been added to the "AddOns" menu, it sounds as if something is then managing to remove it.

When you run FSX are you also running other things, yourself, or is everything aslso automatically starting as well? If the former, try it without running anythnig else as well. If the latter, please find and showe me your EXE.XML and DLL.XML files and we'll try to work out what to eliminate. Those files are found in the same folder as your FSX.CFG file. You may not have an EXE.XML, but there will certainly be a DLL.XML file because that's needed to load FSUIPC.

If you don't know how to find these things, show me the FSUIPC Install log and I'll tell you where to find them. The install log is in the same place as the FSUIPC log you showed earlier.

Can I e-mail you directly please?

I really don't need pictures in any case. Don't worry about those. Descriptions are fine.

Regards

Pete

Link to comment
Share on other sites

Hello Peter & Ian.

Tried removing CumulusX and WinchX from the module folder, but made no difference.

I used to have in the addon menu;

FSUIPC

AICarriers

CumulusX

WnchX

AICarriers has now dissappeared, along with FSUIPC from the drop down addon menu.[it too may be still running, but I carn't get to it via the addon menu]

The glider gauges still work, so as you say, FSUIPC is still working, even though it does not appear in the addon menu.

If I manually start CumulusX and WinchX, they appear under the addon menu[as they should]--they actually used to start automatically, but do not now.

I made a new FSUIPC module folder with your latest dll, but also made no difference.

Still get that 'FSUIPC Not Linked' window showing up twice before game starts.[and twice more when I change view modes]

----------------------------------------------------------------------------------------------------------------

This is the XML dll;

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>CumulusXDll!</Name>

<Path>C:\Documents and Settings\Ken\Desktop\FSX Addons & Info\Stuff to Add to every NEW Re Install of FSX Jan2011\Cumulus X\Modules\CumulusX!\CumulusXDll.dll</Path>

<DllStartName>DLLStart</DllStartName>

<DllStopName>DLLStop</DllStopName>

</Launch.Addon>

<Launch.Addon>

<Name>FSUIPC 4</Name>

<Disabled>False</Disabled>

<Path>Modules\FSUIPC4.dll</Path>

</Launch.Addon>

</SimBase.Document>

----------------------------------------------------------------------------------------------------------------

This is the XML EXE file;

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>EXE.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>CumulusX!</Name>

<Path>C:\Documents and Settings\Ken\Desktop\FSX Addons & Info\Stuff to Add to every NEW Re Install of FSX Jan2011\Cumulus X\Modules\CumulusX!\CumulusX.exe</Path>

<CommandLine></CommandLine>

<NewConsole>True</NewConsole>

</Launch.Addon>

<Launch.Addon>

<Name>WinchX!</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>C:\Documents and Settings\Ken\Desktop\FSX Addons & Info\Stuff to Add to every NEW Re Install of FSX Jan2011\Modules\WinchX!\WinchX.exe</Path>

<CommandLine></CommandLine>

<NewConsole>True</NewConsole>

</Launch.Addon>

<Launch.Addon><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Name>AICarriers</Name><Path>C:\Program Files\AICarriers\aicarriers.exe</Path><CommandLine>-nogui</CommandLine></Launch.Addon></SimBase.Document>

Thanks,

Regards, Ken

Link to comment
Share on other sites

UPDATE__UPDATE

Hello Peter & Ian.

Success at last.

I just happen to have kept a copy of the XML EXE and XML dll when I was doing battle with the 30min Demo problem.[from 2 months ago]

I replaced the existing ones I sent you above, and all works well again.

Seems that CumulusX corruped the XML EXE when it askd me to confirm something about CumulusX in the XML EXE file.

CumulusX does not start automatically now[but thats a minor problem] WinchX does start automatically though.

FSX starts quicker [first time] if WinchX and CumulusX is in manual start mode anyway.[i'am only using a reasonable laptop--overheats the video card badly wihout an extra 3" cooling fan under the video card air inlet area.]

Thanks very much for your continious help with me.

By the way--Do you happen to know how to get my FSX out of the 30min Demo mode? [my origional problem]

Thanks,

Regards, Ken

Link to comment
Share on other sites

I just happen to have kept a copy of the XML EXE and XML dll when I was doing battle with the 30min Demo problem.[from 2 months ago]

I replaced the existing ones I sent you above, and all works well again.

Seems that CumulusX corruped the XML EXE when it askd me to confirm something about CumulusX in the XML EXE file.

Well as far as I can tell, in the files you pasted into the previous message, the only entry wrong was the AICarriers one in the EXE.XML, where this should be several lines, not all one:

<Launch.Addon><Disabled>False</Disabled><ManualLoad> False< /ManualLoad><Name>AICarriers</Name><Path>C:\Program Files\AICarriers\aicarriers.exe</Path><CommandLine>-nogui< /CommandLine></Launch.Addon>

should be something like

<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>AICarriers</Name>

<Path>C:\Program Files\AICarriers\aicarriers.exe</Path>

<CommandLine>-nogui</CommandLine>

</Launch.Addon>

You could insert that back if AICArriers isn't loading. Do it just before the last line (</SimBase.Document>).

CumulusX does not start automatically now[but thats a minor problem] WinchX does start automatically though.

The CumulusX pasrt of the EXE.XML is:

<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>CumulusX!</Name>

<Path>C:\Documents and Settings\Ken\Desktop\FSX Addons & Info\Stuff to Add to every NEW Re Install of FSX Jan2011\Cumulus X\Modules\CumulusX!\CumulusX.exe</Path>

<CommandLine></CommandLine>

<NewConsole>True</NewConsole>

</Launch.Addon>

so you could try inserting that back into your EXE.XML, at the end, just before the last line (</SimBase.Document>).

By the way--Do you happen to know how to get my FSX out of the 30min Demo mode? [my origional problem]

I thought it was simply a matter of entering your product key. I've not had to do that for years so I don't recall where it is done -- in the Help menu, maybe?

If not maybe a post in the FSX Forum will elicit an answer?

Regards

Pete

Link to comment
Share on other sites

Hello Peter.

Thanks for your help and time.

Hopefully I will not have any problems for quite some time now.

Except the Demo mode problem.

I did registor this FSX 5-6 months ago, but it seems during the addition of many addon aircraft and scenery's, it has reverted to Demo mode.[seems to be a common problem unfortunally]. The only cure seems to be re-install.

Which is not an option for me as I do not have the time or remember how to insatll a lot of stuff I installed in the last few months.

I was actually new to FSX then and was doing a lot of development work[new bush airstrips and texture improvements locally] & did not run FSX for very long and did not notice or realize when it reverted to demo mode.

I have tried many things to make it ask me to re-registor[usually a demo version asks at each start-up], but no luck so far.

After the last near loss/corrupt file session I think I will leave it as is[30min demo] in case I destroy many hours of work getting it running as I want it now.

Thanks again.

Regards, Ken

Link to comment
Share on other sites

There were a whole raft of problems regarding "lost" activations on systems that had previously been working fine, but it was a long time ago now and I can't remember the exact solution.

I do seem to remember that there was a thread on the Microsoft TechNet Knowledge Base about it. If I get chance later today, I'll have a look and see if I can find it. If not, it might be worth searching the forums at places like www.avsim.com and www.sim-outhouse.com as I know it was discussed at both, back when a lot of people were experiencing the problem.

Ian P.

Link to comment
Share on other sites

There were a whole raft of problems regarding "lost" activations on systems that had previously been working fine, but it was a long time ago now and I can't remember the exact solution.

I do seem to remember that there was a thread on the Microsoft TechNet Knowledge Base about it. If I get chance later today, I'll have a look and see if I can find it. If not, it might be worth searching the forums at places like www.avsim.com and www.sim-outhouse.com as I know it was discussed at both, back when a lot of people were experiencing the problem.

Ian P.

-----------------------------------------------------------------------------------------------------------

Thanks Ian.

I'am also still trying MS games support for somebody who is very uptodate with FSX files and problems.

Unfortunately they send me e-mails and phone calls that I do not seem to be able to reply to.

And I get a different person each time.

Makes for poor support.

Regards, Ken

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.