Jump to content
The simFlight Network Forums

4.85 + Loader + Mouselook = broken


Recommended Posts

I confirmed that after I went 4.85, the mouselook function is broken. I have mouselook on/off toggled with a spacebar, and since I updated to 4.85, it broken. After reverting to 4.83, problem disappeared.

If you don't use the optional loader Mouselook works fine for me with the FSUIPC controls "mouselook on" and "mouselook off" programmed to Space bar press, release (no repeats). I'm checking how the loader can mess that up now. Makes no sense to me.

[LATER]

Yes, I confirm that FSUIPC cannot see the MouseMove and Mouse Button messages when not loaded by SimConnect directly. I don't know why. I eliminated other addons from loading and it is still the same. I even eliminated the time delays (5 secs in the Loader, 3 in FSUIPC) before subclassing the FS window in order to get the messages, yet nothing allows those particular messages through. Very odd. It can see the MouseWheel messages and all the keyboard messages, so it makes no sense to me.

I'm looking to see if I can override this, but if I can't I'll just have to publish a warning not to use the optional Loader if you want to use FSUIPC's mouselook facilities.

BTW why did you opt to use the Loader? Just to try it, or to overcome some problem?

[LATER STILL]

No solution so far. I'll publish the warning.

Pete

Link to comment
Share on other sites

BTW why did you opt to use the Loader? Just to try it, or to overcome some problem?

Sometimes when I load FSX, I get a crash (error) while FSX is booting. It usually happens when I click somewhere else, eg. Firefox, while FSX is booting. Sometimes it's going to happen when I don't click somewhere else.

I was hoping the loader might be helpful with this, as I guessed it might be a Simconnect thing. It never happens on a clean FSX.

Link to comment
Share on other sites

Sometimes when I load FSX, I get a crash (error) while FSX is booting. It usually happens when I click somewhere else, eg. Firefox, while FSX is booting. Sometimes it's going to happen when I don't click somewhere else.

I was hoping the loader might be helpful with this, as I guessed it might be a Simconnect thing. It never happens on a clean FSX.

Try 4.85 or 4.851, rather, now, without the loader (just rename the loader and re-run the Installer). The other changes I made to FSUIPC4 initialisation may help. Let me know if it does.

The problem I've been trying to fix is really more related to the trust checking which once done for a new version is not done again unless you remove the "trust" entry in the FSX.CFG file.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.